Network connection problem


#1

Hi, i have two p4 computers running on xppro with onboard 1klans. i bought a cable with reverse wiring so i could connect them without a hub. I set up the ip adresses so they are identical except for the last digit(i was told it has to be 0 and 1 respectively) but i get a message that the network is disconnected. the strange thing is that if one computer restarts, the other one sees it, until xp load, as if there is an additional setting somewhere that prevents them from connecting. any ideas?


#2

It appears the conflict is with the IP settings…but generally Win XP informs abt it automatically. Its really strange that the connection goes dead after XP loads…anyways…
Well i dunno if u already got these done…but u might try if u havent :

  1. Keep the workgroup name same for both the PCs

  2. Instead of using the last digit(octet) of the IP address as 0 use 1

    eg: 1st PC- 192.168.1.1
    2nd PC- 192.168.1.2
    Subnet Mask(both PCs)- 255.255.255.0

  3. It wud be superfluos but still check the onboard LAN drivers and TCP/IP protocol, reinstall them if needed. Also “Client for Microsoft Network” should be installed(auto-installed by XP though)

  4. Finally if nothing helps try win XPs home networking wizard. More or less fool proof and can be done in a jiffy.

This is what I can think abt troubleshooting at the moment. But step 2 is all u need for the 2 comps to communicate…ofcourse u can enable filesharing etc as the need be.
All the Best:thumbsup:


#3

They should not be 0 and 1, but 1 and 2 or anything 1 through 254.


#4

i tried changing the last digits, checked and rechecked all the settings but nothing changed. the windows help is not that good in these cases. any other ideas?


#5

Well if it doesnt work…it can be any of the following things:

  • bad cable
  • bad network interface (NICs)/drivers
  • bad OS
    Check the cable on some other computers if u can…
    Try pinging the IP : 127.0.0.1 on each computer…this will check if the NIC is gud…and again if u can then try the NICs on some other computer.
    Finally if u think u can afford reinstalling the TCP/IP protocol or the OS itself…that might help…

Did u try the Network Setup Wizard?..its under Accessories > Communications


#6

I was inclined to believe that it was the network cable until you said that you can see it untill xp loads up. This leads me to believe that you have something running that’s causing this problem. Check for spyware, virus. and finally, do you have the xp firewall turned on?


#7

do you have the xp firewall turned on?
I reckon this is your problem. Disable any software firewalls on both machines and try pinging each machine then navigating to your shared folders.

You’ll probably need to setup the firewall to let the ip address of the machine through.

ta,
jbw


#8

Bummer…ya firewall …didnt think of it…that cud also be an issue…


#9

If its a Cat5 crossover cable, when the two machines are connected, the networking adaptor will be active (the PCI card should have a green light on). A crossover cable usually has Orange and Green wires switched on one end, so make sure its right. In XP, you shouldn’t have to mess with the protocols and all that junk, just the IP.

Otherwise the IPs need to be set to something like:

PC1
IP: 10.0.0.5
subnet:255.255.255.0
gateway: empty or 10.0.0.1
DNS: empty

PC2
IP: 10.0.0.6
subnet: 255.255.255.0
gateway:empty or 10.0.0.1
DNS: empty

You can use anything between 2-254 (0 = network, 1 = gateway depending on subnet mask)


#10

unfortunately its not the ip adresses, nor the firewall, i tweaked both, but nothing changed. since the computers “see” eachother before xp load, i know its not the cable either, but some service propably…


#11

You’ll need to install NWLink IPX/SPX/NetBIOS Compatible Transport Protocol. It’s the only way Windows Machine can identify each other using a computer name hash.


#12

What do you mean by “see each other before xp load”?

Do the lights on the NICs light up at all? If they don’t (lighting at Boot/POST only doesn’t count) and the Network Connections show the NIC as “disconnected” then its a physical cable problem because in XP, as long as theres a signal, the NIC is active. And in XP, you don’t need to install any crazy protocols.


#13

Make sure you have an account with the same user name and password on both machines.

videodv.


#14

ok, i tried all of the above and i have still the same problem. the funny thing is that when i shut down one computer, the otherone sees it for about 3 seconds… im a bit pissed off, as im in the middle of a project that needs constant file swapping between the 2 computers.
Anything else???
by the way, id like to get some info on network drives as i have no clue and would like to know if they are worth the investment(im thinking of a “standalone” hd, that can be accessed by both computers)


#15

Uninstall and re-install tcp/ip on both machines. It could be the stack got screwed up somewhere. If that doesn’t work it could be a bad nic or a bad jumper.


#16

I remember I have ever done this too. Same scenario, using a crossover cable to connect my desktop with my laptop.

so what I did last time is install the File and Printer Sharing for Microsoft Networks and choose Service on both machine … no IP settings. The 2 machines then can see each other, but slowed down the system startup and also slowed down whenever I expand My Network Places.

Don’t know whether this is the correct way to setup a crossover cable network. Coz a friend of mine told me recently that I should actually install Client for Microsoft Networks and not File and Printer Sharing for Microsoft Networks,and choose Service on computer A and Client on computer B.

You may want to try both and let us know.
But then, do you think crossover cable network can be used for network rendering )or network gaming)?

Anyone can advice on this?


#17

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.