Mutant Smoothing Groups / Normals in SILO Output


#1

Morning All–

I’ve been doing a work around on this item for years…and it is time to fix whatever it is that I must be doing wrong! My workflow often revolves around bringing in various architectural bits from drafting files (DWG etc)–grabbing components I need, cleaning them up, and finally outputting a .OBJ to Substance Painter for texturing. The final architectural model then goes to UNITY for some shaders, where it looks great, and finally to the Microsoft HoloLens for AR viewing.

I still love SILO and use it for all my modelling! :slight_smile: But I’ve had to resort to a quick auto-smoothing pass in 3dsMAX in recent times because something very wrong is happening upon output from SILO. Thoughts and suggestions will be incredibly helpful in eliminating the work around pass. Here’s pics:

This is what I see in SILO after cleaning a part up a bit. I might do more to clean up the placement of edges–but as you can see the geometry is clean:

If I then output this as OBJ / 3DS / FBX–I get something w. clobbered smoothing angles, like this:

As you can see, this terror is the same in both Substance and MAX–so its definitely the model…which looked FINE in SILO. I don’t believe it is the output that’s the problem…I think it is when I hard edit some geometry a fair bit.

My usual fix is to let MAX or UNITY do some autosmoothing upon input–and save out again if need be, but this is not optimal.

For instance, here it is RE-fixed in MAX.

What am I doing wrong? And how do I fix it.
Thanks so much everyone–this will help me hugely on my current workflow and projects.

Roger


#2

Does it look ok smooth shaded in silo?


#3

Hi Andy–

Nope.
Smooth shaded is a mess as well in SILO.

The “cleaned mesh” via autosmooth in MAX or 3DCoat …when re-imported looks fine back in SILO even in smooth shade. So, looks like its just smoothing groups that are getting clobbered.

Problem for me is–i don’t know how to set these in SILO when modelling from scratch–or even if there is an auto-smooth. What do you think.

THX!
R/.


#4

My first thing would be to check that the faces are planar.


#5

Thanks, Andy…I will test this up.

I didn’t realize that you were the gent w/ the awesome subdiv tuts!! Very fine work, and thanks so much–your work has helped me so much over the years!!

I’ve actually been wanting to review how to make perfect subdiv cylindrical holes lately…so need to find them once again.

thanks much–good day!
R/.


#6

Faces are indeed coplanar…And I even tried re-setting their scale to 0 just as a test…Still see messy smoothing groups in SMOOTH mode :frowning:

still see the weirdness. Could be a numerical issue due to import. Thoughts?


#7

Awesome is a bit of a stretch :]
Try the unify normals command at the end of the modify menu. It’s possible the odd face might be flipped?