Multi pass problem!



I have a big issue with my multi pass option. Usually I am rendering the image channels to be able to manipulate them afterwards in photoshop just the way I want to, but suddenly this afternoon I must have changed something, because now the multi pass works differently. Normally I save the image twice, one with layers and one without, just the final image. Afterwards I duplicate the channels to the final image and change the opacity of the global illumination and ambient occlusion passes for example. But suddenly, after I re rendered a scene, they behave differently, I must have changed something. When I opened the scene in photoshop and inserted the channels and tried to manipulate the global illumination pass it suddenly went all black when I turned it off. So I can’t change opacities or even turn off single passes without getting a black result on the image.

Additionally photoshop asked me to convert the colors to a different set when opening the file with the channels. What am I doing wrong? It really bothers me cause I can’t continue working on the file I’m currently working on…

Thanks and all the best,



I’m wondering why you aren’t saving your multi pass as 16 or 32 bit psd instead of 8 bit tiff.
You could also try to copy & paste everything into a new document and go from there.


Thats a good question, That was the setting I was taught to use by a colleague. would a 16 or 32 bit get better results?
I already did that a couple of times. The most confusing thing is that ever since the problem occurred, the file with the layers contains the layer “background”, as seen in the image attached. Before, when I was able to manipulate the single layers, it wasn’t there!


Also make sure the Specular layer is set to Linear Dodge (add).


>That was the setting I was taught to use by a colleague. would a 16 or 32 bit get better results? <
Yes you will get better results. Here’s a link to some info on the subject:


5 cookies says your destination colourspace is set to cmyk

Also, always render multipass in 16 bit


Thank you very much for your answers!

artdude: The Specular layer is set to linear dodge (add). Thank you for the link, that was really helpful! Didn’t know that about the settings yet, for the next one tomorrow I really have to change the bit settings!

imashination: I just double checked it, the color profile is set to sRGB in c4d and RGB in PS. I attach an image showing the message asking me to change the color profile. Unfortunately its in German, but the two color profiles are shown. Should just the multipass be in 16 bit or should the regular image be 16 bit as well?

I just tried to render the hole image with 16 bit for both the regular image and the multipass, but I ended up with the same problems as before. I will attach a few images so you can see what I mean.


A couple more things to try:

Delete/Remove Global Illumination from your render settings, then add it back in. You’ll have to re-do your settings.
Same thing in the Multi-pass list just for good measure, delete, add back in.

Also add in the RGBA Image pass to your Multi-Pass list.


By this, I assume you’re referring to image passed with RGB data?

My multipasses are entirely greyscale object buffers, and I’ve had good success with 8 bit PSDs; does 16 bit offer that much of a noticeable improvement in the greyscale edges?


With multipass, 16bit colour offers significant image quality improvements. an 8bit image is ok if you are rendering to srgb colour space as this is whats used by your screen. However multipass needs to use linear colour space to work correctly, and the conversion from linear colour to srgb screen colour space loses a lot of information. In a nutshell your dark gradients will start to band really badly or introduce graininess. Check this out, this is just a white sphere with an area light rendered in 8bit multipass. the banding is pretty bad even here.

OP: I don’t see any problem with your scene file? You are rendering an indoor room with an outdoor light. All layers will be black except for the area where the light can enter the window. the only layer with more data will be the GI layer with the bounced light. What are you expecting to happen here? Maybe a scene file would help.


I’m just super confused about the sudden change of behavior. I will attach two images how it reacted first, I was able to change the GI to like 45% opacity without getting a weird result. I understand the fact that its black because the hole light comes from the window, but why was it different at first and what caused the change?

with all the layers turned on:

GI turned



My first guess is you have no secondary GI pass, just a primary one. This way the 1 bounce of light can illuminate the right side but it needs a second bounce to reach the left side. My second comment though… your GI pass doesn’t look like GI. It is incredibly evenly lit, GI usually will fade out brightness as the surface gets further away from the light source.