MR strange artifacts


#1

As you can see in my rendering, there are some artifacts. I really have no idea where they come from. It looks like they are caustics in the worst quality :banghead:
But they are turned off!? Whats wrong with my settings? I know they are low, but even with high quality parameters it looks like this.

Please give me a hint. I’ll try everything
:cry:


#2

maybe because you are using a very low values in ALL your mentalray options !!
just increase your gi photons (( under global illumination rollout and under global light properties to something like 100000 )) and see if this change anything.
also later you will need to adjust the rest of your setting.

ps : you have nice gallery


#3

no. It takes longer and looks just as bad. OK…the position of the artifacts changed, but thats it. I just wonder because without those glasses (architectural material) it looks as good as it’s needed.

Thanx for the compliment :smiley:


#4

so , have you tried any other material , like the glass physics_phen material , btw how many light in your scene?


#5

Yes i did. I builded many different glasses with different mats, colors…lighted it seperatly with the same lights and it worked perfectly. Now in the complete scene everything is crap.
As light sources i used 1skylight with hdri texture and 3 mrAreaShadows 1mrSpotlight. :hmm:


#6

ok , my last guess is have you changed the value of luminace cd/mr in your glass architectural material ?


#7

hey decembermoon! Thanx a lot for your help :thumbsup:
Your last guess will be my last try. Then i will change my materials to some standard stuff.
If that won’t work, i will change my job. :argh: …or perhaps spent some time fixing it in Photoshop.

thanx again.

If someone knows the solution, please let me know.


#8

if it didn’t work (( sadly i know it won’t work )) just take a break and try again . :slight_smile:


#9

Looks like you’re using to few photons for your scene, with a large radius. How many are you using?
I also noticed you’re using a 1.75 decay value… any reason for that? The decay value only uses 3 values…

0 = no decay
1 = linear decay
2 = inverse square decay

I’m not sure how mental ray interprets float values for that particular parameter (maybe they’re just clamped), but I’d change that (I’m just anal on that kind of stuff… but that’s me)

Let me know about the photon values though… cheers!


#10

hey toonman!

welcome to my “mission impossible” thread. :smiley:
Now i know what you mean. During that screenshot i was mistaking the photons with the samples. But i already tried nearly everything.
Trust me, i will try everything, but tryieng everything takes time with MentalRay.

…once I’ve seen Jeff Patton in my “active user” list. As you can see…no response
I’m lost :cry:

I remember a experiment I’ve done about the decay thingy. Like you say. 0 results in no GI, 3 in completly overbrightness…and the inbetweens like 1,75.
Perhaps i will test this again :hmm:


#11

Ok. Tell me how many lights you’ve got in your scene, which type are they, and how many photons are emmiting each one. When doing test renders to try out different GI solutions, you might wanna turn off everything you DO NOT need (such as FG, for the time being, bring down the sampling values, lower your raytrace depth, etc). That’ll make test renders much faster. Lemme know when you have that info. Cheers!


#12

check your units and photon radius!
that is the start and key with any Mray scene
forget about final gather for the start (turn off)
see if your units (system and scene units) are ‘real life’ size
so 1 cm = 1 unit and your chair is about 60-90 cm high or something like that
if this is not the case : you will never be able to get a good setup with photons…

if it is the case : then you can set the radius of your photons with control.
give them something like 50-70 cm and just use 5000-10000 to start
this way you can see if you have a good start
fine tune the brightness and try to avoid photons from flying into the sky (blok them with invisible meshes)
then increase the amount of photons to something like 50000-100000 (maximum)
and give a little FGather (100-500 maximum)

if this kind of setup does not give you a good and quick rendering result… start over
cause then something is wrong with it (impossible to say what exactly without trying the scene myself…)

this workflow if setup in a good way will give you a fast and good result, speed would be comparable to scanline speed (if you do not use stuff like field of depth and such.)
and once you get 1 scene setup ok, you will be able to use that setup for other scenes in no time…

good luck


#13

hey guys
Thanx a lot for your support. Normaly I’m not that bad with all my MR experiments, but this XXXX kills me :banghead: (sorry usally I’m a nice one) :smiley:
My scene is “real life” size. There are just MR-Light’s with standard GI and energy settings and 1 Skylight with HDRI. The “architectural” glasses just has different colors/shiness/transulency, nothing special.

AH! In the camera settings I have the “druqs shader” enabled. Here’s the result:

I see colors

Just kidding
Again thanx a lot
From now on, i will compose my “best” tries in photoshop, and paint the missing parts.
Because this is for a game project I’m in a hurry. If someone is interssted, i can share the scene (except the girls, because they don’t belong to us) with you.
Perhaps you could play around with the settings. Even if it’s already too late for the project, I still would like to know what the :rolleyes: went wrong


#14

I’ve seen this problem before, but it was with either Brazil or VRay I think…

BTW, yes I’ve looked at this thread before, and I went off searching for the answer. There just wasn’t really any point in me responding when I didn’t have the answer at hand yet. If you can post or email the file (or part of it), I’ll be glad to take a look.

Jeff


#15

Have you tried adjusting the radius values? I had something like this once and a small radius made small circles show up. Worth a shot anyway.


#16

It really seems strange that these artifacts are only appearing near the bottles… perhaps there is something wrong with the shader they have… did you apply any photon shaders anywhere in your scene? And which camera shader is the one you’re using? (I had never heard of a “drugs shader”). When doing tests to troubleshoot stuff like this, I strongly suggest turning EVERYTHING off (except what you’re troubleshooting… in this case, GI). That would help a lot pinpoint the source of the problem. Let us know. Cheers!


#17

Have you tried taking one object out of the scene at a time? Like start with the bottles, does it render o.k. w/o them?

e.


#18

None, I’m pretty sure he was making a joke referencing using drugs and seeing funky colors everywhere. :slight_smile:


#19

I also did some radius experiments. But was unsure about the settings. Maybe that could have been a solution. Last night I increased all settings to “maximum” (13h rendering) and it looked even worst. :shrug:
So I was at the point to stop all experiments, and start photoshoping.

The scene should show a Bar with girls sitting there. They are drinking that strange, glowing stuff and fall besides her chair. So I have to paint over them too :banghead:

I will ask my bosses if I’m allowed to share that file. As I said…now it’s just for my educationell reasons. But i would be very thankfull if a pro could take a look at my photons.


#20

Just for giggles, can you try lowering your trace depth settings to 3?