MR caustics error


#1

Hi guys,

I’m trying to render a scene with MR and caustics.

When I hit Render it starts to calculate the photons and when it gets to 77% I start getting the following error msg:

RCGI 0.2 error 361053: no photons stored after emitting 1000000 photons (canceling emission job)

RCGI 0.2 warn 362004: no photons stored after emitting 10000 photons

until it reaches 100%.

Then the render isn’t coming out right.

What does that error means and how can I fix it?


#2

Very common problem. First, you can try sticking a sphere around your scene with flipped normals, just incase any photons are bouncing off with nowhere to go. Also, make sure that the material for your caustic-generating object has a value greater than zero for its specular level. I was ripping my hair out for weeks until I found out that that made a difference.

Good luck. :slight_smile:


#3

thanks for the quick answer.

I’ll try that later when i’m home!


#4

Also,
http://www.jeffpatton.net/MR-Caustics101.htm


#5

Hi jeff,
Great tutorial for beginers in caustics like me :slight_smile:
I still havn’t tried what Vormav suggesed, but since i see you’re deep into caustics, have you got anything to add about my error problem? perhaps another solution if the first one wont work?


#6

Whoa. Hey Jeff, I’m getting some really strange errors when trying to open your caustics scene. When I go to open it, it says that it’s missing the DLLs ParamEditor.gup and reactor.dlc.
I don’t have any idea what ParamEditor.gup is; no signs of it anywhere.
But when it comes to reactor.dlc, I’m quite confused. Not only is that file present in the proper place in my max directory, but according to the Plugin Manager, it’s loaded.

Are you using Max 7 already? If that’s it, I sorta would’ve thought that Max7 files would be more backwards-compatible.


#7

The reason you are getting this error is because photons from your light aren’t hitting anything. There are a couple of ways to fix this. An easy way to fix it is to move the light closer to the objects. You can also decrease the falloff of the light in the “Mental Ray Indirect Illumination” menu. Finally, you could increase the energy of the light. Depending on the size of your scene, don’t be afraid to make it frickin’ huge. I’ve had exterior architecture scenes where I’ve put it near 300,000.

Good luck


#8

I just setup my materials with the proper photon maps and don’t really encounter any problems with photons (caustic or GI). The inverted sphere is a good idea to keep a check on stray photons. The decay/energy/focus of the lights are important too (just as peakyfreak80 mentioned).

@-Vormav-: There’s two versions of the file at the bottom of that tutoral page. One for Max6, and one for Max7. Sounds like you downloaded the Max7 version.


#9

Ahh… Normally, you’d think the large, all upper-case font reading “MAX7 SCENE” would hint to that.
Looks like I need some sleep.


#10

Thank you all guys!

I did everything you suggested and now it’s working well.
Thanks alot.

See you soon…:wavey:


#11

Hey im having the exact same problem. I have tried everything that has been suggested in this thread. :shrug:


#12

Post a file, or at minimum some screen shots and setting details about your scene.


#13

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.