Mouse problems


I have scoured the internet to find a solution to my problem, but alas, I have found nothing. So hopefully someone can give me some insight into what is going on.

I recently bought a new laptop - MSI Dominator with the following specs:

  • Intel i7 4800MQ
  • 16 GB RAM
  • NVIDIA Geforce GTX 870M
  • Windows 8.1

I also recently bought a Razar Deathadder 2013.

Anyway, I installed Softimage 2013 and 2014. Everything was going fine until recently. When I open the explorer and try to select an object, when I click on said object it doesn’t select it, instead it opens a properties menu of that object (as if you had selected the object and the pressed enter) - whether it be a model, mesh, light, camera…etc. This happens in 2014 AND in 2013.

Sometimes this happens straight away after I’ve opened Softimage (and haven’t even loaded my scene file that I want to work on yet), and sometimes it happens only after a while of working. Closing and opening Softimage DOES NOT fix it. Only a restart will.

I thought the problem was specific to my Deathadder (as it is also giving strange problems with Windows), but I’ve plugged it into my desktop and it works with no problem, and I’ve also tried other mice on my laptop and they all give the same problem. So it is definitely got something to do with my laptop specifically.

The problem is that I don’t know whether it is Softimage which is giving the problem (which I kind of doubt because both 2013 and 2014 give the same problem), or a problem with my mouse/mice. I’ve updated everything I could possibly think of, but yet the problem still persists. The only thing I haven’t tried is reinstalling Softimage and formatting my laptop.

Softimage is the only program which acts strangely with the mouse.

Can anybody shed some light on what’s going on? Any suggestions?

Do you know how hard it is to work without being able to use the explorer properly?! :banghead:


The “Deathadder”? Ok… :stuck_out_tongue:

seriously, double-clicking an item in the explorer will open its property page.
So perhaps your gaming mouse software added something where holding down the mouse for a bit will make it double click?