motionbaker noob


#1

i’ve created a motion with the gravity plugin on letters of a logo.
i would like to put that motion into motionmixer, but it seems i have top bake the motion first(motionmixer has no effect on the gravity driven motion)
when i try to bake the motion, my logo letters go flying in all sorts of weird directions(up and in sideways)
i’ve experimented with the different motionbaker settings, none seem to work.
my animation only has the initial keyframe of the position of the letters.
will this work with gravity on?:shrug:


#2

Well, you could use MD_Scan to bake the motion of your objects, but I don’t think MD motions will work with MotionMixer. Have you tried baking other objects which don’t have gravity applied? It could be a case of plugins just not communicating with each other, in which case I’m not sure what to tell you. :hmm:


#3

it must be something i’m doing

i just tried to bake the motion in the scoutwalk scene included in lightwave.i baked the different objects seperatly and they immediatly shifted, almost like they were unparented(when i baked the head,it shifted to below the knees of the robot ect.)

so it’s probably not limited to the gravity plugin, i just don’t know what i’m doing:blush:


#4

Hmm…I see what you mean. That is odd. But that’s not really a relevant scene to test it on, since there are no bones, everything is FK, and there are no motion modifiers applied. So, basically, why would you want to bake the motion and do nothing but add extra keys?

For the heck of it, I tried using Motion Baker on the good ol’ cow.lwo with Texture Motion applied. Basically, what I did was make the cow a child of the null. Then I applied texture motion to the cow, then applied Motion Baker. It will default to baking the motion to extra channels (which will show up in the Graph Editor as “After IK”.) I ran a preview to do the baking, then turned off Texture Motion and Motion Baker. In the Graph Editor, I told the null to follow the motion of these extra baked channels, and everything worked perfectly.

FWIW, if you are trying to bake a scene with IK, you should check out BakeIKtoKey from DStorm. It’s super-simple to use and works very well. The one drawback is that it doesn’t work on objects that have Match Goal Orientation applied, but I think you can get around that by using Orient Constraints (not sure though, as I’ve never tried).

Hope this helps in some way…:hmm: Good luck!


#5

i’ll try your method
thanks GGG:p


#6

hmmm… didn’t have much success.
try baking something affected by gravity? I tried your method and it seems to bounce right out of the screen. :eek:


#7

oops…correction your method does work, i didn’t use the extra channels option.all i have to do after is disable gravity and nothing else then motionmixer will control it…whew thanks again:thumbsup:


#8

Not sure what the problem is…it worked fine for me. The only thing I can think of is to turn your bounce % down (in the Gravity Settings). Also, after you’ve baked the gravity, you’ll need to key your object at world 0,0,0 at the beginning of the scene since the motion that was baked to the extra channel is now going to be applied to the null which is the parent of the object. Otherwise, you’d be doubling the values of whatever your original key was…instead of your object falling from 10m, it’d now be falling from 20m.

Here’s my test scene (24k zip file). Maybe it’ll help? :shrug:


#9

Oh…ok, good. Glad you got it figured out. :slight_smile:


#10

i find i can do it without the null as well, just by copying the afterikY and pasting it to position Y.

i think my big problem was i parented the logo to a null and then scaled and moved it, so in the graph editor evrn when my first letter was at +5m the y position would read-7m, but the afterIKY would be +5…???I think when you scale something,it scales the motions as well. Now i’ve just scaled the other elements in my scene, and left the logo and everything seems to work fine.
i just bake copy and paste disable gravity and voila(pronounced walla:D )

pretty frustrating though!


#11

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.