Morpher shrinks object


#1

I’ve got an object that is morphing. It’s a fairly complicated object with a lot of morph targets in a single morph channel; twelve, not counting the base state.

Problem is, while it works perfectly fine in the scene where I’ve built it, if I import the object into another scene, suddenly it starts shrinking.

It starts doing this after it hits the first morph target. The first target is at 10%, the next is at 30%. It stops shrinking once it hits 30%. It completes the rest of the morph normally, as if it has always been that tiny size.

I’ve tried everything I can think of.

  • I’ve hit every object–base and targets–with Reset Xform and then applying a new Morpher modifier. I’ve also tried collapsing the modifier stack after doing this.
  • I’ve made sure that the pivot is at the same place in every mesh.
  • I’ve made sure that the objects won’t inherit scale from a parent object (despite not being parented to anything)

If I do an Extract Current State while it’s shrunk, the object that comes out is normal size.

What in Hades is going on, here?


#2

And if I save it in the scene where it’s messing up, then re-import it to the original scene, it works fine again.

Something about the scaling of the two scenes or something?


#3

is it possible to upload file at all ?


#4

I can, and I shall: https://www.dropbox.com/s/ldcu4sa7k1hmf2c/Morpher%20Grows.max?dl=0

For some reason, this version actually grows rather than shrinks, but regardless., it’s still changing size in ways it ought to not.

There’ll probably be a few issues with missing maps in the material, but that’s unimportant, really.

Thanks.


#5

so I just merged the object into a new scene, morphed to 100%…

works (2016)…what am i missing ?


#6

Well, I am using 2013, if that makes a difference.

Did you load the file without merging, as well?


#7

Opening the file: (I’m on cm, file is in Inches)

  1. adopt Inches…it grows
  2. don’t adopt inches, rescale instead…works

#8

That’s…odd.

Still, if it works, it works. I’ll try it.

Thanks.


#9

odd thing is, if I pretend i was already working in Inches…opening the file it wouldn’t ask me to adopt new scale…it grows, you would’ve thought it should be smooth sailing in this case !!!


#10

Yeah, I’ve noticed that.

Seems like, no matter what I set the system’s default scale to, it will always ask that adopt-new-scale query.
Been trying to figure that one out in order that MAX likes what I’ve told it.


#11

but I noticed your scales are 110.336 / 110.306 / 98.048

ideally they should have been all 100 ?


#12

Are they? Hrm.
I coulda sworn that I did a full-on reset of scales and all other transforms before I starting picking Morph targets, on the targets and the base object.

Weird.


#13

this is incredibly annoying…anyway, try this file.

https://1drv.ms/u/s!AvgNse7E8aayg20KALtpqLe6e3PR

Assuming you are in inches, if you open this file, the orig geo has the scale problem, while the one on the right I’ve fudged it so it does not…however, if you look closely in the morpher modifier, it has been restricted to min 15% and the XForm above it does the rest…

Not ideal, a dodgy fudge if i may say so…but so far that’s the only workaround I’ve found. (My hunch is at some point during morph targets creation, you’ve done some sort of of switcharoo between cm/in)