mia material x transparency issue


#1

Hello,

I looked around for a while to find a solution for an issue i have been having rendering some transparent windows of a building. i am using mental ray with physical sun and sky, and using mia material x for the walls and windows. the scene was rendering fine with all the transparency but after i UV mapped (in UV Layout) and textured the walls, it is no longer rendering the objects at the back through the transparent material of the windows. i can see the horizon and the sky only. i maxed out the raytracying in render setting (both quality and final gather).

any suggestion will be very helpful. thank you

I have attached a picture of the render

Tanzib


#2

It shouldn’t be too much work to isolate your issue. Have you tried rendering with lights other than physical sun and sky? You could also try applying (or re-applying) the glass preset to your windows mia_material_x, or even just try creating a new glass material altogether.


#3

Hi there,
Thank you for the reply. since my post i have applied a dielectric_material to the windows and the result is the same (but with a transparent normal Blinn works fine). the problem started to appear after i imported the building wall mesh as an obj file (I used UV Layout to edit the UV and imported the new UV-ed OBJ back in to maya). i do not know if it has something to do with normals. i did check them, seems to be pointing at the right direction.

i also created a new scene with new physical sun and sky for the same mesh. result was the same.

i had the same problem with the swimming pool.the water material would not render the base of the pool. i had to model the pool again and uv it inside of maya and it worked fine. problem is i do not want to re-model the building mesh.

thanks again for your reply

tanzib


#4

check visible in reflections/refractions on your mesh shape node.
Maya turn them off by default when importing obj (seems that we are still in 1995 :smiley: )


#5

Mate you just saved me!!

thanks a lot for your reply. It worked. visibility was turned off.

Grateful for your help

tanzib


#6

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.