Messiah <-> C4D workaround revisited


Here is better workaround than my previously posted one, less of a hassle with this method.

  • Setup your object(s) in C4D and launch messiah via the Dialog and successfully send your objects to messiah.
  • Save your messiah scene file and when asked to save the model do so, preferrably as a obj format. It should create an object folder.
  • Save you scene in C4D and close C4D.
  • Work standalone in messiah after that using the saved messiah scene file.
  • When you are ready to bring your finished work from messiah to C4D, open C4D and Launch messiah from the dialog.
  • Clear the scene in messiah if you need to.
  • Load the saved messiah scene in messiah, it will prompt you if you want to connect to the host, choose yes.
  • Your object should now appear in C4D.
    It works, just in a different way. I hope this helps.



Which version(s) of Cinema have you tried that with?

Thanks – that might help with something I’m working on right now :slight_smile:


I test this out in R8.5. I believe it will work as well in R9, from what I have heard back.



Cool… I haven’t gotten v9 yet, so that’s good news for me :slight_smile:



One more point.

If you already have setup your materials and stuff in C4D, independent of the messiah connection, save the file separately with no messiah tagged objects. Merge with the scene in C4D and drag and drop you materials to the “new” objects coming from messiah.



Thanks for the note… I hadn’t thought that far ahead yet. :slight_smile:


Thanks for the info, tjnyc !:thumbsup:

One question though: I always encounter crashes when I try to attach a bone (in messiah:animate/studio) to an object that is connected to Cinema4D. Even when I am using your method, C4D crashes as soon as I am trying to connect an object with bones. This crash doesn’t happen when I apply other effects (e.g. ‘Bloat’) to that object. Someone else encountered this problem ?

I’m using messiah:studio 2.0b and Cinema4D XL 8.5.


I don’t have that problem. Did you recently installed messiah 2?



I upgraded only recently from messiah:animate 5 to messiah:studio 2, but I had the problem of C4D crashing already with m:a. I guess the reason is my shortage of RAM (I have only a meagre 512 MB) which is not nough with two huge apps running.
Another strange thing I found out is that when I startup m:s from C4D, the objects from the last connection appear in messiah out of nowhere. This seems to be related to the Sketch & Toon module; that module creates some pref files at startup which causes a hiccup in the connection …

I think the best thing is probably to wait for Mark Wilson to port PointOven to C4D or, even better, if pmG drops the idea of a live connection altogether and creates their own stable interchange file format with reader plugins for all major apps.


The ghost scene is something I get as well. You just need to clear the scene in messiah.



They’d probably be better off adding FBX support than trying to roll their own, I think.

And I agree with you that it might be a better way to handle integration.


Agree. Though I think PointOven is the most likely alternative in the foreseeable future.


Well, one can hope, right? :slight_smile:


FBX format involves licensing costs and therefore might be out of reach in the moment. But in my opinion a very simple format like MDD for deformations and one format for motions should be enough. I just mentioned that pmG should develop their own format as NewTek might demand licensing fees for using MDD !?


True… it’s a shame that Kaydara/Alias are continuing to insist on charging for the FBX SDK :frowning:


does this work with messiah animate 4.0 ? and what plugins do you need to load into messiah and/or c4d to have this connection ?


This should work with Animate 4. You should read the Animate documentation on setting up the plugin.



this is animate 4 demo… can you actually rig in messiah and then export to c4d keeping the bones intact to animate ?


I don’t believe you can use the plugin for demo.


I figure everyone has seen the other thread: “Free MDD Reader for C4D.” But the newer posts here seem not to have looked at the free point importing plugin offered. Be sure to take a look. I tried it out and it seemed to work as advertised.