Mesh smooth looks messed up..


#1

Okay…heres the deal…I’m workin on my model, and the mesh is all nice and clean and smooth…then, I throw on meshsmooth, and the lines get all “wiggly” and what not, but it doesnt really mess up the mesh, unless one face happens to run into another…any ideas on how to fix this?!

Heres some pics to show ya what I mean…

Heres the unsmoothed mesh…

And the smooth vers…

From what I gater, it almost looks like a vert weight issue, but I’ve checked all the verts, and they dont have a weight assigned, or its very small (like, 1). Any ideas guys? I’m pullin my hair out here!


#2

Oh…one more thing…I’m using Max 6 :wink:


#3

Okay…this is really annoying…now the mesh is alll kinds of screwed up…this just happened after 2 edge extrudes (right in a row). I extruded the edge(s) and then went up to my symmetry modifier so see what it looked like, and it went all crazy on me…so I deleted the symmetry, and checked meshsmooth, and it was the same way…go into unsmoothed edit poly and it looks 100% fine…this is REALLY starting to annoy me LOL…i mean, its 4 am…wired off caffine and max decides to do this to me…bah LOL

here it is:

any ideas?
:cry: :cry:


#4

try using weights in the meshsmooth modifier


#5

Heya…yeah, I’ve tried that as well…thats another thing that seems to mess up lol But honestly, I dont know why you would have to use weights on a simple extrusion like that…really doesnt make any sense to me LOL:shrug:


#6

To obtain a good smoothing use a combination of smoothing groups, crease and vertex weights.


#7

and make sure the points are welded properly.


#8

Heya fellas…thanks for the suggestions…well, it seems as if it was a mesh issue somewhere along the line…dont know how though…but i deleted mesh smooth and deleted all the faces and rebuilt the area and it seems to work great…here’s a grab for ya:

Thanks again fellas!!


#9

Glad you solved it! Gibbz, and schwinnz just for the record, I would avoid using vertex weighting when modeling cars, it distorts your mesh which in turn distorts your reflections. Proper modeling technique eliminates the need for vertex weighting.:thumbsup:


#10

Aye, I’d have to agree there…as you can see by my model, there are still some issues to be dealt with…it looks fine, but the reflections do become distorted or out of “flow” with the rest of the model. Anyways, thanks for the comments fellas!:beer:


#11

Originally posted by Tbonz816
Glad you solved it! Gibbz, and schwinnz just for the record, I would avoid using vertex weighting when modeling cars, it distorts your mesh which in turn distorts your reflections. Proper modeling technique eliminates the need for vertex weighting.:thumbsup:

Yep ! :slight_smile:

I’m not a big fan of weighting myself but in extreme cases it can be useful :stuck_out_tongue:


#12

Hmmm you know…max 5 never had this issue LOL …Now its just getting worse…I have so many places now that are all screwed up…I dont get it…I mean, how can your mesh get all messed up from just a simple extrusion??? Gawd this is frustrating…any way to export the file so I can use it in max 5?! Cause I’d rather model it in there and then bring it back into max 6 to render…but I love some of the new additions to max 6 for modelling…dammit discreet…why cant you ever ever ever get a damn release to act correctly?! I mean, one vers has certain bugs, then the next release fixes the issues, but things that worked in the prev. vers now seem to be buggy?! Sheesh…I’m getting fustrated…I’m gonna take a breather for a while…thank god my puter is out at my 'rents house for the time being…the dang thing would prolly be out the window into the 2 feet of snow outside LOL Okay…maybe not really, but you know… Welp…now that I’ve completely rambled on about pointless and completely wasted about 15k of server space LOL

Any other suggestions? I’ve checked all the weights and such, and I’m in the process of remodeling the area, but its still acting very very goofy. hmph.

:cry: :hmm: :argh: :banghead:


#13

Stupyfied, I would tryremoving the meshsmooth modifier, converting it to a editable mesh, then converting back to e-poly. 1 time I had a similar problem-in max 5, and that rectified it for me, worth a try anyway, do it on a back-up copy of the file so you have your original just in case:beer:


#14

occasionally the meshsmooth modifier does get corrupted for me. happened in max 6 once and a couple times in max 5. Who knows w hy, but usually deleting meshsmooth and adding it again solves the problem for me.


#15

Hey, thanks for the suggestions, fellas…I’ll give it a shot when I get a chance, and let ya know how it goes! :smiley:


#16

Most of the times, this problem will happen when you change vertex/edge weight even for one of them and even 0.1

Weight will Use with both the NURMS subdivision option and the MeshSmooth modifier, so if you change just the weight of one the vertices/edges in editable mesh/poly and then extrude that polygon, it will change the weighs of new extruded polygons.
when you want to create a clean mesh/poly (like car), you must don’t change the weight of vertices/edges when you are doing the modeling, and when you finished modeling then you can change the weights But just a bit (I don’t recommend to use weight for some clean models or very low poly like car models at all)
Btw, you should know that if you convert a poly object to the mesh, the weights will not change

So do these works:

  1. Select all of the vertices of your object and then type number ’ 1 ’ for weight.
  2. Select all of the edges of your object and then type number 0 for crease and number 1 for weight.(This is different from vertex weight)

Hope this helps
Nima NF


#17

Hey guys, I figured out the problem!!! Ahhhh, another new bug in 3ds max 6

The problem is because of using “Connect Edge segment”! Sometimes When you use this for some models it will create some new edges with weight 0 not 1 .
So, It will mess your vertices…
To solve, as I said before, you should select all of the edges and set the weight to 1.

Now, where is my award? LOL :bounce:

Nima NF


#18

Heya, Nima, thanks for the suggestions, bud! :slight_smile: Thing is, is that I believe i’ve double checked all my vert wieghts just to be sure…I’m not 100 percent positive though…I’ll have to check when I get my puter back (Its still out at my 'rents house…dont ask LOL). That, and I’ve never used that “connect edge segment” that your speaking of… Anyways, I’ll keep that in mind when I go to take a look at it. But from what I can remember, I believe I’ve allready restarted the front facia, but its still acting all messed up. Bah. LOL I’ll update you guys when I get a chance to take a look at it. I’m going through withdraw symptoms here, and I need to get my 'box back :(:cry:


#19

You said:" I’ve double checked all my vert weights just to be sure… " !!!
But Did you checked all your edge weights ??

“Stupeyfied” you should know vertex weight is different from edge weight.
btw, sometimes this problem will happen when you use “cut” or " Extrude" not only when you use “connect edge segment”.

So check edges weights too…
For several time, I had the same problems as yours last week (Exactly like both of your problems) and they were because of edges weight not vertices weight…

Cheers
Nima NF


#20

Does it happen if you delete the symetry modifier and meshsmooth half of it? Try making a copy of the object after deleting all of the modifiers in the stack, then apply your mods and see what happens-just a suggestion. I use all of the tools Nima mentioned and haven’t had the same situation arise so far in 6.:beer: