mentalray out of memory?


i have a large scene render with maya 7 mentalray , maya tell me mentalray out of menmory.but my machine is 2g memory . i find that some of memory have not used.
anyone can help me,why this happen


Are you sure you’ve set your max memory correctly in your render globals?


Hi Leigh,

Can you explain a bit more about this please? I’m very curious of how to do it efficiently…




Under the Mental Ray tab in the Render Global’s is a section called Memory and Performance. Open the drop down menu and you should see another drop down called Memory Limit with a option that is called Physical Memory.

Change that number to about half your Ram…soo for you put in 1000. Or you can even put in a higher number, but not to high b/c then ther will be no ram left for other tasks and programs will start crashing.

I have mine set at 1200, wich renders all my heavy scenes without MR loosing memory and aborting.

I hope this all helps :buttrock:


Thank you very much, Daniel…

I’ll try that…

And pardon me, is that just the memory MR use, excluding the ram maya took to run?


Yeah that’s the render RAM limit. You should make sure you don’t set it to use all the RAM in your system because your computer is using RAM for other stuff, including just running Maya’s shell.
My computer has 3Gb RAM and I set my MR limit to 2Gb.


running out of memory is probably the most common cause of what appears on the face of it to be arbitrary crashes and figuring out how you can minimise this is probably the single most productive thing you can do for yourself if you render using mental ray. Increasing max memory is one approach but it’s a bit brute force and you could be missing some tricks. Generally speaking, reducing memory footprint will speed up render times.

Aside from the obvious geometry and image size, looking at the mr BSP settings may help you reduce frame times and memory quite considerably. The method is simple enough; take the first parameter, move it up or down. If render time increases, move it the other, if it decreases, move it more. Keep going until the render time levels off. Now take the second parameter and repeat. incremental values of 5 or so are more than accurate.

You don’t have to do this on a full frame or with full anti-aliasing either, it’s directly up-scaleable so select a small, representable region and crank the AA down way low.

If you want to know more about mr optimisation and anti-aliasing I’d recomend Dave Lajoie’s excelent white paper. But you’ll maybe have to be nice to Softimage. :wink:


I would suggest to use Large BSP, after changing the amount of RAM.And then follow what kimaldis said.Also check this link, you will find some nice info about Maya and Mentalray specific.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.