Mental Ray


#1

Im trying to use the mental ray and it reads in the command line: //Info (Mayatomr):Aborted //

Then in the Output window it reads:
mental ray for Maya 6
mental ray: version 3.3.1, 12 Mar 2004
LINK 0.0 error 191007: cannot load <INSTALLDIR>/mentalray/lib/base.dll, The specified module could not be found.
LINK 0.0 error 191007: cannot load <INSTALLDIR>/mentalray/lib/physics.dll, The specified module could not be found.
LINK 0.0 error 191007: cannot load <INSTALLDIR>/mentalray/lib/mayabase.dll, The specified module could not be found.
LINK 0.0 error 191007: cannot load <INSTALLDIR>/mentalray/lib/contour.dll, The specified module could not be found.
MI 0.0 error 121417: E:/Program Files/Alias/Maya6.0/mentalray/maya.rayrc, line 29: cannot find $include file “<INSTALLDIR>/mentalray/include/contour.mi”

What should I do and could anyone please help? Thanks.

Michael


#2

And are those files there? Have you modified your rayrc file?


#3

The script editor is showing you the directories to look in and what to look for. It’s telling you what it cant find. You need to follow those directory paths first and see if those files really are not there.

So first follow the paths it’s showing you, and check for your self. Tell us the results.


#4

Yes, I have all 5 of those files still. They are named with the extension of .mi though. Does that matter? Or should they all be .dll files?


#5

Whoops, sorry. I also have the .dll files. So i dont know what the problem can be.


#6

I’m not sure what the problem could be but isn’t E the default letter assigned to all CD/DVD optical drives in Windows? I wonder how it wound up there? :shrug:


#7

Here is a thought. Are you using windows? If not those DLL’s are not compatible with your OS.


#8

“E:/Program Files…” would indicate he is using windows, if he was using linux or something else it would show his mount partition.


#9

I´ve had the same problem. The only way i´ve found to solve it is to edit the maya.rayrc and replace the following :

  • registry “{MAYABASE}” value “<INSTALLDIR>/mentalray” end registry

with (in your case)

  • registry “{MAYABASE}” value “E:/Program Files/Alias/Maya6.0/mentalray” end registry

I don´t know why, but it seems that it won´t assign <INSTALLDIR> to the actual Maya instaltion path. So you have to replace <INSTALLDIR> with your instaltion full path.
Hope this helps.


#10

I am using windows, And I am going to try your advice xxano! Thanks and I hope it works.


#11

Are you suppose to type - regisrty in the command line in Maya, cause if so it says Error: Syntax error. And If I try typing it in the “run” command nothing happens.


#12

Okay, I thought I had it and had it figured out, But apparently I dont. Now the script editor reads the following,:

file -f -new;
// Result: ./untitled //
docServer(1);
updateRendererUI;
// mental ray for Maya 6
// mental ray for Maya: using startup file E:/Program Files/Alias/Maya6.0/mentalray/maya.rayrc
// mental ray for Maya: setup
// mental ray for Maya: initialize
// mental ray for Maya: using 1 license
// mental ray for Maya: register extensions
// mental ray Node Factory: loaded
// generating nodes …
// parsing E:/Program Files/Alias/Maya6.0/mentalray/include/base.mi
// generating nodes …
// parsing E:/Program Files/Alias/Maya6.0/mentalray/include/contour.mi
// generating nodes …
// parsing E:/Program Files/Alias/Maya6.0/mentalray/include/physics.mi
// mental ray for Maya: successfully registered
updateRendererUI;
// Error: (Mayatomr.Export) : mental ray startup failed with errors //
// Info (Mayatomr): Aborted //

What can I try to do now, Thanks for the help thus far!!!


#13

i think the best solution is to reinstall Maya using your c: drive instead of E::shrug:


#14

wouldn’t it just be quicker to reinstall Maya so that you may rule out a bad installation?


#15

Yes I should try to re-install it. OMG! I tried to unistall it and I get about half way and then an error comes up that reads, " Error 1713.Maya 6.0 cannot install one of its requiured products. Contact your technical support group." What should or could I do? I tried calling, but no one could help cause i didnt pay for some esupport, blah, blah, blah.


#16

Sorry for the delay 3DRenderer, i´ve been way for a few days.
About the " - registry", you must not type the " -", anyway you stiil can´t put it to work!
You won´t be able to unistall it, at least not as you usually do! (I´ve tried almost everything i´d remember, and i couldn´t!).
The work around, it worked for me, is to repair the instalation, but still, you will have to changed the maya.rayrc just like Í mentioned in the previous post.

I had the same probs you´re having, the only diference was that I had it instaled on drive C.
I repaired the instalation ( I couldn´t uninstall it or change the intall directory), and then changed the maya.rayrc according to my intall directory!
I hope this helps!

P.S. You could also try to force Maya to unload mayatomr, and then load it back! Some times it helps


#17

xxano - thanks for your help on this subject. I searched other forums and came up with lots of unhelpful sarcasm but you delivered the necessary information! Thank you!

I’m using 6.01. It was installed on win2k pro and then I changed to xp and reinstalled maya and the 6.01 update. I think this thread was last current before 6.01. Anyway I got the error and am wondering if there is any new info as to why this occurs. I thought perhaps it had to do with two maya directories existing 6.0 and 6.01 and possible bug there.

Anyway - mental ray is working thanks to you - if you have any more info on the problem or know if alias has done anything to correct it that would be great :slight_smile:


#18

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.