Mental Ray - Render Troubleshooting



@danielw74: try the blur offset to 0,001 and premultiply alpha to off.

@BigPixolin: my bo_photostudio make no problem and use glare, distortion an other lens shader. I think it is a bug from the new framebuffer.

hot chip


ok… i found the problem. for some reason i had refractions off in the render. so when on it works. So cutout needs refractions to be on to work correctly? :hmm:

– cheers!


nope. it’s a 3dsmax ‘design’ bug.

you don’t even need raytracing to be ON to get cutout maps to work.

the point is that the ‘refraction’ parameter, in mentalray, controls both ‘refraction’ and ‘transparency’. so if you turn it ‘off’ , also transparency depth will be set to zero. transparency don’t need ray tracing.

for example, try to switch off raytracing leaving the refraction on. cutouts are ok.
now the same, switch off raytracing but before siwtch off also refraction. cutout black lines.



thanks for clarifying that problem … :beer:

over and out…


Hi everyone,

I’ve never used mental ray before, and I need to improve my lighting skills. Someone suggested this tutorial for lighting outdoor scenes in mental ray:

My problem is that it tells me to create a daylight system and change the “sunlight” and “skylight” to “mr sun” and “mr sky”, but those options don’t show up in the dropdown menu – I only get “standard” and “ies”.
However, when I go to Create -> Lights, I can create “mr area omni” and “mr area spot”.

What am I missing? Any advice would be greatly appreciated.


Hi Carl,

Which version of Max are you using? Max 8 and
earlier don’t have the MR Sun?Sky light types available!



Ahhh, that explains it – I’m using max 8. Oh well…



i have found a the other way to calculate the Background when you use a exposure and you don´t need change the physical scale.

EVf= EV Value F-Stop
EVs= EV Value Shutter

background multiply= (2^(EVf+EVs)*pi) / physical scale

background multiply = (2^((ln(f-stop)/ln2*2)+(ln(shutter)/ln2))*pi) / physical scale

and it is includet in Photostudio Pro:

hot chip


Hi, I constantly facing system irresponsiveness when rendering with mentalRay(max2k9 x64)

I cant do nearly anything during rendering (eg. typing note, playing music, or other smallofficetasks) - it seems that mentalray has during rendering high system priority and i dont know how to change it ( in others renderers there is switch to turnlow priority thread` )

Please tell me some solution, it`s driving me crazy.

my rig : q6600 @ 3.2ghz, 8gb ddr2, vista sp1 x64


Task manager / Processes tab: Select the 3dsmax.exe and right click.
Set Priority to what you want.

If you have a computer with multiple cores you can also Set Affinity and say it to use the number of cores/processors you want.


This method doesnt work, it seems that the mentalray ignores it, no matter if i set it to the lowest priority, it is always the same. I tested your method with low priority with finalRender R2 and native scanline renderer, and it works, so it must be mentalRay issue

PS : i think it is opereating system and 3ds max version independent as this mentalray behaviour is still the same, tested on max9 / max 2009 with xp64 sp2 / vista64 sp1


I’m running Max 9 SP2 with XP, and I’m rendering with Mental Ray. Setting the priority in the Processes tab of the Task Manager has always worked for me. Must be some other issue, then?


Nope, 3d_vlk is right, no matter the priority and even the affinity on multiprocessor machines, mentalray HOGS the system completely… don’t know if 2008 does it as well, but surely 2009 does it, and indeed max9 didn’t do it… it’s very very irritating! But nothing can be done it seems… I’ve heart more complaints abour it.



Hi, it’s me again.

This just started happening – when I tried to render an image of one measly object (32 polys), it gets stuck permanantly at “90.9% photon emission”. And like I said, this just started happening – last week I wasn’t having this problem with more poly-heavy images.

I have screencaps of my mr settings here.

Any thoughts?


Are the lights in the scene properly focused on the mesh to prevent photons from hitting “nothing”? Is the material of this mesh properly configured for photons?


My lighting setup is pretty dirt-simple: A skylight and one mental ray spotlight. I tried focusing the spot more so it would only hit the object, but it doesn’t seem to help.

I haven’t really touched the settings of the spotlight but here they are, in case anyone sees anything wonky:

As for the material settings, I wasn’t really aware there was a specific setup for mental ray. Shows what you’re dealing with, eh?

An interesting new wrinke, though: when I try rendering from far away, it works fine now. When I try to render from up close, it gets stuck on photon emission again. I’m pretty sure my PC wasn’t garbage last week, so I don’t think it’s that… hmm…

Edit: OK, here’s something really strange. If I unhide everything in the scene it renders in less than a minute. Could somebody please explain how 36000 polys renders rester than 32?:argh:


it looks to me that you are using max 8 or earlier correct? if you mentioned that already and i missed it i apologize.

now my knowledge of global illumination isnt much but i believe that the higher poly scene might render faster and more efficiently because it has more objects closer together to bounce the photons off of. where as with a single object isolated you are shooting all these photons having them bounce off a single object and thenback out to…infiniti?

thats my two cents., as well as the setup is so different now its crazy


alkhobarspecial: Yeah, I am using max 8.

Your idea makes sense to me. I guess I’ll just have to remember if I want to showcase a particular model I’ll render it inside an inside-out box to catch all the photons. I learned something today! :slight_smile:

Well, thanks to all of you for your help and patience. No doubt I’ll be back in the future…

PS: The mr setup in later versions of max – how is it different? Better? Worse? Worth upgrading to?


Mnetal ray since version 9 of max changed alot. for most situations you can really get away with not using GI at all. and use FG to bounce around the light very quickly. i would say the updgrades are more than worth it especially jumping from max 8 to 2009. with the photographic exposure control and mr sky adn daylight system. and the list goes on.


The basics of GI and FG are much the same (FG much improved though!) but there
are MR features in 2009 that are not to be lived without. :drool: