Mental Ray - Render Troubleshooting



When faces are coplanar or almost coplanar due to some unit (or scene scale) issues you can see some artifacts like this. I’m not sure if this is the case for your current scene, but your old scene seems so.

Assume you have a box with zero height. Then the bottom and top surfaces of the box are coplanar and on such cases menral ray creates unwanted textures or shadows on the faces.
This may happen if two surfaces are close enough and the scene is very large compared to the distance between them.

Bias parameters on shadow settings may help reduce unwanted shadows sometimes, by simply moving the shadow away from the shadow casting surface.

As a recommendation for your current scene, consider assigning the same material to all the objects on your scene. (preferably, one that mental ray recognizes- like arch&design mat.) Let’s see if it’s a material problem.

I have to admit that mental ray does create such artifacts for no reason at all.

Try to eliminate possible factors by simply selecting your ground object and the problematic proxy building objects, then pressing Alt+Q. This hides all objects other than the selected. We may sometimes duplicate objects unintentionally. Then try re-rendering.

Assign a stl-check modifier to see if there are any errors like open faces or double faces on the mesh. Ground object may not be solid (one with thickness) so it will also be reported as errors.
Consider adding it some thickness by shell modifier. Also try the cap holes modifier. It may not help correct a bad mesh but at least, may cap holes and your problems may suddenly dissappear. You may then find out there is a problem with the mesh.

Change the renderer to scanline, and then back to mental ray. Believe me, it helps, by resetting some parameters and may solve many of your problems, even improving rendering times.

Let’s see if any of these work.


I’d say its bad geometry, probably inverted faces, make sure your materials have double sided turn on. I’ve found even with double sided turned on if some of the polys are inverted you will have to flip them, unify doesn’t always work.



Lately I have had increasing difficulty with dark areas (shadows and dark objects) on my renders, where there simply isn’t enough detail. Things start getting grainy and banding occurs. In VRay you override this by using 2.2 gamma in the colour mapping. But how do you address this in Mental Ray? Lowering the Spatial Contrast works on the image as a whole and makes the render much slower. It looks like the image is calculated linearly then modified to 2.2 gamma, i.e. not calculated in gamma 2.2 from the outset. Is this the case?

NB. I use gamma 2.2 with both in- and output bitmap gamma at 2.2, daylight system and mr Photographic exposure.

(Also, my renders show up a bit darker in Photoshop, but that may be a separate problem…)


Good day, great masters of mental ray!

In my experiments with mental ray I’ve found a strange bug with mrProxy. Here is the illustration:

I’ve made a single “block” of that shrub fence, approx. 2 meters in height and length and 0.5 meter width. It was made with the help of PFlow scattered leaves over a simple box. Then I’ve converted that PFlow in a editable poly, added a box to it and created the mrProxy. One mrProxy contains about 30K faces. Then I’ve made an array of mrProxy instances to make that big shrub fence. All instances have exactly the same material. But as you can see, mrProxies that near to the camera have normal material color, but as the distance from camera increasing, they’re starting to fade into black. What am I doing wrong?

Thanks in advance, Nick.

P.S.> The grass made with single mrProxy renders just fine (as you can see above). I am using 3ds max 2010


Silly but I remember such a thing happens. It’s been a long time since I last used Mr proxy, but I definitely remember the fact that a re assigning of the material to the proxies is necessary.

This was one of the specifications of mental ray that makes me call it “Dumble ray”. :slight_smile:


Thanks a lot! My problem is gone :slight_smile:



on my first interior i got the infamous NaN (Not a number) error in the render message window.
Sometimes the result was still ok, sometimes i got some small black artifacts.
I think i could track it down to some glossy materials (glossiness <0.5), but i´m not sure.
It also seems pretty difficult to find any conclusive information about that error.
Anybody got some useful ideas/links?


here is my solutions for “Photon Artifacts” or “Color Spots”

To the post


Hi all…

I´m currently participating in the project from hell, with so much going wrong it´s almost absurd.
The client is great and the project is interesting but I / we have extreme problems getting the same rendering results from the same files! For the last 2 days and night I have been trying to figure out what is wrong but come up empty. So I´m kinda desperate for any kind of input.
I have this scene, render out a picture with MR, send both max file and rendered pic to client who opens the max file and render it and the outcome is not the same, the reflections are all wrong and my image is so much brighter(overexposed kinda)!! We have the same units set-up , Gamma disabled, HDRI Option settings, 2012 SP2 …
Can anyone THINK of something that can cause this, because I´m all out of options right now!?
Thanks /M


You put your finger on my wound… (A Turkish idiom meaning: I have often exact similar problems here, none of which have easily spotted reasons.) A list of my crazy reasons is below:

  1. First of : Try archiving the files -if don’t do so- by MAx’s archive command to keep all the bitmap and resource files with the max file. There are times you may have file not found errors although you archived, God knows where those files are- probably in material editor’s some unused slot.

Of course very probably you did this. Secondly:

  1. HDR and GIF files sometimes can not be recognized by mental ray on some other machine. If using distributed bucket rendering it’s almost always happening. Whether or not you have the exact same directory structure on both machines. It does render once and not in the next. Often reflections are affected this way. This is obviously due to a wrong bitmap location definition or some other reason that doesn’T let mr reach the file on the other machine.

  2. Final gather maps cause a lot of confusion since you may have created the map on some other resoultion or from some other frame range and just forget. Double check the status of fgmaps.

  3. I often have this literally silly issue using environment maps: Although I turn it off from the environment panel, It turns on by itself. I have spent several hours trying to understand whatever is going on. Some parameters also reset themselves by changing the renderer. That causes confusion.

Also this seems obvious to me that mental ray introduced a new type of pathology: Normally parameters that do not have effects on the selected object are disabled. On mental ray you may be trying to adjust the environment from some map slot that actually doesn’t affect the scene. There are many parameters on mental ray that doesn’t work, at least have no effect on your special case but it is there and selectable.

The skylight -use environment from skylight option parameters are definitely confusing. Be careful on them. you have problems having difference in reflections, that may actually be because of that.

There are many parameters on mental ray materials that don’t which otherwise would work. I mean for example visibility. Not related with your specific subject, but you think it will work because it normally works, but on -let’s say- carpaint material : it doesn’t work. There are issues like this, where you might think you have placed a map on an object which actually is not rendered with that specific kind of material or map composition.

Hope I could have been of any help


Hey, Massemannen, I agree with Byteman3D: It could be that you re-use a Final Gather Map or a Caustics and Global Illumination Photon Map or both, and don’t have the same maps stored as the client.

Or it is one of the other things Byteman3D suggests. But this should be the one that is the easiest to check, just look in Render Setup under the Indirect Illumination tab.

Hope you get this sorted out, I know the feeling… :frowning:



I would add in addition to the above to you and pass back and forth a Project Folder. Make sure all your maps (even default ones) are within that folder system. Your FG maps should be in there as well.

Good luck.


Thanks guys (gals) for your input and suggestions!! This is really a mystery… FG is always recalculated so no saved FG that can make trix though. I will hopefully get back with some kind of solution, but please keep sharing suggestions and ideas!!



To pinpoint the problem, I often hide things and leave only the wrongly colored object and do test renders to see whatever is the trouble.
Narrowing down the number of objects and still having the issue will eventually bring you to the cause.

If it’s ok for you and if the project permits, just send the file somewhere and your rendered image with the same settings. I can check the scene and tell you whatever happens over here.

Really it can be anything, even a video map which plays back fine on your system but rendering black on the client system just because there is no suitable codec.


Massemannen: Are you and your client using the same version of the 3D and/or rendering software? I’ve had several interesting experiences making changes to old 3ds max files which used to render beautifully, but became horribly too bright and the lighting color was awful. Finally it was pointed out that it was originally done in a earlier version of max than I was using, and the lighting system in the program had changed a lot in the new version.I then tried in the old version and it was OK.


Sometimes your muli-subobject materials end up with non-consecutive ID’s, for example 3 sub materials using IDs 1, 2 and 5. If an object in your scene uses ID 3 or 4, mental ray will crash with a Null DB tag error.

The crash occurs when a ray touches a face with the ID that is missing in the material, as best as I can guess (this includes FG rays).

I’m sure this is not the cause of all such errors, but it is a pretty simple fix once you know what to look for!


hi every one!

i have a big problem with mental ray, whenever i add an arch&design material in any slot , 3ds max crash.

this problem start when i made a scene with some particles and camera tracking , when i render it mental ray give me this error message :

DB 0.0 fatal error 041052

i tried to find a fix for that in google, found some few, tested, no luck ! :frowning:

i’m using 3ds max 2011 sp1 on win7 x64, I7 2600 3.40ghz, DDR3 12go

please i really need to fix that as soon as possible :frowning:

and thx in advance


I’ve never experienced a crash with this so I’m not sure if this will help but, arch design templates file has corrupted several times on my system and it eventually doesn’t work . It’s size also appears to be smaller than normal. You can download the file from the below link- just replace.

Some other files may be corrupt, too.

Another recommendation:
Switch to scanline render and back to mental ray. It solves many issues.

Is it the same on any scene or specific to this scene? If specific to this scene just merge your files into a clean scene and try that way.


thx man for reply! i just test it and it didn’t work :frowning: , i found the same solution in i think! and no luck :frowning:

no not just with this scene , with a fresh empty scene too, i start 3ds max choose mental ray as renderer , add A&D material in any slot , 3ds max crash… freeze forever or if i have some luck the viewport go black :frowning:

i did unistall 3ds max delet every thing reinstall 3ds max add all hotfix (fresh download) and the problem come back… :frowning:

formatting my computer is another solution but i have too man data that i can’t move them cuz i have no second partition or HDD … so this will i’ll keep it the last

thx again Byteman3D for your help, i’m trying to find other solution in google


Something strange i noticed and couldnt figure out why?
my fgm files are always 834 bytes whn i cache fg. I think the only way to determine if data is properly written to your fg files is to check the fgm file size…right?
I’ve yet to test it as it is generating fg file right now…its a long sequence…any ideas?

Moreover…are there any tips to avoid AA flicker other than sampling and spatial contrast settings? I’ve noticed rendering scenes with a lot of trees or capturing small details is very difficult to achieve with a good rendering time. Any suggestions?

its an interesting read but issue remain unresolved

I’m using max design 2012.