Mental Ray - Render Troubleshooting


Ah, i’m putting this in here, not sure where else i can. MR directs don’t support area shadows? I know there isn’t really an “mr Area direct”, but you do have the option of turning a mr spot into a direct (or omni) and it only looks like omni and spot support it? Are there any other solutions? basically i need a direct light with area shadows like you can have in vray area shadows - with the similar type of lighting.


Keeping this fact in mind that “the principle of direct lights and area lights are strictly contraversial” I wouldn’t expect area light behavior from a direct light.

Direct lights cast parallel rays which normally doesn’t happen in real life. It’s intended to get the effect of a distant light source like the sun.

To achieve such a specific effect -almost parallel light rays casting some area shadows like that of the sun, you may place an area light far from your scene objects.


Yeah i gathered that much. I just thought there would be a way to do it like you can in vray - not all he time we need everything to happen like it does in real life.

Oh well thanks


I personally haven’t used Vray before that’s why I want to ask: What particular effect is it that you want to achieve with a “direct-area light”?


Hi guys.

I have some characters i´m animating, do you have some good tips on removing blotches in the renderings. especially the hair. since its a dense geometry with lots of spikes.



I´ve have a scene with a whole bunch of arrows coming down on a sphere. This is totally R&D and nothin´ fancy… BUT when I render out the sequence the arrows (and sometimes the sphere) wont render properly or not at all.
I´ve attached 2 pics. The first is frame 78 from the over-night render and the second is frame 78 single render. All I´ve done is changed, in the Render setup, from Active Time Segment to Single… Any ideas anyone?

Take care!


sorry massemannen im not sure what would cause that. when you rendered over night were you distributive rendering or rendering to a farm? could it be a certain rendernode that is having issues?

has anyone encountered problems with when you turn on render elements shadows suddenly dont render?

in the first image i rendered with render elements on, i had z depth element and object ID.

in the second one I turned off render elements and my shadows came back.

Max 2009 Mental Ray.

any ideas?


Sounds like you may need to install SP1. That particular bug was fixed in SP1 that was released last July.

SP1 Link:


Thanks for taking time too answer, alkhobarspecial!

It´was renderer on my workstation so my 2 slaves had the night of :wink:



Yes, I had the same problem one year ago. I had MANY problems like this so I can barely remember this one. But I think I could fix it adding the “shadow” as a render element. I only needed to render the alpha and some other channel, but I had to render the shadow also in order to get back my shadows.

Hope this was the fix!



I’m trying to render on a quad core render node, and a laptop via backburner.

Laptop is comparable (quad core 2.5GHz), but renders about 4-5x quicker.

Similar amount of RAM, but I noticed that the CPU usage maxes out at 100% fairly constantly on the laptop, but drops right down using final gather on the render node.

Any ideas why this might be happening and how to increase the speed?

Max 2009 SP1




Laptop is comparable (quad core 2.5GHz), but renders about 4-5x quicker.

Similar amount of RAM, but I noticed that the CPU usage maxes out at 100% fairly constantly on the laptop, but drops right down using final gather on the render node.

Any ideas why this might be happening and how to increase the speed?

Max 2009 SP1

are the laptop and the render node running the same OS? if your laptop is on 64 bit that could be the difference right there.



They’re both 64bit, although the laptop is running Vista and the render node XP64.

I’ve tried submitting from 64bit Max using BSP2 and the laptop is slower and the render node quicker, but there’s still a > 2x speed difference.




sorry,disregard post


I got a strange bug when rendering with skylight portals and archdesign shader. When changing sampling of archdesign the reflections changed their saturation and didn’t get back.


I’m using the mr Environment / Background Switcher shader to allow me to comp some foreground elements in post.
When I use transparent black in the Background slot, my A&D solid glass material acquires a black artifact (the element is a simple sphere…).
I’ve tried bumping the refractive trace depth and a number of other solutions, but I’m still stumped.

Any ideas on a solution?

many thanks…


What you do should work, I do the same often… Weird, I wonder what you do differently?

I see that you have a small “m” for an inactive map in your screendump of your switcher settings. I usually assign None as map there, meaning that that button would be plain gray without that “m” - I know I had some unrelated problem with Mental Ray and inactive maps a long time ago, so I try to get rid of them everywhere nowadays, either an active map or no map at all, never an assigned but inactivated map anywhere, if I can avoid it. Just in case.

I don’t know if this artifact could be caused by that inactive map, but at least that is something you do that differs from my settings.

Hope this helps - at least it should be easy to test so even if it doesn’t help, it shouldn’t take up too much of your time!


Bumping this, but maybe I should make this a different thread.

The difference between a network render and a straight render on the same machine is astonishing.

About 25 secs network rendering, and 7 secs when rendered directly.

When I look at the monitor, it seems that the CPU usage varies widely on the network render, but the direct render is a lot more conistent.

Any ideas, I don’t think it’s the memory issue.

What’s really strange is that doing this the other way around, submitting the job from the i7 results in no speed issues on the i7 itself or the laptop render node.

It only seems to be a problem if I submit from the laptop. And all the assets are on the server, not stored locally.

I’ve worked around it, since luckily I’m moving my licence over to the i7 for the moment, but I’d love to know what the actual cause is.

Thinking back, I had exactly the same problem with a quad core desktop as a render node, that rendered far slower than it should have done.




is it not just the added time for the network render node to load the file? if its an animation i know the first frame always takes longer because of file load time. have you tested rendering multiple frames?


thx, wsknin.

the problem still exists when i completely remove the inactive map.

i’m finding that the artifact doesn’t appear if i throw the spherical map into the material environment slot… that’s the workaround for now…

any other thoughts?