Mental Ray - Render BUG.... colored spots everywhere!!!


#1

Mental Ray - Render BUG… colored spots everywhere!!!

tried everything … even rebuilt everything from scratch…

normal wouldn’t fix anything…

the problem appears when i add ANY glass material from glass_physics… to architectural glass

plz help


#2

A picture might help. :slight_smile: This may be just a matter of tweaking your mental ray settings.


#3

Sounds like it could be your photon settings. Yes, a picture would help.


#4

See if the info in this thread helps:


#5

sorry… it was my first post and it had to be aproved

ok pictures…

first IES SKY and IES SUN
http://www.computergames.ro/forum/attachment.php?attachmentid=71629&d=1135162540

second NO LIGHTS ( just final gathering turned ON)
http://www.computergames.ro/forum/attachment.php?attachmentid=71630&d=1135162565

third a basic omni light
http://www.computergames.ro/forum/attachment.php?attachmentid=71631&d=1135162580

thanks 4 your time and sorry for the delay


#6

thanks 4 the link… i’ve already been there… read every last bit of info… NOTHING WORKS

here are the pics… already posted them once…they didn’t show up… so again…

first with IES SKY IES SUN… and glass_physics
http://www.computergames.ro/forum/attachment.php?attachmentid=71629&d=1135162540

second NO LIGHTS… just final gather
http://www.computergames.ro/forum/attachment.php?attachmentid=71630&d=1135162565

third… an omni
http://www.computergames.ro/forum/attachment.php?attachmentid=71631&d=1135162580

any solutions… ONLY happens when I add even the smallest glass material to the scene…


#7

I’d like to take a look at the actual geometry & scene settings. Can you post the file? If not the whole file, then how about some of the glass object(s)? If you want to email it directly to me instead of posting, that’s ok too. I’ve just never had any luck in re-creating these colored spotches.

I’m surprised that the 2-sided thing mentioned in the other threads didn’t work. You’re sure there are no coincident(sp?) faces? Because maybe it’s not the glass that’s really causing the problem. In the second image you posted (second NO LIGHTS… just final gather), it looks like the building has some coincident faces (see the small black spots in the shape of a square)…but it might not be…hard to tell from a render.

I guess for me, the bottom line is that there’s something up with the geometry that MR doesn’t like. It’s not the materials because if it were, then I could easily recreate the problem. Nor do I think it’s the lighting (again, it would be easily recreated). So if there’s anyway you could post the file, that would be great!


#8

You know Jeff, everytime someone posts a complaint about colored spots or black spots, I’ve asked for a file to see because I never encounter these problems. Invariably, I never get a file to inspect.

G’luck :slight_smile:

Maneswar


#9

link to file
zipped

http://www.computergames.ro/forum/attachment.php?attachmentid=71706&d=1135178370

link to another render… just hit f9 in max to get this one

http://www.computergames.ro/forum/attachment.php?attachmentid=71705&d=1135178274


#10

Crap, you must be using Max8 because I can’t open the file (using 7.5 here). Sorry I guess I can’t help this time.

Hey Maneswar! Hopefully you have Max8 and can take a look at the file.


#11

crap…ANYWAY… I found a temporary fix… apparently if u start max fresh and merge the old file into a new empty one and U don’t import any materials from the old… it’s fixed…

so my guess is that it’s not geometry… but rather some combination of settings that trigger this… couze i’m rendering the same scene … same lights… same everything… and no problem

the symptom i got before the error was an extremely slow render… and i said to myself… what is it taking it soooo damn long… and then BOOM spots everywhere… and by the way it’s not the first time… but until now… a simple max restart did the trick…

one more thing… exporting the file to 3ds … and importing then in a fresh file and reassigning materials… resulted in the same ERRORS… so

i’m final guess it’s something that get’s saved WITH the 3ds file and INFECTS the newly created max… but doesn’t get through when U merge the files and take NO materials from the old file…

anyway… i’m only guessing here :smiley:


#12

Hey Jeff.

Yeah, I have Max8 and I am taking a look. If I can track it down, I’ll let you guys know what I find. If not, I’ll report that as well I guess.

My first suspicion is that the Architectural Materials are not optimized for reflectance / transmittance, etc, and the low FG of 20 rays may be a creating situation where not enough samples are taken at given blobs which represent the reflected / transmitted color bleed. Get that?

I’m now trying with 100 rays for the FG and I’ll then try adjusting the reflectance / transmissive settings. Also turned off the FG ray limit since that may stop the calc at a specific value.

Definately not the FG ray limit because splotches are still there at 100 rays, so it’s something with the Arch materials, but using no FG and 100 rays in GI eliminates the splotches. So it’s Arch Mat, possible doubled geometry faces, rays.

I’ll let you know shortly.

Maneswar


#13

same scene … Arch mat and glass… caustics… gi … everything ON… only form the merged file this time… same low fg settings… u really don’t need hundreds…


#14

Samov / Jeff,

The problem and the reason for the slowdown is that the Arch Materials that are basically opaque materials have an IOR of 1.5. Set that to 1 and see the render go much faster and no splotches. By the way, switch to using Standard Materials and it renders even faster. If you need glossy, select a different preset and increase the Shininess parameter.

You can try that on your uploaded model. Just open the mat editor, only change the IOR setting for the Gray, White and Green materials, to 1, render.

By the way 2, you are wasting time rendering with only FG since it is GI that is 100 times faster. Use as much GI as possible, then add on FG. GI alone will not slow down teh render much at all, whereas even a bit of FG slows it down noticably.

G’luck g’luck. :slight_smile:

Maneswar


#15

ok…thanks…

I use gi a lot … and only use FG 40 samples or so when rendering final…

will try that IOR thing…


#16

ok… tried it… IT’S FIXED…

apparently it’s a small bug when using architectural materials… and switching back and forth from stone-glass-whatever… IOR get’s stuck at 1.5 that’s why merging with a new file and resetting the materials worked…

thanks… i’m now 1% smarter than i was before :smiley:


#17

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.