Mental Ray/HDRI/FG Splotchiness Problem


#1

Hi all,

Skylight set to white. Object materials: raytrace, falloff reflections, HDRI map in environment slot, FG set at 1500.

I’m trying to achieve a gloss plastic white housing.

Results so far are so so.

Suggestions?


#2

Looking good, but turn up your FG samples. to like 15,000 instead of 1500, to get rid of that black smoke effect


#3

Is your HDRI map blurred or ‘normal’? Are you using photons in the scene? How about the physical scale of the scene? Using 15.000 FG samples would be madness it must be something else. Try playing with the min max radius for FG and also try using the diagnose tool found in the ‘process’ (i dont have max open now so that might not be the correct one’)render tab for the final gathering.

http://www.jupiter-jazz.com/wordpress/wp-content/data/tr4kv2/html/chapter1-FG.html


#4

thanks for the responses!

i can imagine the render time for 15,000 would be crazy.

i’ll play with the radii. haven’t quite gotten the feel for radius settings, i know its scene scale dependent, beyond that: its experiment time.

HDRI map is blurred at 1 or 2.

by photons do you mean GI?

i only have a plane for the floor. does GI require an enclosed space such as a box with the normals turned inward. if so, how would this affect the HDRI environment map.

by the way, the models were created in Pro/Engineer, exported as STEP, then imported into MAX using NPower’s Translator.

What a great tool. i’m using the 30 day demo and will be buying it soon! RECOMMENDED for CAD to MAX!!!

sorry for the pathetic questions.

CGTALK is the best source for solutions.

thanks again!

fred


#5

yeah, photons are for the GI but I don’t hink you need to use GI for this one. For the future reference tho, it is smart to use an enclosed scene for the photons so that they don’t shoot out to the space :wink: and create errors/longer render timre (?).

I can’t say for sure but somehow I believe you need to blur your HDRI image more…it should be quite blurry actually not to cause blotchines. Try using a commonly known HDRI for test purposes, something like the kitchen probe…

there is no stupid questions! :wink:


#6

here’s another project i’m working on.

i’m satisfied with this result. i think the devil may be in the SCALE of the scene of the other project.

more later.

thanks a million!


#7

the more i think it out, i do believe its a scale problem.

the second rendering was exported out of Pro/Engineer into MAX, inches to inches.

the first project (the splotch monster) was exported Pro/E to MAX, millimeters to inches.

i bet if i scale up the scene in MAX 25.4 times, i will wet myself with glee.

film at 11.

f


#8

Looking good, but turn up your FG samples. to like 15,000 instead of 1500, to get rid of that black smoke effect

That is crazy! :eek:
As you have found scale can play a part, as well as light type, and shadow type. I would say you should almost never have to go beyond 1500 fg samples if you are using MR 3.4, even that is a bit high.


#9

that’s a relief to know.

any suggestions on how i can get better reflections on the main vertical surface and the foot (which is supposed to be chrome)?

f


#10

Neil Blevins has a tut on his site about using a bump map to help with reflections on flat surfaces, i think that would be your best bet :thumbsup:


#11

Hey All,

If the HDRI is in the environment slot only
then it will not be contributing to the
shadow casting that is causing the splotchiness
unless a skylight in the scene is set to
‘use environment’. I agree that there should
never be any need to go beyond 1000 FG
samples. The render times would just
cripple any paying project.
On the occaisions where I’ve come up against
this problem scale has definately been an issue
so checking that out as you have said may help.
Also the Radii and filter options will help
average out the light/shadows in your scene.
I always turn down the FG samples to about
100 and then play with these options to see
what effect they have in the scene.
Hope that helps.

Bri


#12

deadline do or die!

thanks for all the help everyone!

a little better results:


#13

Brian Bradley is right, sometimes you can simply activate the radius and min radius under fg and it will clear up the stepping you have in the renders. Render times will go up, but with little or no adjustments to the default values you should get better results. Also, have you tried uising a blurred version of your hdr for the skylight?


#14

Also, have you tried uising a blurred version of your hdr for the skylight?

i needed to have a white floor/backdrop so i just had the hdr in the environment and white for the skylight.

i got a better white plastic when i simply used a standard material with raytrace reflection. i was originally using a raytrace material. but, that was yielding more of a grey.

hopefully my last round of renders will be signed off by the client.

f


#15

Much improved:thumbsup:

But your gonna kill me if you don’t let us know
what you did to help achieve the final result!!:sad:

Bri


#16

Ahh!
Beat me to it :frowning:

Bri


#17

Brian,

i was so frustrated with my early results that i referenced the lord master of all things MR:

Jeff Patton.

he had an HDR example on line that i merged my model into.

sure enough, rescaling my models did the trick. i scaled/rendered my stuff in his scene until it looked clean. saved it, then merged my models into an empty scene and setup the skylight, hdr and materials from there.

i still feel like i’m flying blind with MR, but at least some of the fog is lifting.

f


#18

Hello, I think that the problem is in the radius of final gather, i always put my own values with which faster results and of better quality are obtained, the computer only make a approach but you can put the radius than you really need.

Sorry for my english, i can read but write is very difficult for me.

Grettings


#19

Ahh yes,
the good old, when all else fails search out
Jeff Patton manouver. :thumbsup:
I have used it a few times myself.

Thanks for the info.

Bri


#20

:surprised LOL, you guys crack me up. I’m glad to hear you fixed the splotchy problemo without resorting to 15,000 samples. :eek: