Mental Ray - Fatal Error 031005 ??


#41

The local Dell support said: --We don’t know nothing about software!

I guess any child is able to give us the same … support!?

Strange: the same software runs well on other machines, including older dell, at any resolution, while the Precision is able to do a maximum of 400x300; larger than that, it crashes!

Shame on you, Japan Dell!


#42

I’ve decided to build a new PC - will not be going with DELL for my own Workstation again (they’re fine for corporate machines).

Just sourcing parts now. One priority is a quality case with good quiet cooling. My dual DELL Precision sits like a vacuum cleaner when it gets hot. Ridiculously loud and annoying.

Dave


#43

Hi Dave,

I had to get up to speed on this thread since i hadn’t read any of it before. It sounds to me that it’s an issue with your Dell Workstation, not the Implementation of MR in Max, simply due to the fact that your laptop, with a fraction of the power can render it (albeit slowly)
Try removing your ram and testing each stick one at a time in bank 0. (it should be marked on your MOBO what that is) If you still get the issue id see if you could borrow some ram if possible to try to ascertain if it is the problem. If it’s a dodgy stick of ram then it should, like the laptop, just render it more slowly with the one good stick of ram if that’s the problem.

My other question is how many buckets are you seeing? With a dual processor you should get two buckets rendering at a time. My Dell utilises Hyperthreading, so in MR i get 4 buckets rendering a frame. If you are using hyperthreading on the Dell then id suggest turning it off if while you work out if its the RAM or not. Im no expert on these things but disabling any form of acceleration is advisable until you can locate a problem. The laptop which renders fine would not be using any thing like that any way.


#44

Try to use backburner ( net render) with Split Scan Lines check on and divide per 2 or 4.

First you can create a .pmap and .fgm files with a low resolution (e.g. 320 X 240) and then re-use them.


#45

Hey looks like this thread has been going on for awhile. I think I might know what your problem is. Its your video card. What kind of video card do you have? I had a problem very similar to this about a year ago and it was pissing me off. I too had 2gigs of RAM and it was not even close to utilizing it all when it would crash. Anyway after trying everything else I decided to swap out my video card thinking that it would do nothing after all the video card shouldnt have anything to do with rendering. However it fixed the problem. It was a radeon 9800xt 256mb, i swapped it out with an old nvidia 64mb ti and it rendered just fine even though it was a far worse card. I was not using mental ray just scanline. I would consider trying to swap out the video card just to test. It is reletively easy to ask a friend to borrow one for an hour or something. Good luck and what kind of vid card do you have?


#46

Thanks for all the comments.

I have just built a new workstation for myself and had no problems with any scenes :slight_smile: It flys. Packed it with 4 Gb Memory.

So the DELL can be relegated to menial tasks.

I might have a crack at changing the graphics card - but I think I will reformat the HD and install EVERYTHING from new.

Dave


#47

Argh, I had this problem too. Strangely, it disappeared when I deleted my light source
(mr omni) and replaced it with a spot.
I really don’t know if the mr omni was the true source of the problem, and I might experiment to find out (it will take a bit of time). I was just pleased that the crashing stopped.


#48

I have the exactly same problem and my machine is a p4 2.5 with 1.5 ram. The problem is not with memory and not with textures becouse i had a procedural textured scene and in a weak machine the render was ok. I’m trying a lot of things and I hope to find what is this fuc* message. I tryed 3 versions of Max and 2 versions of MR. Come back soon for results.


#49

oh!, any results?


#50

Guys,…I just ordered a Dell670 Dual 3g Zeon 2Gigs o ramo today!!! Im having the same issue on my franken-pc Int-3g 1gig Ram. I went is search of answers and found this! I think im going to cancell my order ASAP! Anyone have this similar Dell setup that DOESNT get this memory issue? Im best putting my 4gs elsewhere I suppose. :frowning: Sorry to see all your issues guys,…I know feel your pain.

Brian


#51

I have new machines now.

But I am going to completely re-configure and install my DELL from scratch and I’ll let you know what I find.

I also have a problem loading in Stitcher files that load fine on my laptop (~700MB RAM), but crash with memory errors on the DELL (2GB RAM). It just doesn’t make sense. Even with the 3GB switch.

I’m pretty sure it is a memory configuration problem with the DELL.

I’ll let you know my findings when I have re-configured/re-installed my DELL in a few weeks time.

Dave


#52

I have this memory error when I try and render anything over around 3500 pixels (varies a little from file to file) On two machines one with 1 meg of ram one with 2, nether are Dells.

I can only render this high with ‘conserve memory’ switch on otherwise the maximum res is a fair bit lower.

I had this problem ever since Max included Mental ray, can’t remember which version now, so long ago.

Why isn’t it fixed!!! They had so much time to do something about it, and no suggested fix has worked for me.


#53

You guys may not believe this but I found a fix for the problems we have been having. My school would render the scene only with 1 gig ram but mine with 2 gigs would not. Your laptop would but your workstation would not. What is the deference? Let me guess, you laptop does not have a graphics card and has to run software texturing? No open GL or direct X9. My computers at school default at software and I forgot to change the setting. I got hope, Set the graphics mode to software, the scene that crashed every time last night now renders fine and fast. Might just be dumb luck for me and not the problem but who knows.


#54

Rick, thanks for that info. I will try this later in the day. I hope it is the solution. I ended up going with my dual Xeon and yes,…it crashed the scene before. Grrr (still a nice machine though) Lets hope this works,…thanks for sharing. I’ll post back later with my findings!


#55

Ok, had the problem in our art department myself. Imho we are talking about at LEAST 2 problems here:
1st people who simply dont have enough memory for their scenes or too large scenes
2nd people who have plenty of memory and still cant render especially high res images

we are of the second category here. Mental ray usually fails with an error message about not beeing able to create a temp file caled “fb000.something” because it does not have enough memory. This alone is strange because creating a file handle needs very little memory and mental ray tells us that it used only about halve of our system memory. Our guess here is that this is a so called “memory mapped file”, a file that is mirrored in the main memory. So what actually happens is that mental ray tries to allocate a big chunk of memory in one go and fails. The bigger your screen resolution is the bigger is the chunk of memory mental ray needs, in our case about 100MB and thats the problem. Every application in 32Bit Windows gets max 2 or 3 GB of memory. mental ray is not a separate application but runs within max and uses the memory Max got assigned. Max itself is a memory hog and uses some 100 MB itself. Before you render max has to load a scene, create a internal representation and display it on screen. So it does already do a lot of memory operations which fragment the memory. Mental ray has to live with that fragmented memory and although everything works well as long as it allocates small chunks of memory at a time, it might fail when it tries to allocate a 100MB big chunk simply because the memory is already too fragmented.

Solution? The best solution might be to render it standalone so mental ray gets a fresh and clean memory space.
If you insist rendering from within max, start rendering directly after you start max, switch to software Z Buffer (Opengl seems to fragment memory more, thanks RickStefani, worked for me), try the the 3GB swith so the fragmentation is slower, and if tall this does fail, think about how else you can reduce the memory usage of max itself. One of our artists had to disable the splitting of his viewport and display everything as box. After a Max restart his scene rendered. Sounds like voodoo, doesnt it?

hope it helps
Jan Jordan


#56

I tried using the grid method of raytrace accelration and it took care of my extremely large file (15 xref’ed buildings into the major retail center site) problem. I too had the “out of memeory” issue. This grid method worked the best, hands down.

I hope this helps someone else.


#57

Damn, I wish I had seen this thread yesterday :(.

We were using a fg map for our 30 sec animation (fg samples set to 200), and after about 100 frames max crashed with that error. We have tried it on two P4 dualcore machines (one @ 2800mhz and one @3000mhz) with 2GB of RAM - the same make; GeForce 6600GT videocard. There were still about 500MB free when it crashed, and setting ‘conserve memory’ and all the other options on that pannel only helped rendering a few more frames.

We had no choice but to edit the flickering this caused in combustion and premiere, and live with that since the deadline was tight.

I will try as soon as possible the latest tips, and post again to tell you which helped.


#58

For error 211005, I took your advice and deleted my ambient light, but instead of creating a different one, I just created a new ambient light and made it the same color and intensity as before. I be very happy - Thank you


#59

somethings telling me it’s with dells ram, maybe something to do with the voltages on it… it could very well just need a voltage boost, because the ram might just be shitting out. however it’s weird that i’ve never had the problem occur till yesterday


#60

I’ve been having this very same problem… I tried the idea of changing back to software graphics, but, that just got me past frame two and into 98 (of the 100/750 I set it to render) and died on me anyway… So I just ended up wasting 15 hours. Has anyone come close to finding out whats wrong for sure? :’(