Mental Ray - Fatal Error 031005 ??


I have just encountered an error message when using Mental Ray :

mental ray has encountered a fatal error and the application will now shutdown. The error is:

MEM 0.1 fatal 031005: cannot free memory

I have a dual Xenon machine with 2 Gigs Memroy and 4 SCSI 36GB Hard drives. Not enough memory !!??

I can find NO reference in the Mental Ray manual supplied with Max 7 or on Discreet’s website.

Does anyone know why this occurs ???

I’m off to contact Discreet - I NEED to be able to create large images for a client. I am not happy.



Like this :



OK … this is very strange.

I took this scene home and rendered the exact same scene at 4000 x 3000 and it worked perfectly !! That was on a 1.2 GHz 700 Mb Laptop !!

What can possibly be making my twin processered 2 Gb memory system have this memory problem ??? Is it a problem with twin processor systems ???

This cannot be a simple memory problem. Can anybody advise ??? Can anybody suggest any tools to find out WHY mental ray is acting this way ???

I have searched the internet and I am not alone in finding this error. Perhaps it is not isolated to memory after all.

This is VERY annoying.

My Killer system falls down but my wee laptop takes it in its stride !! Mad !!



Hey man, same problem here when rendering an extreme amount of polygons. Takes about 4-5 min to load the scene on my 2.5GHz HT w/ 1GB ram, over 60GB free on both hard drives. But, from what i remember, it rendered fine (but slow) on my brother’s 2GHz single processor with 512mb ram. Could it be that mental ray has some issues with dual processors? I don’t know, but i’d be interested also for an answer too.


Same problem over here. I posted a thread related to this topic a while ago but nobody was able to give me answers…
It mostly occurs to me when rendering high res images (3000 pixels and above) during the finalgather prepass step. I tried everything out and the only thing left for me to was reducing the resolution…
I would be REALLY grateful to if anyone knows a solution to that…


Thanks for the feedback guys !

Lets see if we can see if there is something common that we all have and keep this thread going. I asked Discreet but they said after the few weeks you have for installation they don’t offer support ! W.T.F. :shrug: I have also posted on their discussion forum. We are NOT alone with this problem.

Do you guys have :

Twin Processor system [ ]
Over 1 Gb Ram [ ]
Mixed memory - bought extra Ram to increase the original [ ]

I’m [x] to all the above.

I have been experimenting and can render, so far, to at least 4000x3000 on my laptop (1.2 Ghz 720 Mb Ram), while my DELL Precison 450 Workstation with 2 x Xeon 2.4 GHZ and 2 Gb ram falls over.

Here is latest screen grab.

And here is the output (shortened - LOTS of “outside of a frame” lines removed) from Mental Ray. Does anyone know what is happening ???

DISP 0.2 error 211005: timeout waiting for finished rectangles
DISP 0.1 error 211020: received rectangle 1584 432 1631 502 start outside of a frame scope
DISP 0.1 error 211021: received rectangle 1584 432 1631 502 stop outside of a frame scope
DISP 0.1 error 211020: received rectangle 1536 432 1583 502 start outside of a frame scope

RC 0.2 info : rendering statistics

DISP 0.1 error 211020: received rectangle 1471 192 1535 239 start outside of a frame scope

RC 0.2 info : type number per eye ray

RC 0.2 info : eye rays 287642 1.00

DISP 0.1 error 211021: received rectangle 1471 240 1535 287 stop outside of a frame scope

RC 0.2 info : transparent rays 166350 0.58

RC 0.2 info : reflection rays 65545 0.23

DISP 0.1 error 211020: received rectangle 1471 144 1535 191 start outside of a frame scope

RC 0.2 info : refraction rays 128 0.00

RC 0.2 info : shadow rays 746320 2.59

DISP 0.1 error 211021: received rectangle 1471 192 1535 239 stop outside of a frame scope

RC 0.2 info : environment rays 2210 0.01

RC 0.2 info : finalgather rays 119196 0.41

DISP 0.1 error 211020: received rectangle 1471 56 1535 95 start outside of a frame scope

DISP 0.1 error 211021: received rectangle 1471 288 1535 335 stop outside of a frame scope

RCI 0.2 info : main bsp tree statistics:

DISP 0.1 error 211020: received rectangle 1471 96 1535 143 start outside of a frame scope

RCI 0.2 info : max depth : 40

RCI 0.2 info : max leaf size : 195

RCI 0.2 info : average depth : 36

DISP 0.1 error 211021: received rectangle 1680 432 1727 502 stop outside of a frame scope

RCI 0.2 info : average leaf size : 10

RCI 0.2 info : leafnodes : 993675

RCI 0.2 info : bsp size (Kb) : 52685

DISP 0.1 error 211020: received rectangle 1536 96 1583 143 start outside of a frame scope

DISP 0.1 error 211021: received rectangle 2400 384 2447 431 stop outside of a frame scope

DISP 0.1 error 211021: received rectangle 2448 384 2498 431 stop outside of a frame scope

DISP 0.1 error 211021: received rectangle 1920 432 1967 502 stop outside of a frame scope

PHEN 0.2 progr: calling output shaders

RC 0.2 progr: rendering finished

RC 0.2 info : wallclock 0:06:57.32 for rendering

RC 0.2 info : allocated 203 MB, max resident 235 MB

GAPM 0.2 info : triangle count excluding retessellation : 235320

GAPM 0.2 info : triangle count including retessellation : 235320

MEM 0.0 info : heap size limit set to 3000 MB

JOB 0.0 info : slave rendering OFF

MEM 0.0 info : heap size limit set to 3000 MB

JOB 0.0 info : slave rendering OFF

MEM 0.0 info : heap size limit set to 3000 MB

JOB 0.0 info : slave rendering OFF



Found this on it:

Sounds like you just don’t have enough memory to handle the rendering job.


Hi Vormav,

Thanks, I have seen that link. That is what I first thought.


I tried the EXACT same scene on my 1.2 GHz DELL X300 laptop with 720Mb RAM at 4000x3000 and it rendered perfectly (although slowly). It is not a huge scene with many polygons.

I tried it again this morning on my 2x2.4 Ghz Xeon, DELL Workstation Precision 450 with 2 GB Ram at 3000x2250 and it gave me that error. So it CANNOT be a memory problem.

It might be a problem with Mental Ray actually “seeing” my system memory - but there is more than enough memory in the system.

The fact that others have this problem AND that in one other case the same scene renders fine on a lower spec model while crashing on a high spec PC makes me suspicious !

The lack of help from Discreet is NOT GOOD.



I just rendered a 6000x4500 test of a diamond scene I’ve made (Caustics & GI). It completed without any problems. Here’s the basics of my PC:

BOXX system:
Dual 3.2 Xeon (1mb cache each)
2048 RAM (2 x 1024 sticks both from same manufacturer)

I wonder if it’s because of the different brands of RAM, or as someone else mentioned maybe an odd number of RAM? IE having 3 sticks instead of 4? Either way, very strange and I’m shocked at what Discreet told you. Was that what your reseller said, or an actual Discreet rep?



Thanks for the reply Jeff. I’ll rip out my Ram and have a look - and test without the extra RAM as people have suggested.

I added the extra 1GB RAM as a set from Kingston to take it up to 2GB ordering EXACTLY what was suggested for my DELL model - it adds in to balanced banks.

I just upgraded to Version 7. The reply I got from Discreet was …

Your request for technical assistance could not be processed as your 30 days of installation and configuration support for this product expired on 11/06/2004.
Here are your options to receive technical assistance:

*For assistance and for additional information about Discreet software support contracts, please contact your local Discreet Reseller. To locate a reseller near you, please visit the reseller look-up on the Discreet website at:

*Our per incident support option with a valid credit card. Please call +44-207-851-8000 for more information.

*Our website contains downloads, valuable FAQs and an updated product knowledgebase at

*Our product discussion forum, provided free of charge, is found at


Discreet Support

Looks like they expect me to pay for support. And I feel a bit of a mug having boxes for Version 3,5,6 and 7 on the shelf.


PS. Thanks for the thread on Mental Ray and your website, Jeff :thumbsup: very, VERY helpful.


You may also want to contact your reseller. Any time I have an issue I contact my reseller and he can help me out or will see what he can find out from his Discreet contacts. If your reseller cannot help or is uninterested I suggest looking into another reseller. It doesnt surprise me that they want to sell support contracts as many other companies do the exact same thing with requiring you to purchase a years worth of support to get updates and support from the company. Be happy that Discreet offers different levels of support based on what you need. If Discreet didn’t charge for support the cost of the package would go up or things of the package would be effected as they would have to shift company funds to support all 280,000 registered users.

Another option would be to look into the bitmap pager it is a buggy feature in past versions of Max, I haven’t tried it in 7, but if used properly it will store pieces of the image to harddrive and save out a final image once it is done. In past versions it would crash Max when the Bitmap pager was enabled anytime you try to preview a bitmap. So disable file input and output preview options and close and don’t open the material editor while it is enabled.

My thoughts on the subject,


i had a similar thing ahppen not long ago. what resolved it was going from an absolute final gather sample count, to specifying amount and pixel diameter min/max or 35/5 it still looked good, and completed rendering :slight_smile:


I’ve had the same problems rendering 1280x1024 finalgather with 5million polys. It was on a Dual Xeon 2.8 1GB ram. I ended up lowering the fg samples to 250, and lowered the bsp tree depth to 32. My memory usage was still at 1.89 GB physical.


Thanks for the tips and feedback guys. I’ve tried a few already i.e. Bitmap Pager off, BSP lower (No change with my problem).


My biggest problem is this:

1. PC A is a DELL Precision Workstation, 2x Xeon 2.4 GHz with 2 GB Ram (Thoroughly checked the memory - 2 Banks DELL, 2 Banks Kingston), using dual monitors.

2. PC B is a standard DELL X300 laptop, 1.2 GHz with 720 Mb Ram

With EXACTLY the SAME scene and settings - PC A has a fatal error and falls over, while PC B renders it perfectly.

Therefore, it is not a matter of actual resources on PC A.

This is what is driving me f%^£ing mad !

It is also making me wonder if the errors others see ARE actually related to memory resources OR not. Is it physical memory or graphics memory ??

At the moment I am using my Laptop to render large scenes - and that defies logic. (While being MUCH slower).

I am trying to find out what settings (hardware and software) are wrong with PC A. Otherwise why bother buying a good PC with more memory when you use Mental Ray ?

I will get in touch with my reseller. This is certainly a bug - at least on my machine.



i have the same prob, i’m using P4 3,4Ghz HT and 2Gigs of ram…
still no workaround?




As I know since 3.0, MR has an automatic memory management feature that removes unused things from memory when it uses more than you setted in Render Globals and then, if it needs them back, it will calculate again.
So all you have to do is to set your maximum memory setting in RG to a something like 90% of your installed memory.


edit :: I don’t know if max’s implementation of MR has this thing


Hi Guys.

Nope, no change here.

I have modified all the correct settings to tell MR to use as much memory as possible. But still it crashes with this error.

I have 2 Gigabytes of RAM (Max Swap file in XP) on a Dual Xeon machine and the only way to render a scene with Final Gathering radius set low and a size of 2000x1500 or greater is to take it home to my Dell X300 laptop with 700kb ram ! How the F££K does it run out of memory on my Dual Xeon system ?? :banghead:

I suspect some bad memory - although I have low-level checked that and it appears fine.

I am building a new machine soon and will experiment with the old machine before I move my 3DS Max 7 across.



well, try
bitmap pager on,
manage maps on,
conserve memory
and use placeholder objects.
that helped me.


I have been trying to render my scene for a couple of days now on 3ds Max 7
It worked fine on 3ds Max 6 and rendered with no problems
But here It is giving me the error you guys are recieving too…
I have a P4 3 GHZ HT and 1GB RAM
As i said before I rendered fine in 3ds Max 6
AS i was desperately looking for ways to render I switched to Default Scanline…As i said i was desperate :slight_smile:
And the error i recieved for the same scene was not the mental ray error obviously but a RAYTRACER error saying the “Acceleration Control” factors or what not cannot render the scene. So what did i do i looked for raytracer options and found the ACCLERATION Control thing it gave me an error too…So i increased the default settings for the Face Limit to 30 and Voila i was able to render the High polygon model that would not render…Unfortunetely when i added the rest of my scene it did not go smoothly…So i guess there is something that needs to be tweaked on this Acceleration Controller…Im not sure yet but i think it also can be applied to Mental Ray renderer too…Ill let u guys know if i find out anything


I have had this error occur as well. I am using a dual zeon system with 2gb of ram. What I did to solve the problem was I cleared out my mat editor of all materials and saved the scene while in a wire frame view port then ro-opened and hit render. I think the error has something to do with video memory or lack of. Give it a try it may work.