Mental Ray - Black Pixels


EDIT: Problem Fixed - See post #7

I’m having a problem with Mental Ray. When I render ( even when using a simple Standard material ) I get black pixels all over the place. It’s just a simple 2 light setup, no FG, standard grey material. Eventually I’m going to be using an SSS shader, but it does it with that as well. Does anyone know how to get rid of them?


I didn’t want to add this to the existing Mental Ray thread, as I didn’t want to make it a thread where people throw all sorts of problems at it and make it clumsy and disorganised. Maybe this thread can be linked to it at a later date.


Have you tried increasing your Samples per Pixel?


Yes. The dots just get finer, but they don’t disappear. Even on a low setting, I’ve never had this problem before. It’s just appeared ‘over night’.


if u replace the model w/ a simple sphere, does it keep showing?


Nope. The sphere is fine. So is the original scene that the head was made in. The scene i posted has had that head merged into it from another scene. Would it be something to do with the way I’ve merged it?


Could you post the file? If not, how about part of it (like around the eyes)?


I can see some dots forming lines in the right (left cheek) so it is the rendering of a user
viewport that causes these black pixels following the edges of the polygons of the mesh.
You must render camera or perspective views only for correct results.


Yup, that fixed it. Thank you Bao2! I didn’t know Mental Ray did that with the other views! It’s nearly always something so simple and right in my face! :scream: Thanks a lot guys! :thumbsup: You’re probably gonna see more of this character in the future. I’m working on a short film with a friend and I’m sure I’ll be asking for tips, crits and advice. I love this community! :love:hehe


i haven’t visited cgtalk is ages… but i saw this post and i had a similar experience.

i’m not quite sure, but i think the change in camera angle is NOT the thing that fixed your problem.

i believe you may “video color checked on” in max’s Render preferences… with “Flag as Black” as the setting. I don’t have max installed so i can’t see the exact names for things, sorry. What you need to do is change it to “Scale Luma” or “scale saturation”, or something like that, instead.

the change in camera angle indirectly altered the lighting perspectives from the front views maybe. i don’t know… but that was a problem i had once and that fixed it.


It must have been a different problem Gonzo, because I tried your method and nothing changed at all. It only works when I use the perspective view or a camera. Thanks for the heads up though. It might come in handy at some later date. :slight_smile:


the artifacts that bao2 correctly diagnosed also crop up when you render a dirtmap occlusion shader in anything apart from a camera or perspective view also.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.