Mental Ray "black holes" artifacts


#21

Howdy, It seems your pictures aren’t up anymore but I was having the problem of black small squares randomly here and there in my renders. I found out it was the raytrace acceleration settings. In the render dialog under the renderer tab, goto Rendering Algorithms and change your bsp to large BSP. if that doesnt fix it, make sure you’re using a camera instead of the perspective viewport. Cheers.


#22

Rendering with Mental Ray and FG in Max 7 and now 9, I was getting white, cyan or black splotches on some of my renders which was driving me nuts. I ended up giving MR away and using the scanline renderer with e-light for GI due to the frustration of it.
Just came across this thread and Followed Maneswar (Jeff Pattons) advice. I had falloff maps in the reflection slot of a raytrace material. Turning that off I thought had fixed it but I also found I had to set the reflection slot to RGB 0,0,0 (essentially no reflections) for it to render splotch free. Any other setting other than no reflections caused the splotches to reappear.

Other option is disable FG but can’t get good renders without it.

Tried avkid85’s advice about increasing the BSP but without success.


#23

Hi Kevin,

If you have Max 9 i would def recomend re-textring the scene
using the A&D shader, you can still get the problem,but it occurs
very rarely and if you texture one object at a time it shouldn’t
be to difficult to deal with.

Regards
Bri


#24

Thanks Brian

Yep, I’m tyring to do that at the moment in an attempt to resolve some of my issues.

I’m now having problems with the A&D material where I can select matt, pearl and gloss templates only. All the other templates incl glass don’t seem to work (as in load into the material slot), ever experience that ?


#25

Hey Kevin,

Strangely enough just last week. :thumbsup:
Quite a few on CGTalk and other forums have
run into this problem, seems to stem from
saving materials to Libraries. The base
file from whivh the templates are drawn
gets overwritten. If you have Max on another
machine as a render slave, go to your install
directory (Presumeably)
C:\Program Files\Autodesk\3ds Max 9\materiallibraries
and from that folder copy the file named
mrArch_DesignTemplates.mat and replace this
on your work machine. Other than that a replair
install of Max should sort it out.

Regards
Bri


#26

Thanks Brian

I have been adding materials to other libraries so it could be the reason it got upset.

I’ll have to try the repair option as we only have one copy of the software at work.


#27

look here, i hope it can help.

german: http://forum.german-mentalray-wiki.info/viewtopic.php?t=425

english: http://mymentalray.com/forum/showthread.php?t=455


#28

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.