Mental Ray "black holes" artifacts


#1


Hi,
i started drawing my home´s kitchen to finally complete its design construction. I´m working with MAX7 and Mental ray. I´m just starting with the geometry and a few shaders, the tiles among these. The problem are those black holes that appear on the walls and sometimes in other places. I think they first appear when i applied the tile´s Shellac material in several objects (nothing happened when it was used in just one).
Do anyone have problems like this one? Maybe is the shellac that doesn´t work well with MR?
My FG settings are quite low: 40 or 50 samples and 100 in GI. The same settings, altought looking low, had worked always for me (maybe a little higher for final pass).
I would apreciate any help.
Thanx


#2

Here´s another example of the same

pixelation is due to compression


#3

I think you need to adjust the number of photons per sample, and the average gi photons per light.

this thread is very informative:
http://www.vizdepot.com/forums/show…tal+ray+samples


#4

hmm… agreed. This happened to me before, when I was using a MRshadow map, I changed it to a Ray Traced Shadows, and the problem was fixed.


#5

thanks to both, for your answers.
I´m do using Raytraced shadows, and tryed fixing things with the photons per sample and FG settings.
I´ll give it a try with the GI photons in the light properties and let you know.
Thanks for the link too.
Cheers


#6

This brings me back to my “shot full of holes” problem, which I brought up in this thread:
http://www.cgtalk.com/showthread.php?t=217279&highlight=mentally+challenged
I never figured that one out, no matter how many different settings I tried. I was just able to shift the holes around. The problem seemed to be with Final Gather - it went away when I turned it off. What I ended up doing was, rendering out a lighting pass with a grey material override, to get a black-and-white light map. Then I layered it up with diffuse and reflection passes, and it came out pretty good.


#7

pcbyers, I was having problems with interior renders, I went to that thread I posted- take a look at the values they use, much much higher than you are using. I also found in the end that my latest interior(not posted yet) rendered about 40% faster when I upped those values, and reduced the FG samples–with better results. Anyway, it is worth a look IMO :slight_smile:

Here is the image I found very helpful:

http://www.vizdepot.com/forums/attachment.php?attachmentid=1016

Todd


#8

Thanks for your answers ToddD and pcbyers.
i´m running some tests on the weekend cause i´m at work right now. and let you know if i get some improvements. I found useful that image too.
cheers


#9

I had the same problem as you, and I fixed it just changing the value of the filter in the FG … I don’t really know the reason but it works… in my case … hope it helps…


#10

thanks for the tip emonimo.
i´ll try it and let you know.
cheers


#11

Hola tio que tal?, yo tuve el mismo problema de las manchas negras, y no sabia como resolverlo. Cambie los parametros del FG pues porq es cuando activo el FG q da los problemas de las manchas negras. Pero igual nada…no sabia que esta sucediendo. Hice como uno de esos tios encima te dijo, aplique material por material renderizando uno por uno para ver cual dava problema, y sorpresa, no dio ni un problema?!, porque? nose, estoy usando los mismos parametros y los mismos materiales y ahora nada de manchas negras, te recomiendo q hagas lo mismo para ver que pasa, derrepente las manchas negras desaparecen como paso conmigo.

Abrazos desde Peru tio!
Salud!!


#12

well hello,
thanks emonimo and mangolight for your answers.
i´ve been running several tests on the FG settings and here are the results: deep annoyance.
as i am doing this for fun and learn, and in the little spare time i progress slowly, when i have time to render.
you can see the results tweaking the filter and radius settings. i can hardly find a pattern, except from the radious size and (sometimes) the size of the spots.
also very strange behaviour when appling the shellac (i think it happens if there´s raytrace anywhere) material. i tryed applying the materials one by one and nothing.
i wonder if there´s nothing related to my computer´s performance (?)
next i´ll try replacing any raytrace in the scene (by now i ´ve eliminated architectural mats also).
i don´´t guess what makes the photons behave in that way (look the simetrical bounces of the black spots).
also no changes varying bounces in depth from 2 to 10
if anyone could give a hand, i´ll be greatful.
thanks.


#13

why don’t u post the scene file so some of us can actually play with it rather than speculate? or at least the people that know what they’re doing can play with it hehe


#14

thanks SoLiTuDe for your proposal.
i´m at work right now, and i brought here just the renders.
tomorrow i´ll upload the max file.
thank for helping.
cheers


#15

try bumping up your trace depth under RENDER/RENDERING ALGORITHMS. If you notice it is happening more around areas which have reflections. I have also noticed that max’s architectural materials will cause these artifacts, so I would check that also. Hope that helps

-Brian


#16

Problem: Black spots appear in Mental Ray renderings.

Reason: Final Gather does not work with Multi/sub materials with Raytrace reflections that are “FACETED”.

Solution: Turn “FACETED” OFF.

See 3DS MAX files attached.

http://www.3darchitecture.net/samples/Mental_Ray_BLACK_SPOTS_SOLUTION.zip

Kenneth Loyd

http://www.3darchitecture.net/samples/Mental_Ray_Simple_Test_(BLACK_SPOTS).jpg

http://www.3darchitecture.net/samples/Mental_Ray_Simple_Test_(NO_BLACK_SPOTS).jpg

Kenneth Loyd
3DArchitecture


#17

this may be a bit late and you may have fixed the problem already but if not i had this problem with an assignment earlier last year.

change the size of the photons, and mabey the amout to compensate, i forget wether to make them smaller or bigger but id go with making them smaller.

i hope this helps you


#18

I believe Jeff Patton found that a Falloff Map in the Raytrace Reflection slot can cause Black Spots… remove the Falloff Map and it shouldn’t show spots.

As for Arch Materials… make sure to adjust the advanced properties like transmittance, reflection, etc, so they are more in line with the type of material you are creating.

Maneswar


#19

[left]I had this problem too, I found it was my decals in multi/sub materials. For some reason filtering decides to mic the edge pixels with non existing pixels, giving the raytracer a hard time. The solution: turn filtering off in the bitmap texture.

Hope this helps!
[/left]


#20

Hey, here’s what I discovered when I had the “rabbit holes” issue pop up again in a recent project. I had to do about 50 test renders to isolate the problem, but finally I discovered it was a bump map issue. I had a standard Max material, and in the bump channel I put the “bump(3dsmax)” shader instead of just a plain bitmap. Final Gather was choking on it.

It wasn’t a multi/sub material, but I have had issues with multi/sub mats and Mental Ray before. So far, Arch&Design mats in a multi/sub seem to work fine.