"Memory Error" upon loading large image


#1

I have a huge texture map for a planet i’m making in 3ds max that i’d like to be able to zoom in close with. The image itself clocks at 23,040 x 11,520px and the jpg file save of it is 91.2 mb. When even clicking this jpg in max in order to bring it in for a material, max displays a “Memory Error”. I’m sure this is because the file is so huge, but is there anyway around it? Or a different filetype i should try? Thanks…


#2

i had some problems with some large blueprint not showing up and or crashing. switched to OpenGL and it worked [didn’t look as crisp] but worked.

also, did you ever think about painting the texture black in the areas you aren’t using? this way, when saved, it would extremely smaller. then, when your done in that area, move to the next. kinda like cropping it, but keeping the size.

does that make sense?


#3

You might want to try enabling the Bitmap Pager (under Customize>Preferences>Render I think) which pages large testures to disk and loads on demand. If it does not help, resize the texture. There was also a commercial plugin which would allow virtually unlimited texture sizes using wavelet technology and whatnot… but it is expensive!
http://www.gamasutraexchange.com/FullPreview/index.cfm/ID/247953


#4

You could try turning off the preview images when selecting the image file, right beside the option to bring in sequenced targa. You might also want to disable your material editor so that the shaders only update when selected. Hope this helps.


#5

By upping the bitmap pager threshold, I was able to select and bring in the jpg file, however max turned it into a purely black texture… Any reasons why that is?


#6

When max renders it black … that is Max’s way to tell you he doesn’t still have enough Video
or other Ram to properly load ypur map!

When i had the same prob …i can tell you what i once did… and it worked pretty well.

I resized the image to a lowres version and worked in max with it… then i started a net -render job and didn’t start a server… just the manager… then i renamed the high res file to the name of the lowres file… then i started the server… e voila… it took the highres version and renderd out fine.
Be sure before starting the server to close max to have more ram!.

Hope i could help…and hope it works 4 U!


#7

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.