Mech: Smoothing Faces


#1

Is there a way to render this out without having the geometry be so jagged? Yes, I know I could just increase the number of polys, and softening the normals doesnt give me the results im looking for…

Any suggestions would be appreciated.

Modeled in Maya 5.


#2

have you tried using the smooth tool?


#3

could you please post a wireframe of the model before smoothing? also, please post two pictures comparing what happens when you just increase polies and soften normals as you said doesn’t give you what you want.

from what i see now, it looks like the problem is that you aren’t chamfering all your edges. In real life there is no such thing as a true 90 degree right angle. Everything has roundness to it. Maybe the smoother isn’t working as you want it to because its trying to round down all your angles for you since you didn’t round them.

Here i have marked some of the especially bad lines in blue that make me think you didn’t round your edges:


#4

Youre absolutely right. I didnt know about doing that, so I will def. read up on it and re-post what you asked to see…Im still relatively new to this, so thanks for the input.


#5

You could bevel those edges,so there would be no need for smoothing.(You could do this because you did a very good mesh) :slight_smile:


#6

awesome :slight_smile:

here’s a little tip on chamfering:
on some edges, you sometimes have to chamfer twice (three is overkill in nearly every case from my experience). Usually you can get away with a single chamfer. Always try to go with the minimum amount you can and still have it look perfectly real.


#7

There’s another technique that’s the equivalent of 3DS MAX’s “smoothing groups”. Essentially what it does is average the surface normals of each edge, so that instead of a sharp angle you get a softer one. No chamfer, no more polys…

You select the edges you want to smooth (or the whole object) then go

Edit Polygons > Normals > Soften/Harden [options]

In the box that appears, set the value to 180 to soften everything at the max (recommended). A value of 0 leaves everything “hard”-edged. You can play with the values in between, since they may give you the look you’re after.


#8

I guess in Maya 6 there is a bevel edge option? I was able to smooth the sides, but adding that little edge to various parts is the next step. I downloaded BPT Bevel, and that seems to work well in initial tests…

Thanks for all the feedback and suggestions!

Margus.


#9

aside from smoothing normals (by the look of the hard edges it looks as though there should be enough geometry to soft/hard with just the normals, like aroung the gun barrels) you can try to render in mental ray w/ maya 5, it does pretty good job of fixing those type of problems.
Joe
www.joetreu.emv-arts.com


#10

Looking at your image it seems like a simple smoothing of the normals will fix it.

Select the faces that need smoothin, and under the modeling tool set, goto
“Edit Polygons > Normals > Soften/Harden” and open the option box and press all soft. If this is to hard just undo and use the slider to ease of the softening angle.

Should work.

Dave :thumbsup:


#11

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.