Maya2018 whatWorks/whatNot


#1

first impression:

what works not:

  • nodeEditor: still no container support ( and still one of the most needed functionality at least for me)
  • hypergraph: moving a node inside a container can still result in the whole container being moved (not in the same direction)

what works:

  • obviously, the ‘too many attributes on custom node lead to various errors’ problem is gone : )
  • The layout of nodes in a container is no longer lost in Hypershade

whats great:

  • crashing Maya gives now the stack trace of the last function calls in the output window, wooooo…
  • for many, many years I thought it would have been my bad programming that makes Maya scenes, which have my own custom
    dataType (MPxData), crash when I close these scenes or close Maya. It took me a lot of time ( I mean a_lot ) to find the reason, but I failed.
    And now, with Maya2018, the crashes are gone, great!

#2

still the same bug introduced in Maya2017: When opening a scene, the docked hypershade disappears.

Open the hypershade and dock it somewhere (i.e. between the viewports and the timeslider).
Save your workspace
Make a shpere and save the scene.
Restart Maya (the hypershade will be docked and all is fine)
Open a scene (i.e. your saved sphere-scene)
Boom - your hypershade disappears and your viewports get streched

I made a shelf-button for restoring my workspace, but that workaround is annoying.

Perhaps anyone has an idea for a fix?


#3

I’ve been impressed with 2018 so far. The team did a great job IMO.

I wish there was some sort of way to create containers or node groups in the hypershade and node editor :frowning: Every other node editor on the market lets you do it


#4

I would like to give Maya 2018 a huge thumbs up for for adding bullet solver to mash and fixing a ton of bugs. Maya devs did a great job!


#5

Everything dissapears in the viewport 2 when xray mode is on.

Lambert1 shaders, and primitives.
Quadro P4000 and latest WHQL drivers.


#6

Instanced lights no longer supported in VP2. :frowning:

Vray supported light instancing but yet Autodesk decided to break it. It still renders but nothing shows up in the VP2.

Never understood why light intsances aren’t supported in Maya! It’s 2017!


#7

Ha, now I see that the bug is officially fixed.

How great is that, thanks guys!
(the weird resulting behavior took me hours to get to the bottom of the problem)

edit: I have no idea about the long time future of Maya, but this release seems to be what is a good foundation.


#8

Above posted Xray mode bug was confirmed by Autodesk - it’s because of the alpha cut mode.


#9

what works not:

  • hypergraph: MMB from one node to another to open the connection editor doesn`t work anymore.
    There is no dialog so the connection editor could be opened…

#10

Most people shouldn’t have alpha cut on, anyway. It’s useful if you have a lot of overlapping alpha cutouts (eg. planar trees and grass), but for most people it just breaks transparency.

They didn’t make it the default, did they? It’s a special case optimization for certain types of scenes, and it’s completely unsuitable for general use. (You can turn it off in VP2 settings.)


#11

Today I tried to open a scene which has like 60 references (which themselves have references of identical type in them).
This was no problem in Maya2016 sp1 (I never really touched Maya2017 as it was full of bugs).

Now, in Maya2018 I get crashes every time with the following message from visual studio:
‘Unhandled exception at 0x0000000072F8EE68 (nvoglv64.dll) in maya.exe: Fatal program exit requested.’
I updated my graphics card driver, but without luck.
So, what can I do?
Who is responsible for that problem, AD or nVidia?
I searched the net and found that the nvoglv64 dll seems to be responsible for crashes elsewhere.
But, no idea if thats related to my crashes…

For me, this again is a total show stopper. I cannot switch to Maya2018 if this problem persists…

edit: I should add that its no problem to open files with fewer references …but I did not try to find out whats
the critical reference number in my case…

edit: as these references are filled with many of my custom nodes, its would be problematic to send the files to AD…


#12

You should start another thread so you don’t hijack this one, but I’d start by disabling “load references” when you load the scene so it doesn’t load everything at once, and then load referencesbit by bit to narrow down the problem.


#13

Huh, this is a funny deja vu:
[Maya2017 whatWorks/whatNot

However, I will test the delayed loading…thanks!](http://forums.cgsociety.org/showthread.php?f=7&t=1389093&page=5&pp=15&highlight=Maya2017+whatWorks%2FwhatNot)


#14

Middle mouse click and drag doesn’t clone the object 50% of the time.


#15

gfk: initially loading only the top level reference nodes and than later all child reference nodes works.
But it takes quite a while to be done using mel…

So, this is a bug, haha…lets see whether I will invest time again to prepare a scene for a bug report :scream:


#16

Deleteing shaders deletes the object. I’ve seen this bug before a few years ago.


#17

VP2 will lock up on heavy scenes, freezing the UI.

Whenever you add an object to the scene, VP2 decides to load the entire scene, object by object and that’s when the freeze can occur.

I went from a Quadro K2200 to a Quadro P4000 hoping performance would improve but alas VP2 doesn’t exactly scale well.


#18

Arnold ignores the Maya lights.decayRate attribute and no longer offers its own Arnold lights.decayType attribute.
This is of course totally unacceptable. I have large scenes which are based on lights with no decay. These scenes have
formerly been rendered with MentalRay. And now, what?

Can Arnold please accept NO DECAY, as it did with Maya2017?


#19

Never mind. Wrong thread.


#20

What is your VP2 transparency algorithm set to? There is a bug logged with xray and VP2 transparency set to Alpha Cut.
EDIT: Never mind, y’all saw that, should’ve kept reading :slight_smile: