Maya Texture not rotating with cylinder


#1

I’m rotating a textured cylinder, works fine in workspace with time slider (textured view).
– i.e. when sliding or playing the time slider the texture DOES move with the mesh

However when rendering the sequence out as numbered frames the texture doesn’t move with the cylinder?

I’ve obviously got a setting somewhere, but for the life of me I can’t figure out what it is

Background:

I was working on an animated track (conveyor belt) with a wire deformer and everything else worked, and looked great as single frame renders, but when I rendered out the sequence I realized that while the track animated (cylinder rotation) correctly, the texture stayed static.

So I created a new scene with a simple textured cylinder and rendered it out, the same thing happened even though as stated above everything worked fine from the time slider. I even created a new cylindrical projection UV map, but no change.

I should note I’m new to the Arnold renderer, and am using aiStandardSurface if that makes a difference?


#2

Hi

Check if the place texture 2d/3d node is following the object.

Regards.
Prem

Blog