Maya:Q:invisible in viewport only?


#1

Hi,

Can I make any group/oject/layer’s member invisible in viewport ONLY but still renderable (VISIBLE) in Render View??? I always thought it is in drawing override/visibility, but Nope, they don’t work.

Thanks


#2

if you have onlu one object u can simply do it in the AE
go to the Render Stats and switch off “Primary Visibilty”

if u wanna do more than one object at a time use the Attribute Spreadsheet
fo to render tab and set the “Primary Visibilty” for all selected objects to off


#3

i think f3rry is after the inverse state of affairs …

in which case i can only really think of viewport show isolateSelect (using a bookmark for this state would probably be worthwhile).


#4

Hiya,

If it’s a model, you can try this:

  1. Select the object,
  2. goto [main maya menu*] Display -> Object Display -> No Geometry

The object will now be invisible in Viewports, but still renderable like normal! :slight_smile:

The catch is that, while the object is invisible in the viewport, it will still act like a normal object and still be selectable, which could get annoying… so I recommend that you stick the object in a R (Reference) Layer first :slight_smile:

[*Note that this works on a per object basis! It’s different from going to the panel menu and doing a Show -> Polygons type of thing, which will hide all polygon models OR doing a Display -> Show -> Show Geometry -> etc. The menu names of all these display options all start to sound the same after a while, so note the distinction! :)]

[* = edits]


#5

why do you want to do this? just curious


#6

you could create a display layer and put the object in it, leave visibility unchecked until you want to render.


#7

the other option is pre- and post-render scripts that just show or hide the groups/layers


#8

why do you want to do this? just curious

OK, I never had this problem before until I realize that it SHOULD be easy to do.

Let say I have a character, Hires wrap in Lores model. I know I can put them on different layer, turn them on when render but after so many shots I have done there is always chances I miss to turn it on leaving me with images with lores character in it.

I do not want to turn the hires in bounding box as it will look ugly on screen. As far as I remember drawing overide is the way to go. Why would you have visibility checker if turning it off completely can be done with visibility attributes of the object itself?

The reason also I started playing around in Cinema 4D, they have the TAG to be applied to any object to do this task which I always think can be done in Maya.

Anyone?

Thanks


#9

Well, the stuff I suggested (Display -> Object Display -> No Geometry) should work…

No layer switching or anything required before rendering :wink:


#10

problem with the geom switch is that everything is gone right !.

so i would put these objects into a display layer. turn the vis off and then run a pre and post render script to temp turn the vis on of this layer. that should be fine then and very easy to implement.

pre render :

setAttr “<your_layer>.visibility” 0;

post render :

setAttr “<your_layer>.visibilty” 1;


#11

well, this particular “No geometry” switch is a per-object thing, and it will only hide the models that it has been applied to :slight_smile:

(An important distinction is that it’s NOT the same as going to the panel menu and doing a Show -> Polygons, etc. or going Display -> Show -> Show Geometry -> etc.

This one’s in Display -> Object Display -> No Geometry

But the names of those different menu items sound reeeally similar though… hehe I guess that’s probably why noone’s tried it out yet :slight_smile: I’ve added a note to my initial post about it, just in case anyone reads it.)

You’re right though, a pre and post layer switch would probably be better and more flexible in the long run :slight_smile:


#12

ohh didn’t know that thing. thnx ceql, will come handy some time im sure :slight_smile:


#13

Cool,

Never tried that bfore…

Thanks, dude…


#14

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.