maya batch renders only 1 of 5 render layers!



I’m having a bit of trouble with Maya batch render. I have 5 render layers and when I batch render them, Maya only renders out 1 layer… All my renderlayers have green checkmarks so that should be good. When I render out one frame of the animation all layers render out fine, but when I render the whole animation it says: rendering complete allthough it just rendered out one layer of five :frowning:

Some help needed here!




do render from commandline then use the render layer flag
render -r mr -rl Layer1 filename


I think if you just put -rl with no layer name, it will render all layers.


thanks a lot guys I’ll give it a try! I’ll let you know if it worked.


It keeps saying:

// Error: Invalid flag ‘-r’ //


Hi, they mean from the Windows command line not from Maya’s!


I’m on OSX, so I’ll have to use the terminal then, instead of MS DOS? The help file says this about batch rendering renderlayers:

To render all layers in the command-line renderer

At a Command Prompt, Terminal window, or shell, type the following:
render -r file <filename>
The batch renderer will use the specified renderers in the file per-layer to render the scene.

I’ll try the terminal this time! :slight_smile:

Thanks for your help so far! :thumbsup:


Hmm, no succes yet… What do I have to type when the name of the scene I’d like to render is: renderTest.mb?

Should I type:

render -r file <renderTest.mb>

render -r file renderTest.mb

render -r file <renderTest>

I’ve tried several different things but the only thing that the terminal says is:
-bash: render: command not found


-bash: syntax error near unexpected token `newline’



Even I have this weird problem

When I am batch rendering in Maya 2010 ( and not though command prompt ) it renders only one render layer even though rest of the layers are renderable. I never had this issue with older version of Maya ie maya 8.5


I don’t have time now to try this out, so I’lll just render the layers seperatly 1 after the other for now. Later this week I’ll try this:

I’ll let you guys know if it works then.



the -r syntax is wrong. the -r flag should be followed by your render engine, not the file name.

let’s say you’re doing a mental ray render. your command line would look like this:

render -r mr -proj c:\project -s 1 -e 10 -rl renderLayer1 c:\project\mayaScene.mb

-r mr means use mental ray, -proj sets your project, -s is start frame, -e is end, and -rl picks what render layer you want to use. the last string is always your file name. if your paths have spaces in them, put double quotes around each path so that the command line can read them correctly (in windows, anyways. not sure about os x.)

also, your system needs to be able to find render.exe in order for you to call it from the command line. in windows you’d set the maya directory as a system path in order to do this, or call the exe by its full path like this:

C:/> “C:\Program Files\Autodesk\Maya2011\bin\render.exe” -r mr etc…

again, not sure about the OS X equivalent, but you need the system to know where the render executable is in order to call it from the command line.

hope this was useful.


nice! So Maya’s helpfile isn’t helping when saying:

To render all layers in the command-line renderer

At a Command Prompt, Terminal window, or shell, type the following:
render -r file <filename>

Thanks for the tip, as I said earlier, I’ll let you guys know later if it works for me.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.