Maya 6 om Mac OS - problems & solutions..


#1

Hello Elite People,

Would appreciate ur help and tips on trouble shooting Maya Problems on Mac OS …

I’m using Maya 6 on G5 machines, with Dual 2 Ghz G5 cpus, 2.5 GB ram, Mac OS 10.3.3.

I have the following items for which i have no answers as of now… so here goes …

:banghead:
======Simulations ======================================

Particles Problem:

This is a brief description of the problem we have encountered on different G5 machines.

The scene contains roughly 30 K polygons.

There are 3 curves to whom the curve flow effect has been added. The curve flow particles types are set to Blobby surfaces with the following values:

Radius : 0.33

Threshold : 2.5

The whole scene has 200 frames. The particles also have influence of a common gravity field. There is a common floor polygon plane onto which these particles collide with.

The problem is that when we play the scene (at every frame), after 3 or 4 loop of play the system hangs.

We try to use the escape key to stop the playing but it does not respond. Even the Apple+option + escape key (force quit) combination also doesnt respond. The system hangs and when left for 5 mins the system fans raise in thier RPM and this continues until huge noise of the fans arises. We then hold the power switch and force shutdown the system. We are forced to again reopen the scenes and work.

======General ======================================

Camera Clipping Values:

On one of the G5 systems, when ever maya is opened, its orthographic camera’s clipping values are reset to MIN: .01 and Max to 10 !

We have tried putting back the Max clipping values to 1000 many a times, saved the preferences but still when maya is reopened, the Max values shift back to 10.

We even tried to check the Maya Preferences values to check if our preferences are saved / written to the file. Its shows the values set to 1000 but when maya is opened, we still get this problem.

ShortCuts:

We use the Preferences > Hot Keys to customize some shortcuts. When we reopen Maya they are all not there for us to use them. We have checked many-a-times by logging into the same user. The UserHotkeys and UserRuntime mels are returned default when checked.

File Referencing:

We have 5 G5 and 1 windows seats on which our project files are worked on.

We have around 30 scenes to be animated and we have put all our project files in on of the G5 (Data HD - partition where all our data is stored).

We have 3 main files:

Rig1.mb > character rig, which contains the character mesh, bones, skinning all done with in this file.
Rig2,mb > character rig, which contains the character mesh, bones, skinning all done with in this file.
Finalset.mb > this is the final set file containing references of all objects which are in another folder called “objecs”.

Hierarchy Structure >

  1. servermachine/Data HD/Showreel/Scenes/ Rig1.mb
    " / Rig2.mb
    " / Finalset.mb

  2.  			"			/ objects/Object1.mb
     			"				    /object2.mb .... object10.mb
    
  3. servermachine/Data HD/Showreel/Scenes/ animator1/Sc-01.mb … Sc-10.mb

So each animator has his own working files named say Sc-01.mb in which we reference the required Rig.mb and the Finalset.mb.

We animate our rig in this file.

This way we can get the updated rig files, in terms of texturing, rig changes etc from the common files. So we can update our scenes maintaining consistency while animators do their animation simultaneously.

So the animators access the main G5 (servermachine) by logging into it. They have a shortcut to the main files and they can all access these files. Every animator saves his files directly into this servermachine.

So say on one of the client, a scene file > Sc-01.mb is loaded into which the Finalset.mb and Rig1.mb is referenced. The rig is animated and it is worked on, saved and closed. So the path for each of the referenced files are : //Data HD-1/Showreel/scenes/Finalset.mb (Absolute paths!!)

and this Finalset.mb intern references 10 object files from the “Objects” folder.

Our problem arises after few days where the files created on the clients start to show the following error while loading their files. >>

Reference file not found, where it shows > //Data HD-1/Showreel/scenes/Finalset.mb >> “Data HD-1” not found. We browse and show it the file, but still the scene opens with out the file referenced. These files which were created on the clients itself now show that Data HD-1 based files are not found.

We also come across situations where the same scene is edited by different client machines. So on one machine the scene files open and on some the other half of referenced files only open.

Please advise on how we can set the environmental values on the Mac OS for the Project folder so we can avoid all these missing file, referencing problems. Using environmental variables for such referencing situations is what is the solution according to Alias as mentioned in their documentation.

Also advise on how we can have common environment variables set across G5s so we can maintain consistency and reduce problems arising because of file paths (like textures, referencing etc…)

===== Mac OS Updates ================

I have my Mac os 10.3.3 installed when it came… so when i updated using software updates from Apple site, to upgrade to 10.3.4 >> My maya starts tearing my mesh as if some vertexes are snapped off into some wide space… to cross check, i’ve delete entire limb of my character and this mesh tearing starts to reappear else where… ANy one have similar problem ?

When i reinstall my OS back to 10.3.3 > maya doesnt tear anythings… So i’m afraid to even upgrade my OS … pls… suggest whether this is a known bug in Maya or Mac OS updates…

==================================================

Really appreciate ur patience of reading alll through this… and i’m waiting for any kinda help…

Thanks in advance,

  • ash :rolleyes:

#2

Hello…well i hope i can help…

1 - If your vga card is 9600 with 64 mbytes…there is one problem…u need a big card 9800 Pro SE with 128 or the new 6800 NVidia with 256 MBytes

2 - Update OSX to 10.3.5 …much better drivers in there for ATI and NVidia

3 - Check the rights you have as user on your machine and run Disk Utility on your machine to fix the properties on your system disk . (i think u need Admin rights to do that)

I hope it helps!!!

I will for more solutios soon as possible and get back to u!

Dimitris.

P.S …: U say …
"File Referencing:

We have 5 G5 and 1 windows seats on which our project files are worked on.

We have around 30 scenes to be animated and we have put all our project files in on of the G5 (Data HD - partition where all our data is stored).
…"

With 5 G5 and one PC…they all read the project from the same place? if so …baaad thing …at least in the past …i would be more carefull about that…It’s one of u should have the resources of the projects on his system…less headaches i think!..U must take a closer look on this particular problem…just my opinion.!!!


#3

Hello Dimitris,

Surely ur tips, are what i’ll follow now…

  1. VGA card : well, i dont think we can update the cards as of now…but sure feeel, that 10.3.5 update might solve upto some extent…will update and check…

  2. Disk utility > u mean for the crashing / hanging problem ? if s, i will run that now… and i have admin rights on the machine… hope this can clean out my maya cache / temp junk and solves it…will post the updates…

  3. File REferencing : yes, all the required resources are in a common place on one of the system. The peculiarity is , in the beginning we didnt have any problems. Later these reference problems popped up ! (maybe b’se those same files were edited on diff machines ? any hints ?)

I’ve checked the in bonus tools 6 for maya 6 , contain a FixReference.mel in which he has mentioned it has to run in script editor. But installing bonus tools in MAC OS is a ain for me… !!

I cant seeem to find the modules folder on Mac OS and any one got the FixReference.mel from the bonus tools working ? pls… guide me…

Thanks for your inputs and pls do get back with any more solutions…

  1. How do u set ENVIRONMENT VARIABLES in MAc becasue in Alias , they have the Best_Referenccing_Practices.pdf >> that these things will get solved if u use environment variables. B’se maya references using > absolute path ( i donno y alias feels it can only use absolute paths !!! huge problems with it…) and environment variables set > paths…

ANy one having any ideas on this, pls do ping me…

BTW: I’ve downloaded the Maya 6.0.1 update, havnt checked it out yet but it says Unlimited is also included. So do i just run and update and my limited version will be updated for the same license ? Any ideas ?

Chheeeerrrss !!
-ash


#4

Hello ,

I have updated my OS to 10.3.5 and sure can see that my dynamics files dont seem to crash…when i play them back… I’ll test further though…

BUT THIS update tears my models !!! SOMEBODY HELP !!! SOS !!! 911 !!! …

But only one model of mine tears … others dont seem to tear…pls see the attached img… any one with ideas ? Or is that tearing model having some mesh abnormalities ? how can i check that ? advise me on how to check for these problems…

Hope to be helped !!

thanks for ur time,
-ash
Pls view this >> http://dantuashish.tripod.com/works/3d/macos1035.jpg


#5

Hi, I have problem of mesh tearing. maya tearing mesh assome vertexes are snapped off into some wide space. it only happened in Mac Maya, when I open some file in PC, its seem fine. My Mac version is 10.3.5

anyone know how to fix this problem?

Thanks

Purelander
:sad:


#6

look in the general configuration part for this sentence

“We do not recommend saving data directly from Maya to NFS or Novell Netware or other remote mounted file systems. We have received several reports of data corruption when saving in this method although we have been unable to reproduce this. We strongly recommend that you save the files locally and then copy the data to the mounted storage system.”

just in case this is related to your issues

dann


#7

yes the unlimited features are there but you need the correct encryption to activate them - that is just a notice so that users don’t think they have to download a separate installer for unlimited or complete. all versions are this way. you do not get unlimited for “free”

dann


#8

Hi again…

1- The tearing mesh… —> This has occured to me when incorrect mapping was on my mesh …or…when the texturing data is too much for the vga card to handle on shaded view , i can’t think any other reason right now

2 - What dann_stubbs quoted from Alias site is VERY CORRECT!..the very first project we did in the studio i work for , with Maya 2 or 2.5 (don’t remember) , was a very big project which included a character we needed to animate for many scenes in complex enviroments and with both Motion Capture Data and keyframing. We were 2 animators working in 12 hours base continuasly (one after the other). We were working with the project on a server and from there i continued what the other animator was leaving behind and vice versa. IN about 65% of the times i opened the scene that my fellow animator was working …IT WAS CORRUPT scene.

After 5 days of trying to figure out what was happeming we finally decided to take the project on our disks…and this is something that i still do…

my 2 cents!


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.