maya 4.5 files open in maya 4.0


#1

How to open maya 4.5 files in maya 4.0? The error messages come out everytime when I open that straight. I did also save the files as ma ascii files and modify the contents, change all the “4.5” to “4.0” and this time no error message shown. However the persp, front , side and top panels never show up but I can see those other interfaces (time slider, range slider etc…). Does anyone know any solutions? This is killing me cause I cant open my works at school. Please help.


#2

its just a matter of changing a few words in the ascii file… What you would do is open a maya 4.0 file in notepad or some other simple text editor, and copy the tag that is at the top. It shoud look something like this…

//Maya ASCII 4.0 scene
//Name: your_scene_name_here.ma
//Last modified: Wed, Sep 25, 2002 12:18:02 PM
requires maya “4.0”;

Then, save the 4.5 file as an ascii, and open it in notepad. Then, simply paste over the header in the 4.5 file (up until it says something like “requires maya 4.5”) with the old header of the 4.0 file. That should do it. Works on almost any version of maya file. Good luck with it


#3

im not sure if i did something wrong. i did what you said (copy and paste, change the file name...) and still didnt work. this time the error message on the floating panel didnt come out but showed up on the command feedback said "Error: Error reading file". the persp and orthographic panels came back but the object or model didnt show up (completely nothing in 3D space). just wondering have you actually try on this version (not maya 3 to 2 etc…)? if this doesn`t work, any other solution?


#4

make sure in notepad that “word wrap” is off since it will put extra return keys at the end of each line.

Now instead of starting a new thread i thought i could post my problem…

Have you had troubles opening 4.0 scenes in 4.5? Im trying out 4.5 beta2 and things are not working out quite well. Missing skin geometry, parts of skeleton missing, and more. Maybe this isnt a problem with the final resease but has anyone experienced wierd stuff like this?


#5

Well… I’ve been working back and forth from 4.5(beta) to 4.0 for some time now. I haven’t been having any real problems like you are talking about with the missing joints and such. Curious, is yours a cracked version of the 4.5beta or a fully licensed version. This could have something to do with it. As far as the conversion of the file from 4.5 to 4. . . Well, it works for me… Here are the exact lines that I have to change to go back to 4.0 (by the way, why would you want to do this?) Here’s what I change. . .

THE 4.5 FILE::::::
//Maya ASCII 4.5ff04 (Beta) scene
//Name: your_file_name_here.ma
//Last modified: Mon, Sep 30, 2002 05:46:08 PM
fileInfo “application” “maya”;
fileInfo “product” “Maya Unlimited 4.5 Beta”;
fileInfo “version” “4.5Beta2”;
fileInfo “cutIdentifier” “200203010807”;
fileInfo “osv” "Microsoft Windows XP Professional Service Pack 1 (Build 2600)
";
requires maya “4.5ff04 (Beta)”;

CHANGE TO THIS IN THE 4.0 FILE:::::
//Maya ASCII 4.0 scene
//Name: KittyRIGforMaya4.ma
//Last modified: Wed, Sep 25, 2002 12:37:23 PM
requires maya “4.0”;

On occassion, the screen will come up with nothing on it, but all you have to do when this occurs is click on a different layout option(2 views side by side, 4 views, blah blah…) I’ve used this conversion method many times, and made a new file for this explanation, just to make sure I was telling you right. If you still have trouble, well, I’d say stick with 4.5 Its great! :beer: Well… time to get back to work…


#6

From what I have seen, if you have the ascii saved and then open it up with the text editor. All you have to do is DELETE the

“requires maya “4.0”;” (or 4.5 or whatever it is)

statement and it will open it just fine.


#7

i’ve done everything you guys said and still didn’t work. i think it’s time to give my file up, switch back to 4.0 and redo what i’ve done in the last 10 days (because still using 4.0 at school). here is a file made for testing purpose in case any one of you like to try that out. i really like to find out if there is any problem of the file or my computer or i really did something wrong. please let me know any result come up. thank you.


#8

Okay, I opened the .ma file in WordPad, and deleted the following lines:

requires maya “4.5”;

fileInfo “application” “maya”;
fileInfo “product” “Maya Unlimited 4.5”;
fileInfo “version” “4.5”;
fileInfo “cutIdentifier” “200208160001”;
fileInfo “osv” "Microsoft Windows 2000 Professional Service Pack 3 (Build 2195)
";

It opened okay with only a warning on line 128 about a smoothed wire frame, but it seemed okay anyway. Try it and see if everything you intended to be there, is there. That is something I couldnt tell because I didnt make the test. ma.

Hope it works for you.


#9

thanks everyone for all the replies. i did what dmcgrath told me to do and i tried on my computer, my friends computer and the computer at school still nothings changed. in outliner, other than default cameras and lights, nothing. and there is still a error message on the Command Feedback said “Error, error reading file”. if anyone knows whats going on please let me know. i really wanna find out whats happening. thanks, everyone.


#10

this one of the reasons why I always save files in ASCII format

plus when I need to, I can rip something out of the ASCII file and use the text for reference in a MEL script…


#11

k well it seems the problem i had was just because it was beta. All my 4.0 scenes are working fine in 4.5 now with the full release. so far :slight_smile: crosses fingers


#12

Just to throw my 2 cents in. i have the same problem going back and forth between my school and home computer. the solutions others have posted about changing the Ascii file info in the beginning have worked for me, but there has been problems. my experience with Maya is lending itself to the idea of Maya as Ostrich. If there is a problem, Maya pretends the offending object doesn’t exist. solve the problem and Maya will suddenly “see” it.

here are some other solutions:
if you only need the basic geometry then export as DXF file (does not keep trims or shaders)

can also export as “IGESexport” file to keep all the geometry (trims…) but this does not keep the shaders.

in order to export in these files you have to go to Windows - Settings/Preference - Plug in Manger- and then check the MayaToAlias box (loaded and autoload)-close window. check that they are working by going to File-Export option box. in the file type should be the new files you can export to (aliasWire, IGES, DXF).

haven’t found an export that kept the shaders. Any idears guys?

hope this helps. would love to hear if you were able to solve this any other way (editing ascii and such).


#13

Who can open maya 5.0 files in maya 4.5?


#14

Originally posted by Mappy
Who can open maya 5.0 files in maya 4.5?

just do the same thing as outlined above substituting 4.0 for 4.5 and 4.5 for 5.0

just be sure you do not have any 5.0 resident features in your scene


#15

I also have run into this problem due to school. sucks being ahead of your educational institution. But thanks for all your help. FYI, the above suggestions also work under os X. Thanks you guys have saved me again.


#16

Its pretty simple but not many prople know this.
First save your file in ASCII format (e.g. abc.ma) then open your maya 5.0 file in notepad or some other text editor. Now in some starting lines, you will find… requires maya “5.0” kind of statements. Just replace ‘5.0’ with ‘4.5’ and save it. Now you can open your file in Maya 4.5. I have tested it before and succeeded. I hope it will help you. Bye.


#17

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.