Maya 2019 Xgen fatal error


#1

Hello,

I find myself being in a pretty desperate situation here. I have this project that I was working on where I used Xgen to groom hairs. It worked fine until a couple of days ago where I had a fatal error opening my last save.

And now, my previous incrementation also won’t open and will crash immediatly after loading up. For no apparent reason since I don’t remember making a single change to it.

“Error: Xgen: (kFailure): Object does not exist”

I tried to open the scene with both Maya 2017 & 2018, result in the same issue. I also updated my gpu drivers, doesn’t change a thing. I tried to create a new scene to see if I could reproduce the issue, it doesn’t appear. So it is Xgen-related and specific to my last 2 saves.

I really need some help here, it’s over 10 days of work gone if I can’t get my saves to load. Thanks in advance.


#2

please check the official Maya forum.


#3

Hey,

I already did and also posted there. No answer yet so I’m trying everywhere. But it’s starting to look like something no one wants to tackle because it shouldn’t have happened in the first place. I might be in for a fresh unwanted start-over of most of my work for some poorly developped tool.


#4

Standard trick for this type of thing - try importing the file into an empty scene. Often clears out bad actors.