Maya 2009 Freezes


I’ve been using Maya 2009 64-bit at home for a couple of weeks now and in the last couple of days or so it has been randomly freezing up. I’m then forced to end it in the task manager. When using the same scene at school, Maya 32-bit often just closes at random. Maya 6.5 on my same home machine didn’t have this issue.

Has this happened to anyone else and can anyone recommend a fix? Is there a 2009 service pack, or something similar, coming anytime in the near future by chance?

My computer specs are:

XP 64-bit
GeForce 8800GTS 512 with most recent driver
8gb ddr2 800 ram
Intel Q9450 2.66ghz

Thanks for any help.


The scene I was using is really basic. It’s just a low-poly rigged character with a cube for a room. The file size is small. As far as what operations I’m performing, it’s usually none. It randomly happens and I cannot pinpoint an operation that may be causing it. It normally happens in-between operations, but not necessarily immediately after any specific one. Sometimes it happens while my animation is looping, sometimes it just happens while I’m tumbling in my scene, and sometimes I’m simply not doing anything. The task manager shows my cpu at idle. I have no other programs open. I’m also using the most recent nvidia driver.



This has been a major issue for us in the animation team… You’re playing your animation or scrubbing the timeline and BAM!! FREEZE. Autodesk Support asked us to try the following and it seems to work… Add this to your system environment variables…

value: 1



Thanks wolverine, I’ll give it a try.


wolverine: A followup question. I have the exact same problem as you. I have also tried using the MAYA_NO_PARALLEL DRAW var to try and remedy the problem, it did not help at all though. However so far i have been told to add it as a environment var in the Maya.env. I have NOT tried to add it as windows system environment variable however. Is this how you added it?



Yes in windows environment variables not your maya.env file… Though normally everything Maya related you put in windows env could be placed in Maya.env as well… Anyway… The whole team has it set in the windows environment variables… that brought it from 3 crashes an hour (letterly) to nada…



Lovely, now Maya actually reports during startup that ‘TBB parallel draw disabled’, which it didnt do at all when adding the var to just the Maya.env file. Now only time will tell if this makes any difference.

Thanks man :slight_smile:



Judging by the silence, can I say… “…No more scrubbing crashes…” ? :slight_smile:


hehe, na, i havnt actually had the time to test it properly yet. I will during the following week however. I have some animation sequeces i was planning on finishing. Previously i have had something like 3-4 total freezes a day when doing animation work, mostly during viewport updates, where timeline scrubbing obviously is an event that triggers said updates.

So if i get no freezes at all later this week after a day or 2 of animation, i can probably file this under the “problem solved” category. I will report back later about this with my findings.




Maya 2009 freeze in my pc very often when painting some skin weights and also when using the timeline.

I try using this technique going to control panel> System> Advanced> Environment Variables> and there i create a new variable in the “System Variables” and i write the name code and value that Wolverine advice.

But i still have the same issues. Maya 2009 freezes constantly.

When i start maya 2009 i don`t get any report as Matte was saying…Or i have to check in some specific place for that report??. Maybe i did not set that right…?..

I have also two previous version of maya installed in the same machine.

My Specs.
quad core 4GB Ram
Win XP 32 Bit
Nvidia GeForce 8500 GT 1GB RAM

Any help is appreciate


P.S. I did not use the code in the maya env. file…I may try there, but which will be the code to write there…? can be adapted to use it in maya.env…?


It’s like the first line you see in the script editor…
Something something disabled…



wow…fastest reply ever…Thanks

Yes, i check there but there is no report…By the description that i give…did i set something wrong…?

thanks again


I have it in User variables instead of System variables… Maybe that makes a difference…


Thanks. I try there but the script editor still do not reported.

Can you please tell me what to write in the maya env file…? maybe it will work if i write it there.?


in a Maya.env file it would be


This could be a videocard issue as well… we have nvidias here… So it might not disable anything on a ATI card or which other else there is out there.



Wolverine, so far so good. I’ve used Maya for about 10 hours since I added that to the system environment variables and there hasn’t been a problem. Thanks again.


thanks. I`m going to try that.



hey guys.

maya 2009 just keep freezing very often in my PC.

As i said before i try the solution by Wolverine but the script editor never shows that change.

I follow the instructions but i just don`t know why maya script editor never report it. Does anyone knows why this could be?

Perhaps i may have to add this code to an existing variable…? and not create a new one…?

Or perhaps is because i have maya 2008 and 8.5 installed in the same machine together with maya 2009…?

Please any help is highly appreciate


And here are my specs. again

quad core 4GB Ram
Win XP 32 Bit
Nvidia GeForce 8500 GT 1GB RAM


yes the good orthograph is


be carefull with “_”.

it seems to be fixed sith SP1a.