Maya 2009 Depth pass coming out solid color


#21

In the depthRemapped tab in the AE, make sure Remap depth values is checked. Then set Maximum buffer value to 100.

I’ve found that the far clip plane seemingly behaves correctly when you set Max Buffer to 100. I don’t know why, though.

Did anyone else notice that the alpha is aliased in this pass?

FWIW, the cube is ~17 units away. I set the far clip plane to 20, so that seems about right. The top of the objects aren’t anti-aliased where the ground plane ends.


#22

:diamonds:i have never had any problems with the depth pass

i always render to 16bit half float exr

the image looks wrong in imf_disp but in nuke i confirm that the red channel has values matching up to my maya scene units, in one case from 500 - 10,000 (this is why you need to render to exr)

this amount of dynamic range is good for me because nukes zdepth blur recognizes all the values and blurs appropriately, if i want to remap it for use as fog or color correction mask i can easily do that (i never let maya do the remaping, because its so easy to do it in comp)

drthunder: from looking at the image it seems that maya isnt performing any AA against an empty background, only against other objects, and easy fix for this case would be to enclose your scene in a sphere, or having something back there.


#23

Real Zdepth files are never aliased. Zdepth isn’t a raster image. Without going into a lot of technical mumbo jumbo, it is floating point data that tells the render the distance from the camera where objects are in space. People decided later on after the fact that the zdepth the renderer creates could be used in post for stuff like compositing, depth blurs, etc…


#24

How do you get proxies to work with the DepthRemapped channel?

It seems all I can get with the channel is cutouts and the proxies aren’t mapped at all?


#25

how did you manage to work zdepth?
all is coming out black in my renderings, too.
i rednered with and without remapping the values.


#26

You have to “Batch Render” the .iff file to get the z-depth info.
And yes, it is as simple as clicking on the check mark “Depth Channel Z Channel” option in the render settings for your camera of choice.:slight_smile:

Though, I prefer 3D Studio Max when it comes to Z-Depth. You can render the Z-Depth out as a Targa in 3D Studio Max.:slight_smile: . With Maya you must render out as a “.iff” file to get the zdepth info which (z-depth info) is not able to be viewed in Photoshop. If I’m incorrect with the above noted limitation, by all means anyone feel free to correct.:slight_smile:


#27

You want to avoid rendering Zdepth as iff, because they can’t hold float information, only 8-16 bit. Render EXR. There should be a pass in the render passes for this called Camera Depth.


#28

First, don’t put black text on dark grey background, no one can read it.

As for zdepth in maya, you can render out zdepth in any file format that supports an embedded zdepth, that would include tif, exr, rla and iff of course.


#29

Iff holds float data just fine. Maya software renderer is limited to 16 bit int for its raster data but zdepth is not raster(its a floating point data file). Software renderers have to use a 32 bit float because there isn’t enough information in a 16 bit int for the camera to resolve. You would have objects in front of each other in the software renderer all over the place if it was only 16 bit int.


#30

You’re absolutely right…
That’s for answering before having coffee in the morning…:surprised


#31

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.