Maya 2009 Depth pass coming out solid color


#1

So I’m trying to render a z-depth pass in Maya 2009 UL. I added both a “depth” and “depth remapped” pass since I have yet to find any explanation of what all these layers are. Anyway, when I render out and bring the EXR sequence into my compositing program, the “depth” pass turns out white, and the “depth remapped” pass turns out black, but there is no depth information in either of them.

Does anyone have any idea why this is happening?


#2

Any ideas??


#3

It may be the EXR output. I haven’t really done anything with depth since 2009, but if I create a basic scene try and render to IFF I get a nice depth pass, if I change to EXR I just get the white and black output.


#4

I was having the same issue using mia_x_passes material. Once I switched all my shaders over to Maya shaders the depth pass came out correctly. Also the shadow pass and a few others I was trying. In the docs it says:

“The mental ray mi_metallic_paint_x_passes, mia_material_x_passes, and misss_fast_shader_x_passes shaders only support object pass contribution map capabilities but not light pass contribution map capabilities. All lights in your scene contribute to a render pass for a pass contribution map that includes these shaders.”

So yah…I’m still playing with the render passes with the mia_x_passes shader. Hope that info helps you out somehow!


#5

Ok, so I tried switching it to .iff and then .png. The IFFs for the depth passes come out unreadable, and the PNGs come out all white.

I think I’m going to put in a support ticket, any other ideas?


#6

I’ve got the zDepth working rendering tif.


#7

… how? :curious:


#8

Does it happen on a fresh scene?

Please let us know the results when you find out what the problem was.

Thanks


#9

Don’t have much time to set up a new scene, I’m currently exchanging emails with autodesk support, I’ll let you guys know what the solution is.


#10

I basically setup a test scene with a plane, sphere, cone and cube. I used Maya shaders(blinns, lamberts and phong) and followed the pass building steps from the documentation. I could not get it to work with the mia_material_x_passes because I believe that only can output beauty, diffuse, direct irradiance, indirect, reflection, refraction, specular and translucence. When I tried to output a depth pass with the mia_material_x_passes it all my images came out blank. If I have time I’ll re-do my setup and post it.

L


#11

you can output depth channel with mia_material_x_pass, by creating a customDepth pass
then output the result from mia_material_x_pass to writeToDepthBuffer utility node.
connectAttr -f mia_material_x_passes1.result writeToDepthBuffer1.evaluationPassThrough;
plug a ramp node (white&black) to the depth input of the utility writeToDepthBuffer
or you can plug p_z shader (Puppet)
connectAttr -f p_z1.outValueR writeToDepthBuffer1.depth;
so this is not a solution but just a trick
/rachid


#12

could you perhaps post the scene + rendered exr with your depth pass…
i think i can help you


#13

hi
I’ve attached the .ma file, just remove the zip extension to extract
here is my setup

and here is the a snapshot showing the zdepth in fusion

hope this help


#14

The reason it’s all black is because the values are too small and the range is too high. This doesn’t mean the values are not there.

You are also looking at the image in a non-normalized viewer. Fusion has a normalizer in the viewport which clamps the image to a viewable range.

You don’t need to normalize the image for the z depth to be read properly by the effects.


#15

Update to this, I rendered 3 ways: Multichannel EXR, PNG stacks and IFF stacks. All came out black except, the IFF stacks open fine and look correct when I open them with IMFdisp, but if I bring the same stacks into Nuke or After Effects they either error or turn out black. No helpfull answers so far from Autodesk support.


#16

Did you read my post?


#17

sample the color in the zdepth and Ill bet you that there is image data in the zdepth but it is something like .000005 to .00001.


#18

Yes I did Leif, sorry I wasn’t replying to your post specifically.

It would be weird for it to be a clamping issue as it outputs different things when different output file formats are selected, but you could be right.

How would I control the clamping for the new render layer system in 2009?


#19

I was having the same problem with the Camera Depth pass as you J.P., and searched the forums and google FOREVER trying to find the answer to the issue that was driving me crazy. This is what I came up with to fix my problem.

While I was reading through the Maya 2009 Documentation I remember reading a line that said “blah blah blah turn on Remap Depth Values blah blah blah.” So of course the first thing I did was go to the Camera Depth pass and clicked that check box. Welp, after spending about a day and a half trying to find an answer it turns out that little check box was the problem the whole time. All I had to do was open my render settings window, open the passes tab, double click on my “depth” (Camera Depth) pass to bring up the attribute editor, and uncheck the “Remap depth values” box. I did a few tests with adjusting the near and far clipping planes, but in the end the default 0/1000 worked just fine.

Let me know if this helps you out.

-Matt


#20

I wasn’t asking because of that. I was asking because in the following post after mine you have the same problems so I thought you had missed my post, which adressess these issues.

Different file types seem to output different values. So far, EXr has worked for me the best.

For me the default pass works fine with EXR and a compositing program like Fusion that can clamp these values.