maximize window slowdown


#1

really strange problem here, if I maximize a window/viewport with space my maya slows extremly down, if I switch back to 4 viewports all is ok again ?!?!

anybody had this problem or know whats wrong? :annoyed:


#2

only know the problem but no real solution besides buying another gfx card.
we had that problem on some (not on all) machines that used a geforce 2 gts card under win NT 4.0…

maybe new drivers can fix the problem as well.

cheers

alexx


#3

we’ve had the same problem. don’t ask me how it was solved at all. but as it was like yours i alway hit the space bar to get the hotbox, click in the center and select single persp view. then it doesn’t slow down.

i guess alexx is right and it’s a problem with drivers :slight_smile:


#4

hm thats possible, maybe the newest nvidia drivers cause the problem, will try the older one


#5

oh… i dont think it is a matter of age :slight_smile:

we had that problem with the 12.41 drivers which were certified by alias wavefront :slight_smile:

but as svenip mentioned… i have no clue how and if at all we solved it… sorry


#6

yep geforce3 here and it does the same thing. the only way i can solve it is to save my scene, close down and restart maya


#7

I have the exact same problem too, though I encounter it by a slightly different way:

Ok so you other’s get it rather randomly, and it fixes with a restart of Maya? Well I encounter this ONLY when restart Maya, or play some game which uses the GFX card anywhere more than i.e. minesweeper does. The only way I’ve found to “reset” my GFX card is to simply restart the whole windows (Why can’t 2000 just restart the OS only, like 98 can… it takes ages for a gods sake), so if my Maya session crashes, it usually (Sometimes if I restart it immediately, it doesn’t slow down) means a restart of windows for me… very frustrating, good thing Maya is rather stable thing :wink:
But everything else, like changing the resolution/color depth, or anything doesn’t “reset” my card back to the smooth state Maya needs, dunno why :shrug:
(And when it’s slow, the four window setting is considerably slower compared to when it’s smooth[as I like to say])

And yes, my card is GeForce2 GTS patched with SoftQuadro (12.41 WHQL drivers)
Am not 100% sure if it was slow when I wasn’t using SoftQuadro, so can’t say if the quadro feature get’s turned off or if it’s something other.


#8

hm, I have also a gforce 2 gts :shrug:


#9

… a “SoftQuadro’ed” one?


#10

no


#11

Damn! So the problem isn’t the Quadro features somehow switching off… damn it…


#12

Hmmm, it’s been a while now when my PC’s ocassionaly (Around once a month) started to get very unstable, and I’ve always thought reinstalling the detonators help, well, it helped for the couple first times, dunno why, but the crashing stopped. Well, Maya just recently started to crash very frequently, and I decided to reinstall the detonators once again, but now the crashing stayed.

Ok, so now I noticed that with the SoftQuadro patch, there comes this other script, SQ-antiprotection which says it fixes the SoftQuadro’ed driver from going to infinite loop, and I think I now understand why Maya crashes on me. Well the thing why I’ve never installed the SQ-AP is because I always get errors, most propably because I’m using the drivers 12.41, while the (propably too old) SoftQuadro has it’s own scripts for drivers only and below 12.40 (I copied the 12.40 and renamed to 12.41 to patch my drivers). Because of this, I think I just have to download never Rivatuner to get the AP to work, but I’d just like to know that do you people have to install the AP aswell, and if you don’t, you get crashes?
Atleast that “Infinite loop” sounds like the crashes I get, the whole machine just locks up. And as the AP only patches a OpenGL related file, it’s propably that, but I’d like to hear it from you too


#13

Dunno if any of you are even intereted in this anymore, but anyways, I fixed my GeForce now. It was the Rivatuner 2.0 RC11 which did the trick, apparently SoftQuadro isn’t the best way to turn GeForce to Quadro, as this new Rivatuner uses this “NVStrap” driver, which loads before the kernel, and forces the GeForce to appear as a Quadro by changing the device ID, so it’s much better way than just fix up the drivers. For an example, with SoftQuadro, my card is never mentioned as a Quadro, I only get the new features page, but with NVStrap, I even had to reinstall the drivers, as I had normal GeForce drivers selected so I had to upgrade 'em to Quadro.

So, now I can open and close Maya as much as I want (Just think of it how hard it was, one Maya session per reboot), don’t know about the stability yet, but if it keeps crashing, I’ll report here, but for now I encourage you all to download Rivatuner 2.0 RC11 and use the NVStrap instead of SoftQuadro!


#14

tryed nvstrap, but I still have the slowdowns

thats really strange…with my old motherboard/ram I didn’t had this :annoyed:


#15

Hmmm, too bad :hmm:

Well, I did update my detonators aswell, I was using the 12.41 ones before, and updated to the newest ones found at nvidia.com, propably something like 29.xx or something.
So what’s the detonators you use currently? And does the NVStrap work, like your card is named Quadro 2 Pro everywhere?

Btw, what’s the mobo/ram combination you were using before the slowdowns? And what are you using now then? Did you just plug the new ones in, without reinstalling windows?


#16

hm no it’s named geforce gts ?!

i was using a msi board with 512mb sdram, now I’m using a new msi (kt3 ultra2) with 1gb ddr ram

but I have formated my hd


#17

Well the ram and mobo shouldn’t affect it, so I’d say that your NVStrap isn’t working in some way, as my card is described as Quadro in every place I look now, it wasn’t when I was using SoftQuadro (And back then I had problems too)

Maybe you should try to reinstall the NVStrap?
Oh and what detonator are you using?


#18

nobody deleted anything, the database crashed on the 16th and a backup from the 15th was taken…

I’m using the newest one from the nvidia page

hm, where is your card called quadro?


#19

aha i see… well i to sum it up again i used rivatuner RC11.1 to get this card recognized as a quadro DCC. Installed the latest quadro drivers from this page ver29.80
http://www.nvidia.com/view.asp?IO=IO_20010601_2940
Picked Maya setting in display properties. it fixed all the problems that ive been having in maya and XSI along with the window slowdown issue


#20

Crode, that’s exactly what I did too, the drivers are the 29.80 from NVidia, and then Rivatuner 2.0 RC11 used to convert it to Quadro, and all my problems were solved too :thumbsup:

And iC4-, my card is called Quadro in every place, like in the display properties page, it says “Display: blahbalbhabl on NVidia Quadro 2 Pro” (It never did with SoftQuadro), in the advanced menu it says “Quadro 2 Pro” in one of the tabs, then in that tab, it says “Graphics processor: Quadro 2 Pro”
And Rivatuner finds it as Quadro, oh and device manager says it’s a Quadro.
So, I’d say your problem is the NVStrap not working in some way, as my card feels like a real Quadro now (Although a underclocked one), which it didn’t with SoftQuadro, you should see the difference in those places after using NVStrap.