max viewport shader error/ mirrored instance object is black


#1

So I’ve noticed this problem on numerous occasions, where an instanced object that’s mirrored ends up looking black, which makes me think that the normals are somehow flipped. As I’m working with the mesh, this instanced mesh constantly goes from normal material to flipped/black shade(usually when I select or deselect the mesh), which can get really annoying after a while. Anyone has a fix for this? I’ve tried doing combinations of backface cull and two sided materials, but haven’t had any luck yet. I’m using max 2015. Any help would be great.


#2

It’s a known Nitrous problem, directX should work fine. Switch to dX and see if it’s any better. In any case, report it!


#3

Thanks. It’s a very annoying problem, and it’s not like a trivial problem either… The whole reason I started using Nitrous was to get away from all the problems default directx was causing. Oh well.


#4

Only 5 years late reply :slight_smile: , but better than nothing
It is very annoying problem, but i finally found the solution
I tried this viewport option and it worked :slight_smile:
I hope it will work with you.