max 2011 -- Why is scale in Material Preview Window so different from max units?


#1

When you’ve got a preview window open working on a material, and you’re working on, say, a noise map, why is the scale of the ‘noise’ size so vastly different than when it is applied to an object in max and rendered?

An example: I’ve applied a standard material with a noise map (noise size = 1) to a sphere. in the first image, you see the preview window for the material as I work on it. The noise scale is so small that it’s hard to see what I’m working on. In the second image you see the render sphere with the size 1 noise on a 12 inch sphere. Quite different.

Just wondering why this happens – or if there’s a way to make the preview window show a different scale.

Thanks,
Mahlon


#2

In the CME options (in the preferences) there is a control for procedural scale. You will need to adjust that, don’t remember if those controls are exposed through SME or not at this time.

-Eric


#3

The default scale for procedural maps in the Material Editor Options is 300.0. To make it match the scene objects scale, you have to set it to 50.0.

For example, create a Standard Material with Cellular Diffuse Map. Apply to a square Plane of arbitrary size. The Cellular Map uses the Object XYZ by default and will appear relatively large.
Now open the Material Editor Options and enter 50.0 for the “Render Sample Size” value. If you display the Cellular Map’s level only in the CME, you will see that it matches the plane’s texture perfectly.

Keep in mind that 3D procedural textures use a 2D rendering of the map to represent it in the viewport (and THAT’S what renders with a scale of 50.0). The same applies to previewing the MAP LEVEL of the map in the Editor. But when you render a 3D texture in Scanline renderer or on a Sample Sphere in the Editor, the actual 3D map will be rendered, thus it might look different between the 2D and 3D representation even with the lower Render Sample Size.


#4

Man, you guys are great. Thanks! :beer:

Mahlon


#5

As always Bobo, many thanks, I didn’t know that even existed!


#6

Thanks from me as well, this was bugging me longtime!!

I wonder why 50.0 isnt the default value in the first place…

Oh, and it seems the SME inherits this value from the CME, altough the SME doesn’t have this value in the options itself.


#7

Well if that wasn’t just a little bit of enlightening information.:slight_smile:

EDIT: nevermind…


#8

Funny, for me ‘25’ is the correct value.

Mahlon


#9

Hmm, compared to the default 300 - 25 or 50 isnt that much of a difference. Both look ‘correct’ in that sense :thumbsup:


#10

I meant ‘correct’ as in 1 to 1 scale between material preview and rendered image. OIn my system, setting the default to 25 gives me the same scale in a render as it shows in the material preview. Setting it to 50 gives me a smaller scale in the material preview than the render.

Mahlon


#11

actually, i guess you’re right. indeed, 25.0 looks a lot more 1:1ish… well, then i vote for 25.0 as default value :smiley:

anyhow 300 seems bonkers. still wondering… :wip:


#12

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.