Mapping: Smooth Transition Between 2 Channels


#1

Let me preface this by saying to pls ignore the crappy material I’m using in this test. I made something quick that illustrates what I’m trying to avoid. And the model is nowhere near being done so ignore that for the most part too :slight_smile:

I made a quick test of a figure, similar to a Godzilla-type character. What I’m concerned about is getting the overall skin texture to blend between different mapped parts of the body. For instance, if a monster was covered with scales, they would align one way, up and down the torso, and they’d align another way along the legs, I can’t just use one cylindrical UV map. So, what I tried doing in the following test was this:

I set all polys in the body to a Material ID of 1 and applied a cylindrical map along the length of the torso. I then selected the arm polys (individually), set the MatIDs of the arm polys to 2, and applied a cylindrical map to them along the length of them. I then collapsed the stack and applied an Unwrap modifier.

The problem is, the place where the arms meet the torso has a definite line showing where one texture ends and the other begins. I’m wanting to get a smooth transition of some sort so it looks like it’s one smooth texture covering the entire body.

So how does one go about creating these smooth joints? I’ve seen some people say to have one skin texture and to keep your details within the maps so they don’t touch. This works fine with a human skin-type texture where there’s no real up and down. However, with a monster character like this, there is a definite texture pattern, either ridges, or scales or bumps, that almost always runs over the whole body.

Any help would be great.


#2

I’ll try to explain a way pretty fast.
Map the arm and body with seperate mapping channels so that they overlap a bit over each other. The armtexture will go a bit over the shoulder-polygons and the bodytexture a bit over the arm-polygons. Don’t worry about material id’s.

Use a blend material with the body and arm materials in the two slots. For the blend map you add another UVW-map for the whole character from the front for example and set it to a new mapping channel. Then draw a map that could look something like this:

Use this map in the blend slot and set it to the new mapping channel, then you have a smooth transition.

CML


#3

Same idea…
http://www.neilblevins.com/cg_education/map_channels/map_channels.htm


#4

Ive been looking into blending textures this way on a character like this, and Ive been messing around with Neil’s tutorial, is it possible to use UVunwrap to tweak each UV individually? I cant seem to get that to work.


#5

Just yesterday I got Max Slop back online. Not many tutorials yet, but some about blending using mapping channels.

Max Slop


#6

any way of getting UVunwrap into the process? Or is it simply planar or cylindrical mapping used on each surface. Seems a bit limited, but I’ll try this approach, its very useful. cheers


#7

You certainly could use UVW Unwrap… just make sure each separate UVW Mapping modifier is set to a different UVW channel #. Then you can edit and adjust them separately, adjusting each channel with a single UVW Unwrap, since Unwrap only allows you to edit one UVW channel at a time.


#8

yep, that does work, thanks!


#9

I’m still having problems. I went through the tutorial listed above and rendered out the result fine when using a procedural noise map. However, when I simply replaced his noise maps with a bitmap texture, the results looked nothing alike:


All I did was replace the texture. All the UVs and everything else is the same.

So what am I doing wrong? Why can’t I get the grain of the texture map to run along the length of the brach as well as down the trunk?


#10

Have you considered to try using vertex color as blend map in blend material?
With vertex color over a detailed mesh you can have a very good control where the two mat. blends…

Daniel.


#11

The noise map is a procedrual 3D map. The object is “swimming” in it.
A bitmap is a 2D map and will be projected on to the model.
You will ned 2 map channels like the arm/body problem erlier in this thread.
Note that there are options for 2D/3D in the Material/Map Browser.
There you can see if a map is 2D or 3D.

You could try the Shrink Wrap option in the UVW modifier.

Conny


#12

If the material is setup the same, it could be that the bitmaps aren’t set to use the appropriate UV channels…?


#13

Here’s the file so you can see. I laid him out with UVs and matierials just like the tutorial file that EricChadwick posted the link to (also shown above as my tree stump samples). But as you an see, it’s not working when I apply the bitmap. I know this can be done but it’s driving me crazy.
http://www.allizdog.com/temp/ChannelTest.zip


The torso is a cylindrical UW channel 1,
The arm is a cylindrical UW channel 2,
The leg is a cylindrical UW channel 3,
And the blend is a planar map of the whole frontal view on channel 4.


#14

Hmmm, max6 file. I’m still in max5 here. All I can suggest is double-check your material settings. Make sure each bitmap is set to the appropriate UV channel.


#15

Eric, I love you! I was totally missing the bitmap channel!


Nothing fancy yet, but as you can see, the arm and torso are now both going in the directions they need to be!

Thanks SO much for your help. I knew it just had to be something small I was missing.

BTW, is there any way for me to save Max6 files so that a 5 or lower user can view them? If not, that’s just dumb.


#16

Glad it worked for you. It’s the little things that always get me too.

BFF might save from 6 to 5, not sure.
http://www.scriptspot.com/bobo/darkmoon/bff/


#17

hi
Im having a few problems getting this to work. Imagine the sphere is the head, and Im trying to create seperate UV’s mapping for the top (planar). The red texture is the material 1 entry in the composite texure (channel2) and the blue texture is using a mask in the opacity slot in material 2 (channel 3), so that would be the top of the head as I said.

How do I stop the mapping from going through to the other side of the model, in this case the underneath of the sphere. Can I isolate those top poly’s somehow so I can have UV’s projected from any direction?

I hope this makes sense. Thanks for any help.


#18

incidently, I didnt want to hijack this thread Waple, I could start a new one for my problem with UV/channels, just seemed relevant to what you were doing. cheers.


#19

Hey, no problem at all. I learn most of what I know from other people’s problems and answers.

I would assume that the reason you see the bleed-thru on the bottom is because you are using that planar map, which does apply the map to the front and back (or top and bottom in this case).

If you’re using a sphere, try using a spherical uv map.

In my sample stuff, the planar map was basicly the transition map, or the mask, (like transitioning from the body to the arm). all the other maps, like the one for the torso and the arm, were cylindrical, where a pixel is only represented in one place (unlike the planar where there is a front pixel and a reversed pixed directly behind it).

Hope I’m making sense. I’m about to go to bed and can barely think straigggggggggg


#20

cool. Funny, using a sphereical map never cossed my mind:banghead: :smiley: Ill give this a shot shortly. thanks