(Mac) Silo 2.3 Can't Be Opened-Identity of Developer Cannot Be Confirmed


#1

Hi, everyone,

I was just wondering if anyone has had this same error when installing Silo 2.3 on a Mac.
I’m currently using a Mac Pro, Mavericks setup. My previous version of Silo (2.2) works fine, so I’m really puzzled as to why this version won’t even install.

The full error message is:

“Silo 2.3 Can’t be opened because the identity of the developer cannot be confirmed”

Does anyone have any ideas?
I’ve re-downloaded it and tried to reinstall it a few times, but I’ve just got the same error message again and again.

Thanks, everyone! I really appreciate your help!