linear workflow banding issues


#1

Hello everyone,

I am new to Maya and am still getting a feel for a linear work flow. I am trying to set up a sky sphere with a 3 point north to south incandescence ramp. Despite all of my fiddling I can’t seem to get a smooth gradient, instead I get a toon shader like stepped gradient.

Having scoured your forums I’ve gotten this far:

render settings:

default input profile: sRGB
default output profle: Linear sRGB

render view Color Management:

image color profile: Linear sRGB
display color profile: sRGB

Frame Buffer:
RGBA (float) 4x 32 bit
Gamma 1

Rendering:
Mental Ray
32 - bit - floating point HDR

I am not using any lens shaders, mental ray material nodes (though I plan to) or gamma correction nodes.

final gather: off
global illumination: off

Could you offer some advise?

Thanks!

Rondo


#2

To be sure that maya is not the source of disply problems, try to look at the image in imf_disp or any compositing package. There you can see the the color values as well, so you can check if you have really 32bit data in your image.


#3

try switching to 32 bit render view (it’s in the same menu as the color managment option in the render view panel) if you haven´t done it already.
It requires a Maya restart to have an effect :slight_smile:


#4

This might be the same problem I had recently and I described in a comment on elementalray blog: http://elementalray.wordpress.com/2011/11/23/linear-color-workflows-in-maya/#comment-56

Try to create gamma nodes manually for your ramp, to see if it fixes the problem. And yes, make sure your renderview is in 32bits (I wonder why it’s not like that by default).


#5

I’ve also had banding issues caused by the Vignetting feature of the Photographic Lens shader, just as an extra thought.


#6

Thanks for getting back to me!

Chafouin it does sound a bit like your issue, did you manage to fix it?

here are some more details:

I am using osx lion on a mac pro, maya 2012 Hotfix 2, 64bit.

I have set render view to 32 bit and reset Maya, restarted the computer.

now when I save the file from render view (either iff or tiff) and open it in Photoshop (cs5.5) the image is saved as 8 bit and still banded.

when I do a batch render and open the image in Photoshop I’ve gotten 3 different results:

saved as iff = 8bit, banded
saved as tiff (uncompressed) = 8bit, banded
saved as openEXR = 32 bit, banded

the shader network looks like this:

place2dTexture>ramp(outColor)>(value1)gammaCorrect(.454)(outValue)>(incandescence)lambert5>lambert5SG

Judging by the different saving results I’ve gotten it would seem that Maya is still saving the file as 8 bit then (in the case of the open EXR) converting the file to 32.

do you guys know what am I missing?

Thanks again!


#7

I have had something similar with cheaper/uncalibrated monitors. Try creating an empty document in photoshop and create a ramp in 32 bit then convert it to bit8 if you see banding on both it probably has something to do with your monitor or display settings. I had a cheaper dell monitor that whenever i did a ramp there was a really harsh line between the lowest dark value and white I no longer have this problem with apple cinema displays.

Also if you using a ramp in maya set it to smooth rather than linear.


#8

I don’t think we are having the same issue as for me, using any other linear workflow pipeline than the integrated maya color management fixes it.


#9

sebastianf: I tried your photoshop test, so long as the gradient is created in photoshop it turns out fine. I am using a dell 2408wfp set to sRGB. It would seem that the issue is originating in maya.

chafouin: I did not start to have banding issues until I started using Maya’s color management. (I switched due to color change and color bleed issues). Could you please describe your workflow to me? Does it produce consistent color in both the render view and final batch render?

Thanks for your input guys!


#10

I’m not sure, but this may be the issue you guys are coming across:

When converting a floating point image to 8bit, if you don’t introduce any error diffusion (or dithering) you can end up with banding, which is really rounding issues on subtle gradients. It’ll look like this:

[](http://imageshack.us/photo/my-images/507/image1wcj.png/)[u]

[/u] However once you introduce some some error diffusion/dithering (which is really just noise), before converting to 8bit, it will fix the rounding issues and get rid of the banding:

A lot of programs like nuke do this inside the viewer (when its set to 8 bit), but I always add a dither node to clean it up for final output.


#11

Mercutio: Thank you for pointing that out. It seems that I have had dithering enabled the whole time, yet enabling it and disabling it between renders seems to make no noticeable difference.

My goal is to render out either RGBA 4x32bit float or RGBA 4x16bit half.

I think I have everything set up correctly, but Maya seems to be rendering in 8 bit regardless.

Either I have my settings wrong or Maya is ignoring them.

Is my set up wrong? If not do you guys know of a work around?

Thanks again!


#12

The dithering setting in maya seems to have no effect, in my example above, the renderview showed banding. The EXR file is actually fine with no banding. Take it into a compositing app, add dithering before you save it out to a 8bit format and it will be all good.


#13

Hi
I’m not sure if this can help, but do you have tiffLoader.mll and openEXRloader.mll loaded in your PLug-in Manager? also when saving as 32-bit-floating point HDR format, mental ray return this warning

// Warning: (Mayatomr.Scene) : output data type “rgba_fp” not directly supported by image format hdr, conversion performed by mental ray //
but the image is saved as 32 bit format, and no warning msg when saving other format like exr or tiff.
/Rachid


#14

The linear workflow system that it giving me banding problems is this one:

  • Use a 8bits texture with a full range from 0 to 1 (tiff, tga, png, jpg…).
  • Use a normal spotlight, or a physical sky (remember to change the gamma to 1 in camera lens)
  • Enable maya color management in the render settings, from sRGB to Linear. Change the framebuffer settings to RGBA Float (32bits), in the quality tab.
  • In the render view, in display, turn on 32 bits, and change color management to Linear to sRGB.
  • I notice banding effects and compression color artifacts in dark colors, with a value around 20-25%. In the render view and in batch rendered 32bits EXR.

To fix it, I have different possibilities:
First disable color management, and use one of those solutions:

  • EXR 32 bits textures instead of 8bits ones
  • use gamma correct node with the 8bits texture
  • Mental Core color management

Tomorrow I’ll post images and maybe a simple scene so you can try and check if I’m the only one having this problem.


#15

maybe this is a silly question, but just to be sure… did you set the framebuffer in the quality tab to rgba 4x32 float? (or half)


#16

Yes I did (forgot to write it in the description, I’m fixing that :wink: ).


#17

Well I’m glad at least that MentalCore solves this for you :thumbsup:


#18

Batch render is saving 32 bit tif files now, still seeing banding.

nookie: yep!

Archory: Yes I do have those plugins running, I’m not seeing that error, thanks for the input!

Mercutio: Thank you for the suggestion, adding dithering in after effects does seem to help a bit. Is there a way to smooth the noise?

What is mental core? Is there a demo available for mac?

chafouin: Thank you. I have noticed the banding is particularly strong in the darks of my ramp and in the darks of physical sky. We may have the the same problem. A scene set up would be particularly helpful, if you get a chance to put one together I would very much appreciate it.


#19

Here is an image to show the different results:

I redid the scene almost 10 times to be sure it wasn’t a stupid mistake from me. So either I just don’t know how to use maya color management (but this should be pretty straight forward), or there is a real bug here.


#20

If this is the most recent service pack of Maya 2012 you should report this as a bug to AD.

If you have a small test scene I’d like to test and send to my sources too for future builds.