Lambert with Layered texture and png with white information


#1

Hello,

I’m doing some simple renderings for roadway stuff and I am having trouble with the layered texture node.

http://www.youtube.com/watch?v=9WGCQAmzkFM&feature=youtu.be

I have a Lambert with the layered texture going into the diffuse.

The fist layer is a “.png” with only the lane lines(yellow, and white stripes). blend mode set to “over” and the second layer is a tileable asphalt texture.

it shows up correctly in the viewport but it renders all white except where the yellow stripe is.

so how do i get the asphalt to tile and the lane line information to overlay like it looks in the viewport?

Thanks in advanced.
Emerson


#2

.png files can be tricky, you’re better off using multiple files generally. One for the diffuse and one for the alpha, for example. But you can try setting “Alpha is Luminance” in your .png file’s texture node, and perhaps that will work?

But if you’re using mental ray, you should be using the mia_mat_x, and not Lamberts and Blinns.


#3

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.