*Locate the file in the \Scripts sub-folder of the Krakatoa MX installation. Note that you need Administrator rights to modify files under Program Files sub-folders!
*Open it in the MAXScript Editor and Search for the line “on btn_createNewSelSet pressed do”. This is around line 8300, your version may vary.
*Modify the object collection code following it like this:

	on btn_createNewSelSet pressed do
		if selection.count > 0 then
			if edt_createNewSelSet.text != "" then
				local theObjects = for o in selection where (findItem geometryClass.classes (classof o) > 0 and findItem #(TargetObject, KrakatoaPrtLoader, PF_Source, PRT_Volume, PRT_FumeFX, PRT_Source, PRT_Surface, PRT_Hair, PRT_Maker) (classof o.baseobject) == 0) OR (classof o.baseobject == XRefObject AND isKindOf o.actualBaseObject GeometryClass) collect o
				if theObjects.count > 0 then

In the above snippet, I have added the code “OR (classof o.baseobject == XRefObject AND isKindOf o.actualBaseObject GeometryClass)” which handles XRef Objects that contain a GeometryClass object.

*Press Ctrl+S to save the file (remember you need Administrator rights to do so).
*Press Ctrl+E to reevaluate it, then open the Krakatoa GUI again - you should be able to add Geometry XRef Objects to the Selection Set now.


Hey guys,

I have a small question about PRT loader Timing (graph animation) My englishis very bad so I try to show you the problem with screenshots and video.
I have loaded partciles and animate they timing from 50 to 60

rendered partciles witn normal channel:

as you can see result is “lagy” How to get smooth motion ?



I would say it’s because you didn’t calculated subframes or enabled “interpolate sub frames”. But when I looked closely, I saw that particle movement is smooth, and the lagged thing is this color, or texture.
What material or texture did you applyed to particles, may be some kind of particle age, or something else, which doesn’t calcuates subbframes?


Hello. Thanks for reply

No material. Color by normal like this.

Few days ago I was resimulate fumefx with retime and I get same result like on video in my previous post: partciles moved slowly with no lag but colors moved with laggs


am using krakatoa to render hair put it happened in some cases i get the particles not on hair it self as it should
it seams offset most of the inside the the objects
and this effect the render and the dos not appear at the frame as am using the matte object option
can i get some hints about the reason of this and if someone could figure a solve
here screen shot for what I mean


When i use this method i reciev solid color in render element. But i need element contain beauty pass for prt loader. Its can get with magma?


Hello guys,
quick question. it’s possible to render point position pass ?


In custom render element put position to color


thank you )


Hi, my matte object contain a vray displacement mod…how can I obtain right (displaced) borders on matte mask?
Again, are scattered objects (like trees in multiscatter or forest) well read from matte mask?


I don’t think you can get the rendertime displacement, unfortunately.

The scattered objects - should work if they create a max mesh at rendertime, but probably not, if they are vray meshes.


Did anybody try this?
Have you been successful?


One and half bad news at once…good starting sunday, however thanks Hristo for fast reply.

I’ll try to solve with depth + id color masks but I’m a bit puzzled about some Krakatoa (in)capabilities.

Back then, I've tried using the Depth Map Sequence feature of Krakatoa. All you need is a z-depth render pass from any renderer you're using.
I still have my notes just in case I forgot anything important in setting it up:

[li]Render a regular z-depth pass (take note of the near/far z distance)[/li][li]Save it as an .exr (16bit or 32bit - either)[/li][li]Render sizes should be the same.[/li][li]You can double the zdepth render size, and set sampling to 2 for the depth map[/li][li]Enable both ‘Use Matte Objects’ and ‘Use Depth Map Files’ for it to work.[/li][li]Set it to ‘Inverted Normalized Z Depth’[/li][li]Set the near/far z the same as your zdepth pass.[/li][li]You may also enable ‘save multiple layers’ if you want to get a render of the occluded particles (bits that were cut off by the matte). Usefull for comping in with transparent objects.[/li][/ul]

Also, I forgot the version that I was using back then… so some things may have been changed/updated in the newer versions.

I hope this helps :)


Hey Jeff, thanks for this tricky advise…
on the thinkbox forum someone spoked about that but as a finished tool inside Krakatoa MX and not present in maya version…now is clear that is a workaround :wink:


Ok, Hristo (for scattered mesh) and Jeff (for real displace matte)…you solved my problem, thanks again.
Now I’m starting with other issues like krakatoa flickering…but this is another story :slight_smile:



I can’t get to work Magma shortcuts. I tried on/off max shortcuts override toggle, nothing.Whenever I have an already existing shortcut in max Magma is ignoring own shortcuts.

What do I do to make Magma use shortcuts and ignore max shortcuts?



I cannot find a node that does the per-point random calc. So I guess this has to be done manually. How can I do that? Input script (random -value +value) gives one same value for all points.


Ok found that there is an input channel called RandomValue. Somehow it does not work, errors out. It looks like its actually looking for an actual channel called RandomValue. So I have to recache anyways… ;(


See my answer in your duplicate post one forum higher.