Krakatoa


#1943

Thanks, zoubein, I have found the way to do it in this topic, using Magma Editor. It’s quite hard for me to understand, but I think I figured it out.

Another strange thing I run into - I can’t use Xref objects as matte objects in Krakatoa :surprised
Xref objects are 3d objects too, why can’t krakatoa use them? When I select them and hit “create\update matte set” it says that there aren’t any valid objects in selection.


#1944

That is a UI bug, and totally my fault. The reason we never caught it (and you are the first to report it AFAIK) is that XRefs were forbidden at Frantic Films where Krakatoa was originally developed. :wink:

Thankfully, the existing Matte Objects rollout of Krakatoa does not force you to use its own Selection Set, you can select the XRefs and create your own Named Selection Set by entering a custom name in the “Create Selection Set” field of the 3ds Max Main Toolbar. Then just add that name to the Matte Objects Named Selection Sets list of Krakatoa. I just tested this and Krakatoa itself does not mind rendering the XReffed object as Matte.

I have fixed the UI test to account for XRef Objects containing geometry. If you want to know how to fix the UI yourself without waiting for us to release the next update, please let me know.


#1945

Wow, thank you VERY VERY MUCH, Bobo!! Because I have a huuge scene and when rendering Krakatoa, I merged all 3d models in scene, then added them in krakatoa as matt objects and so on.
I just didn’t know that Krakatoa supports 3ds max native Selection Sets(actually, I almost never used it).
Thank you for suggesting this method!

And I would love to know how to fix the Krakatoa UI as well, so if you could write how to do this, I think all who encountered this problem will be very happy :applause:


#1946

*Locate the file KrakatoaGUI.ms in the \Scripts sub-folder of the Krakatoa MX installation. Note that you need Administrator rights to modify files under Program Files sub-folders!
*Open it in the MAXScript Editor and Search for the line “on btn_createNewSelSet pressed do”. This is around line 8300, your version may vary.
*Modify the object collection code following it like this:

	on btn_createNewSelSet pressed do
	(
		if selection.count > 0 then
		(
			if edt_createNewSelSet.text != "" then
			(
				local theObjects = for o in selection where (findItem geometryClass.classes (classof o) > 0 and findItem #(TargetObject, KrakatoaPrtLoader, PF_Source, PRT_Volume, PRT_FumeFX, PRT_Source, PRT_Surface, PRT_Hair, PRT_Maker) (classof o.baseobject) == 0) OR (classof o.baseobject == XRefObject AND isKindOf o.actualBaseObject GeometryClass) collect o
				if theObjects.count > 0 then
				(

In the above snippet, I have added the code “OR (classof o.baseobject == XRefObject AND isKindOf o.actualBaseObject GeometryClass)” which handles XRef Objects that contain a GeometryClass object.

*Press Ctrl+S to save the file (remember you need Administrator rights to do so).
*Press Ctrl+E to reevaluate it, then open the Krakatoa GUI again - you should be able to add Geometry XRef Objects to the Selection Set now.


#1947

Hey guys,

I have a small question about PRT loader Timing (graph animation) My englishis very bad so I try to show you the problem with screenshots and video.
I have loaded partciles and animate they timing from 50 to 60

rendered partciles witn normal channel:
https://dl.dropboxusercontent.com/u/79532822/lag.mov

as you can see result is “lagy” How to get smooth motion ?

thanks


#1948

I would say it’s because you didn’t calculated subframes or enabled “interpolate sub frames”. But when I looked closely, I saw that particle movement is smooth, and the lagged thing is this color, or texture.
What material or texture did you applyed to particles, may be some kind of particle age, or something else, which doesn’t calcuates subbframes?


#1949

Hello. Thanks for reply

No material. Color by normal like this.

Few days ago I was resimulate fumefx with retime and I get same result like on video in my previous post: partciles moved slowly with no lag but colors moved with laggs


#1950

hi
am using krakatoa to render hair put it happened in some cases i get the particles not on hair it self as it should
it seams offset most of the inside the the objects
and this effect the render and the dos not appear at the frame as am using the matte object option
can i get some hints about the reason of this and if someone could figure a solve
here screen shot for what I mean


#1951

When i use this method i reciev solid color in render element. But i need element contain beauty pass for prt loader. Its can get with magma?


#1952

Hello guys,
quick question. it’s possible to render point position pass ?


#1953

In custom render element put position to color


#1954

thank you )


#1955

Hi, my matte object contain a vray displacement mod…how can I obtain right (displaced) borders on matte mask?
Again, are scattered objects (like trees in multiscatter or forest) well read from matte mask?
Thanks.


#1956

I don’t think you can get the rendertime displacement, unfortunately.

The scattered objects - should work if they create a max mesh at rendertime, but probably not, if they are vray meshes.


#1957

Did anybody try this?
Have you been successful?


#1958

One and half bad news at once…good starting sunday, however thanks Hristo for fast reply.

I’ll try to solve with depth + id color masks but I’m a bit puzzled about some Krakatoa (in)capabilities.


#1959
Back then, I've tried using the Depth Map Sequence feature of Krakatoa. All you need is a z-depth render pass from any renderer you're using.
I still have my notes just in case I forgot anything important in setting it up:

[ul]
[li]Render a regular z-depth pass (take note of the near/far z distance)[/li][li]Save it as an .exr (16bit or 32bit - either)[/li][li]Render sizes should be the same.[/li][li]You can double the zdepth render size, and set sampling to 2 for the depth map[/li][li]Enable both ‘Use Matte Objects’ and ‘Use Depth Map Files’ for it to work.[/li][li]Set it to ‘Inverted Normalized Z Depth’[/li][li]Set the near/far z the same as your zdepth pass.[/li][li]You may also enable ‘save multiple layers’ if you want to get a render of the occluded particles (bits that were cut off by the matte). Usefull for comping in with transparent objects.[/li][/ul]

Also, I forgot the version that I was using back then… so some things may have been changed/updated in the newer versions.

I hope this helps :)

#1960

Hey Jeff, thanks for this tricky advise…
on the thinkbox forum someone spoked about that but as a finished tool inside Krakatoa MX and not present in maya version…now is clear that is a workaround :wink:


#1961

Ok, Hristo (for scattered mesh) and Jeff (for real displace matte)…you solved my problem, thanks again.
Now I’m starting with other issues like krakatoa flickering…but this is another story :slight_smile:


#1962

Hi,

I can’t get to work Magma shortcuts. I tried on/off max shortcuts override toggle, nothing.Whenever I have an already existing shortcut in max Magma is ignoring own shortcuts.

What do I do to make Magma use shortcuts and ignore max shortcuts?