Koshigaya OpenEXR Viewer 1.0


#1

Hi,

I’m using OpenEXR Images in my current Project… and since there isn’t a nice tool to view them on Windows, I made one :stuck_out_tongue:

Since it’s only a few hours old, it’s still Beta… not sure if it’s working on any machine etc… :slight_smile:

Features:

  • Exposure control
  • Gamma control
  • Channel Selection

When you open an EXR Image you’ll see a list with the Channel Names at the left upper side of the Programm. Now you can Drag&Drop them to the R, G and B Value :slight_smile:

So it’s possible to view Images with more then “R”, “G” and “B” Channel very easy :slight_smile:

Download:
http://koshigaya.de/?content=downloadFile&fileName=KoshigayaOpenEXRViewer.rar (~320kb)

If you find any bugs, please tell me!

Au’revoir,
Aya~

PS: Your GraphicCard have to support Shaders!


#2

Hey, nice tool. Seems to be loading all of my EXRs without any problems.

Just want to clarify one thing, though: If the exposure and gamma settings aren’t working, is that likely to be a graphics card issue?


#3

Anything I have to take care while installing? I just put both files into a folder, no?
Because I get an error, when starting (The application failed to initialize properly (0xc0150002).)


#4

Hi,

mhh… It’s a problem with the GraphicCard, yes… but I uploaded a new Version, try if it’s working now please :slight_smile:

There’s nothing special to do… but please try the new Version too, I fixed some bugs… :slight_smile:

Au’revoir,
Aya~


#5

me too.

ciao
francesca


#6

Mhh… could you tell me what Windows, CPU and GraphicCard you are using? :slight_smile:

And… does the error occur as soon as you start the Program or when you open an Image? (Have you extracted the RAR Archive?)

Aya~


#7

I just redownloaded it. Put both files in a Folder (C:\Program Files (x86)\OpenEXRViewer), double click on the exe, and get the same error.
No Image is infolfed.

I’m usind Windows XP 64bit, Dual Opteron 285, Quadro FX 3450.
Anything else I could test?


#8

Hi,

I don’t realy have an idea what’s the problem… so I made a “debug” version for you :stuck_out_tongue:
Please download this:

http://www.koshigaya.de/misc/KoshigayaOpenEXRViewer_Debug.rar

After you started it, you’ll see Message windows like “Step 1”… please tell me what’s the last Step you get :slight_smile:

Aya~


#9

Yeah, exposure/gamma still isn’t working. I’m using an ATI card though (R9800, to be specific), so if it’s based on OpenGl, then that would probably explain it…


#10

Hi,

yep it’s OpenGL… :slight_smile:
Could you download the “debug” version too and see if there are any Shader-Errors displayed?

Aya~


#11

Sure. Tried the debug. It gets an error at step 4: “Link failed: All shader objects have not been successfully compiled.” But nothing more specific than that.


#12

Actually, an openEXR viewer does exist, made by ILM, at: http://www.openexr.com/using.html
which you can download at the download section.


#13

Koshigaya’s OpenEXR Viewer has also channel selection feature… I don’t think ILM’s viewer has this feature…


#14

It doesn’t work (0xc0150002) even the debug version :frowning:


#15

Hey Aya. I just downlaoded and tested it, unfortunatly same error as befor. So it doesn’t even go up to where your debug mode starts. :frowning:
Could it be WinXP 64 bit issue? Compiler settings?

cheers


#16

Hi,

sure… but it’s very uncomfortable :slight_smile:

About the problems… I’ll see what I can do, but right now I’m not sure what the problem is… eventually the 64bit Windows, but I don’t think anyone with this error uses 64bit… :slight_smile:

I’ll try my best :slight_smile:

Aya~


#17

well dont mean to put you or your efforts down, but there are quite a bunch of sequence players out there that DO support EXR and channels…for example iridas’ framecycler or tvplayer flipbook.

Regards,
Thorsten


#18

Hi,

I think I found one error, but am not sure if it’s the reason for the problems…

http://koshigaya.de/?content=downloadFile&fileName=KoshigayaOpenEXRViewer.rar
Please download and see, if there’s a Error Message at the start :slight_smile:

Mh… ok, didn’t knew this. But if someone don’t want to use my Viewer he don’t have to :wink: I built it mainly for my own use and just thought “Why not sharing it?”

Aya~


#19

Can you please rename the RAR file, I think I’m not able to get to the new one, either your Server or my Firefox / Windows is caching it somewhere (because it’s same filename).

cheers
dany


#20

Yep, done :slight_smile:
http://www.koshigaya.de/misc/KoshigayaOpenEXRViewer_new.rar

Aya~