issue with .RPF in physical renderer


#1

[I also posted this at C4D Café]

I haven’t had much cause to use the physical render options in R13. However, I’m trying so now, and have immediately encountered a problem which would preclude me from ever using the feature.

I’m rendering to an .RPF sequence to have access to the additional data in post (AE). However, right away I’m finding that data is missing. For instance, the z-depth data is missing.

Is there a setting / pref / check-box which would fix this? I hope (!). Or this this a horrible limitation of the C4D Physical Render system?

Thanks.


#2

Are you rendering locally or on net?

If its NET there is a limitation where depth does not render to rpf/rla files


#3

Rendering local. Just a single machine. Just to make sure, I rendered a test frame with the “Standard” render engine enabled, and it worked properly, as it should. So, it’s definitely the Physical Render engine.


#4

Ahh–sounds like a bug


#5

Hmm…not good. Anyone else have experience with this?


#6

I’d contact Maxon if I were you. Did a search and this was mentioned in another forum a year ago, so it seems to be a known limitation. You might want to try a different route for depth.
Good luck!

http://mograph.net/board/index.php?showtopic=27203


#7

Would RLA work instead? Haven’t used it in a while, though.

You are setting the correct “Options” next to the RPF parameter in the Render Settings’ “Save” tab?


#8

You know. That’s a good question. I’ll have to try RLA when a machine frees up. I honestly don’t even have a clue what the difference is, between those two formats. Do you? I’ve always just used .RPF with Cinema.

And, yes, I’ve made sure that all the export options are enabled in the options tab. I wish that had just been the problem…


#9

As far as I know, RLA is the older of the two formats, and I’m pretty sure AE supports it–or it used to. I’m thinking least common denominator in the pipeline here. Might work, might not. Give it a try and we’ll both know.


#10

Definitely, the right way of thinking.
But alas, it doesn’t work, either. Clearly, it’s a bug / limitation of the physical render engine in R13.

Anyone with R14 care to test this out?


#11

I’ve got the latest R14 and AE. Send me a file and I’ll test it out for you.
arik at scientiaviz dot com.


#12

Thank you for the offer. I actually can’t send you what I’m working on, because it’s a client’s product CAD.
But if you feel inclined, you could just make a primitive cube, and export the and .RPF still into AE. Then just a quick application of any one of of the 3D Channel plugs will tell you whether R14 is working.


#13

Yikes!
Looks like there might be a bug here when rendering out RLA and RPF out of Physical Renderer.
I tried RLA and RPF in r14 and cs6 and the depth map is not there.


#14

Wow! That’s horrible. At least that will save me from the absurdity of upgrading to R14 to attempt to solve this issue. But what in the world is the reason for that disconnect, I wonder? The additional info contained in the RPF/RLA files is 100% geometry-based. It’s got nothing to do with materials, hence the lack of alpha and transparency. And the Physical Render engine only regards lighting, materials, and post effects.

There simply shouldn’t be any reason for a bug like this.


#15

There’s also a bug in the r13 Physical Renderer when trying to export an AE scene file. It simply locks up the app for me on OSX. I have seen it mentioned elsewhere. The solution is to simply switch over to Standard Renderer and hit the save button. I don’t know why having it set to Physical would crash the app for the same scene file. Not sure if that’s fixed in r14?


#16

Anyone know if this is supposed to get fixed?
Fairly unsettling, as I would never render out a project without the flexibility of the extra control in post which you get from a file like .RPF.


#17

I asked in your other thread, but I’ll also ask here. What extra control/passes do you need from RLA/RPF that you can’t get from using the standard multipass with any file format and the various bridges that C4D has to composting apps?


#18

Sorry for the massive delay. I had lost track of this thread.
Most important (to my personal workflow) is the access to the Z-Depth information, stored inside the RPF/RLA format. I’m not talking about just the greyscale depth pass, but the z-depth channel. AfterEffects can read that with some of its 3D Channel filters, and I use those extensively.


#19

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.