Is there anyone who can help me with the issues I'm having in Silo please?


#1

I just started using Silo the other day since I can’t use anything commercially with the student version of 3ds Max. And since I’m used to 3ds Max I was hoping for any help and guidance from those who’ve made the switch like I have. How have you adapted to Silo, what limitations are there, and how did you solve the problems you were having?
Thank you in advance. :slight_smile: Oh and sorry it’s long.

1• If I click options to create a shape (let’s say a Cylinder, for this example) values appear to change height and segments etc., but if I go to the viewport to look at the cylinder, sometimes, when I go back to edit the values, it decides to stop changing anything. How do I make it go back to affecting the values of the Cylinder when this happens? In 3ds Max you could look around to see how it’s changed, click off the shape etc. and could do this until you turned the shape into an editable poly.

2• If I lose the view of my model in the viewport (it’s happened before when I’ve imported another mesh and the pan/rotation goes wild), how do I return to it?

3• Are there Smoothing Groups in Silo? Or if not, what’s the closest method to it? I’m creating weapons with obvious, sharp edges – in 3ds max smoothing groups came in handy to define them, especially when I could export them to Zbrush.

4• How do I chamfer edges? Or if I can’t what’s an ideal alternative? I tried Bevel, as I read it was practically the same thing in Silo, for whatever reason, but of course it doesn’t do anything for edges in Silo, unless I’m doing something wrong there.

5• When I create a loop in 3ds max I can use options to increase the amount of loops. I assume I can’t do this in Silo and have to manually insert each loop, correct?

6• Now the inset tool doesn’t seem like the inset tool I’ve used with 3ds max. Bevel does something similar, but it protrudes outwards, which is not what I want. I don’t want to have to compensate with Bevel and move the extrusion in to match up as close as I can with the original face. Is there not a better way?

7• I’ve also got a problem with snapping. How do I snap vertices, edges, faces etc.? And I’m not talking about the merge tool. I would love to be able to move, say, four verts together and snap one to another verts and they’d line up accordingly, as it was possible in 3ds Max.

8• In regards to the Merge tool, It’s more like target weld. In 3ds Max, I could weld two verts together, and they would meet halfway. Whereas with the merge tool, it’s exactly like target weld. I assume the merge tool is all I have in Silo? It’s not a big deal, but it’s helpful sometimes to have two verts meet halfway.

9• I also liked the ability to move the transform gizmo to whatever my snap was assigned to, like vertices, for example. Is there a way to effect the transform gizmo in this way, or any way, in fact? Or a way to move the transform gizmo around? It was handy, vital even, to be able to move the transform gizmo to the centre of the object in 3ds max.


#2

For no.9 make sure you are in object mode, press f. Then press m to turn gizmo white to move it. To snap it to vertices, press a for vertex mode. Then click sel tab on the left of the screen, then select snap component. Now while the gizmo is still white, click a vertex and the gizmo will snap to the point. Press m again to get out of move mode and press f, now the transform gizmo is still where you snapped it to.

Do the same to snap it to a face (press d), and an edge(press s). To snap to grid, select snap grid and move the transform tool to snap to the grid edges.


#3
  1. I think sometime it just doesn’t work. Deselecting and re-selecting the object sometimes gets it working again (unless you have entered a component mode or added any other objects). Call it a bug, or a half-implemented feature…

  2. ctrl f will centre the view (all objects if nothing is selected, or on the current selection.

  3. No. It’s been asked about many times.

  4. Edges bevel fine for me; there is no option to adjust divisions, roundness etc. When you activate bevel you should be able to hold lmb drag to adjust width; or hold down the bevel hotkey and drag to do the same.

  5. Split loop will only insert 1 loop. To insert several loops at a time, select an edge ring (alt r) and use cut - opts to set the segments.

  6. Extrude the face(s) with zero-distance before inset.

  7. You can enable component snapping and the snapping manipulator (selection menu).

  8. Merge will only work as you say, like target weld. If you want two verts to meet, select the edge between and scale it.

  9. You can position the manipulator anywhere you like. Look for edit mode and the various orient/auto orient and positioning options in the selection menu.

You can activate manipulator edit mode and select any component to set that as the action-center. You can make it permanent by using set object axis.

Tip. you can assign hotkeys to any menu item by mousing over it and pressing a key or combination of keys.


#4

Awesome guys, thanks for the help!


#5

Thank you very much, guys! It was very helpful. :slight_smile:

Edit: So kind of got round the problem below. For smoothing groups I just exported the mesh to Blender and did them there. For some reason the scale of my mesh is incredibly small when imported to Unreal from both Silo and Blender (all perfect in 3ds Max, though). So I had to scale the mesh up in Blender to match another mesh (which is the right size from 3ds max), then when it’s imported into Unreal I changed the Unreal Unit scale of the .fbx to 0.01. I get the perfect size then - but anything I make at ‘normal’ size in Silo seems to import very, very small in 3ds Max and Unreal.

At the moment, though, I’m having a problem with exporting an object from Silo into Unreal. When I import the .obj (I can’t seem to find the .fbx export option in Silo?) into Unreal I receive two messages. One tells me the object imported very small - I thought the Generic Units in Silo were 1 unit = 1 cm? I scaled the Export Scale Factor value to 100 (and even tried the Unit scale in general settings) the next time, but it imported too large - it’s practically trial and error at this point. What does 1 generic unit actually measure? I imported a model from 3ds Max into Silo (which scales perfectly in cm in Unreal) and it was enormous.

The other message I receive when I import the .obj is that it says there’s no smoothing groups on the object, and it tells me choose this option in the .fbx export editor in Silo before importing into Unreal. I can’t seem to find any export editors/options in Silo - it just saves it as an .obj.

If someone could help with this I would very much appreciate it, thanks!


#6

Silo is abandonware.You are wasting your time it because soner or later you will have to move I recommend MayaLT or Blender.


#7

It’s a great modelling tool, though. And that’s all I need it to be. It’s limited, yes, but I have other software that I use in my workflow to produce the quality I’ve been getting in Max. And I do other stuff in Blender that Silo can’t do (smoothing groups, for example), but I find Blender a horrible experience to model in.

Besides, look at the mobile game someone on these forums created using just Silo - it’s still a nice, little software application.


#8

I see why rrrambo feels that way, but I think nevercenter doesn’t have a Silo programmer to write code for Silo updates. It will probably be a while until we see another update. Hopefully the new Update won’t be years later.


#9

I’m really late to this one, sorry. I’m guessing you’ve already gone past these problems but I couldn’t help myself. I’m a boob.

Cinnsealach is the go-to man for Silo questions. If he can’t answer your question it’s doubtful there are too many others who could. I’m a bit of a detail freak so I thought, if Cinnsealach isn’t offended, I would expand on the some of your points.

  1. I’ve given up on this and just use a trial and error method. Not the best way but so far it hasn’t caused me any real headaches.

  2. :thumbsup: What he said.

  3. :cry: bastards

  4. Again, what he said. I personalized my side menu to show Bevel Opt instead of just Bevel (as well as most of my other side menu commands). If I need no bevel I set it to zero and LMB drag to get what I want. Otherwise I set a number. Either way, a single Bevel is the same as Chamfer inside Silo. Select your two edges again, bevel and you have the traditional beveled look.

  5. I created a little tutorial about this. It’s not detailed well in the Silo help file and I figured it out through trial and error.

  6. I like to select the edge between two vertices, use the cut hotkey to add a vertex in the middle and then merge the other two with it. Again, hardly ideal but works quite fast. With Max I can never seem to get it to actually weld. Annoys the piss out of me.

  7. The tutorial I mentioned in 7. covers this in some detail. http://forums.cgsociety.org/showthread.php?f=175&t=1319321

As you have probably found out by now there is no .fbx support. I export mine as .obj, import into Max, remove the default smoothing groups and then add them as I need.

With Unreal I think I read somewhere that units should be set for Meters when exporting. I can’t remember since I haven’t used Unreal is a very long time. I had this same problem with Max until I realized I wasn’t setting my units to Meters (as I have it set in Silo) when importing.

Like I said, it’s a bit late but I hope it helps a bit.


#10

Hiya!

What you need to do is change your “Working Grid” scale and your “Units” and “Unit Scale”.

First, all this is under “Editors/Options” at the top. Pop open the “General Settings”. You need to change the Unit Scale to 100 (assuming you have Units as either Generic or Metric). Close that panel. Now go open the “Display Settings” panel. Here we change it so you can see your working grid plane. Change the Working Grid Width to 10, and Working Grid Spacing to 1.

Now, when you create your objects, they will be ‘big’ but your working grid settings will account for all that and off you go! :slight_smile:

N.B.: Silo uses Y as up/down…Unreal uses Z as up/down. So keep in mind that exporting straight from Silo will result it your object being rotated -90 in X. You could set Unreal to import it with a -90/90 X degree if you want.

As for the other errors…they are, I think, because you need to have some sort of UV’ing applied to the object. Just opening the UV editor in Silo and selecting Unwrap UV’s, then exporting seems to get rid of the “bad shading” and other errors when importing and building lighting in UE4. I think. I haven’t done much from that side of Silo…still coming to grips with it’s modeling tools (I’m still a Silo newb…barely two weeks old).


#11

If you import into 2013-16 there is an option for importing with Silo settings. If your Silo is set to meters be sure to check the ‘convert to meters’ option. I had the same scale issue until I realized this omission during import.