I'm Having this mesh problem


#1

I’m modeling a starship Enterprise, and used the knife project tool on the cylinder geometry in this image. The cylinder is perfect until I do the knife project, whereupon I get these errors.

Anyone have any suggestions for how to smooth out the geometry?

Thanks in advance.


#2

I think this might be a case of there just not being enough polygons, because what’s there is trying to make up for the new vertex points created by the knife project although this is more of a guess. Try it with a higher poly object and it’s worth checking out if Speedflow can help you in this project https://gumroad.com/l/speedflow


#3

Hmmm…I guess I thought that 96 in the cylinder circumference would be enough,. but maybe not?

Maybe I should double it to 192?

ETA: I’m probably going to pass on the paid add-on.


#4

You can do but you could also try using smooth subdivision (mess around with the values in the panel when you use this) on the shorter edges of that cylinder piece. It creates an area with denser polygons but I’m not sure if that will matter though if you don’t plan to use a displacement modifier down the line. I should’ve thought of smooth subdivision earlier, it’s pretty useful


#5

I suppose I should have mentioned that I already tried applying a subsurface modifier? LOL

I also tried changing the shading from flat to smooth, in both edit mode and in object mode, applying edge split modifier again.

I’ll make a new cylinder with 192 faces.


#6

You don’t have to model with one if you have enough polygons! Also I hope that works, otherwise there’s also just trying a bit of vertex pushing/pulling but that probably won’t solve it since it’s typically something you need to do complicated mesh editing to fix otherwise but I’m not sure what edge loop setup this would need to fix without messing around with it


#7

Ah, now I’m getting somewhere! :slight_smile:

https://irishman20.deviantart.com/art/New-Enterprise-WIP-61-717218707?ga_submit_new=10%3A1511784524

What do you think? Now, I only hope that the geometry holds up once I start cutting in the viewports.


#8

Aw nice, it looks slick to me keep up the good work


#9

I do have another question about Blender - is there a way to do a render which results in looking like the orthographic view you can get in the viewport, and not the perspective view ? Maybe changing the camera lens in some way?


#10

I figured this one out, too! Select my camera, and change the camera settings, using this video: https://www.youtube.com/watch?v=qIxLQN-V3lI