ICE Particles pick up color from image


I learned how to emit particles from a surface. The particles pick up the color from an image which has been mapped to the surface.

The surface emits particles randomly. I am trying to create a pixel effect. Therefore the emitted particles should be emitted ordered in a grid.

If I could instruct the Emit from Surface Node to emit in the order of a grid would be a way to go.

Or if I could use the veritces of the texture surface as emitters and have them pick up the color at that location. I couldn’t get it to work.

I would appreciate it, if somebody could show me how. Thanks.


If you want that particles are emitted from vertices you must use a “emit from position” node instead of “emit from surface”.


Thank you for responding Gabba.

I made progress but hit the next speed bump:

I have a
‘Generate Sample Set’ node and an ‘Add Point’ node and can generate particles from each vertex of a surface mesh. The ‘Generate Sample Set’ node is set to Emission Type ‘Point’ and Rate Type ‘Points’.

With ‘Particle Emit Location’, ‘Get Texture Map Color’, ‘Set Data’ nodes I am also able to color the particles with the image map on the mesh.

Problem is, it generates a new set of particles every frame. I would like to generate just one set and then stop. And animate just that set, let it drop to the floor for example. I can’t find a way to stop the ‘Generate Sample Set’ and ‘Add Point’ node from making new particles.

I tried it with a filter on the ‘Generate Sample Set’ node that would stop generating the samples when the amount of particles equals the amount of vertices. But the filter has to be created on an ICE tree which resides on the Emitter surface itself and not on the point cloud which generates the particles. It can not see the amount of particles created in the point cloud in the other ice tree. I am trying to use the ‘Get Pointcloud.ID’ node to see that.

Maybe I am doing it all wrong. I am just following tutorials and may be I am lacking general understanding.

I also tried following your suggestion with ‘Generate Sample Set’, ‘Get Point Position’ and ‘Emit from Position’ nodes. There I can emit just one set of particles but I did not succeed coloring them with a texture map.


Ran into the same issue a few months back while playing around with ICE, I was trying to emit 1 particle per pixel per frame for an image sequence; but to no avail.


xowgax that worked for me by setting the
‘Generate Sample Set’ node to Emission Type ‘Point’ and Rate Type ‘Points’.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.