[HowTo] Ati Radeon -> Ati FireGL (softmod)


#41

Hi… Is there any patch or script, what I must download, to Maya?
I see, that there are downloadable file, to support MAX… The Maya supports without any file, or I must download something?

I have Maya 6.5, and Radeon 9600XT


#42

Hi…
I Use Maya 6.5, And I have an 9600XT… I Want to softmod it… I have the proper driver (8.083), rivatuner… But you said: FireGL driver for MAX… Is there any driver for Maya, or it supports already?


#43

paydogs - No, there is no special driver for Maya and there is no need for such driver. Fireglmax is actually a .dll file used by 3dsmax only, not by the OS.


#44

Thx… The driver dont works…
I do the proper installation (rivatuner, patch, editing ini, firegl driver, control panel…), but after restart, both te FireGL T2, and the secondary FireGL T2 videocard fails… Don’t work…
The max res is 1280x1024@60 Hz… But the computer can’t load Control panel too, becouse the driver fail… So I must put back Omega Driver…
Is there anything what I can do? I have Sapphire Radeon 9600XT Fireblade Edition…
And I like to work with FireGL…

(and sorry guys for my english :D)


#45

Hi guys!
I personaly used difrent drivers than the ones posted at the begining of this tutorial on softmoding ati 9800 to fire gl x2.
Because when i did this soft mod Max and XSI were running great but I had minor glitches with Maya.My geometry was showing transparent in the perspective viewport.
But then i started to experiment with difrent drivers and finaly i downloaded this driver:

firegl-unified-8.103.2 from the ati site.It sopose to add suport for maya 6.5.After i downloaded this i patched just the same way was described at the begining of this tut.Unfortunately i wasnt able to patch the control panel so i just used the one from the drivers that are posted at the begining of the tut.
After i installed i rebooted and voila my problem with MAYA was gona.
Hope this will be of any use to someone and thaks to the author of the tutorial posted here,great job.
Cheers!


#46

Uh… Sorry, It was my mistake… I do everything properly, exept the patch :D:D:D:D
I’ve used Force Z1, and not T2 :smiley: SO now its good… I havent tried Maya yet, but when its going to be transparent, then there is firegl-unified-8.103.2 :smiley: Thanks Guys


#47

Hi it’s me again :smiley: When I install FireGL driver… everything works… except Maya :(:(:(:frowning:
Maya shut down with this:
Fatal Error… Attempting to save in… blahblah…
But when I put back Omega driver, and restart, then Maya works correctly… Should I try the other driver? Or what? But this driver is good for maya, becouse Silent_Den tried… Now what…

(I read the official Maya 6.5 manual, and there is, that the older driver is supported…)

PLS help meeee


#48

silent_dan - were you able to patch the ati2mtag.sy_ file from the 8.103.2 drivers? When I try to patch it with the scripts included with RivaTuner 2 RC15.4 i get errors:

Browsing for file ati2mtag.sys... compressed file selected
  Depacking ati2mtag.sy_... succeeded
  Browsing for file ati2mtag.sys... selected 6.14.10.6521, 970240 bytes
  Using native patch installation mode 0
  WARNING: Certified patch script not found, using common patch script...
  000930cd> matched sequence has been replaced
  8b 56 10 c1 e2 10 25 ff ff 00 00 03 d0 
  8b 56 10 c1 e2 10 25 ff ff ff ff 89 c2 
  00093122> matched sequence has been replaced
  8b 56 10 c1 e2 10 25 ff ff 00 00 03 d0 
  8b 56 10 c1 e2 10 25 ff ff ff ff 89 c2 
  0009ec26> matched sequence has been replaced
  85 c0 74 05 6a 05 58 eb 10 
  c6 45 0c 80 90 90 90 90 90 
  0009ef4d> matched sequence has been replaced
  81 f9 00 80 00 00 75 16 a9 00 00 00 08 
  81 f9 00 80 00 00 75 16 0d 00 00 00 08 
  000bf6b2> matched sequence has been replaced
  68 c0 03 00 00 ff b0 a8 00 00 00 e8 c2 45 f4 ff c1 e8 10 
  66 8b 40 04 90 90 90 90 90 90 90 90 90 90 90 90 90 90 90 
  000c08dd> matched sequence has been replaced
  83 f8 40 75 1d 66 81 bd 00 ff ff ff 02 10 75 12 0f b7 85 02 ff ff ff 
  0f b7 85 02 ff ff ff 66 25 f0 f0 66 0d 0b 0e 66 89 85 02 ff ff ff 90 
  000c091d> matched sequence has been replaced
  8a 85 08 ff ff ff 
  b0 80 90 90 90 90 
  000df045> matched sequence has been replaced
  c1 e8 10 3b 46 10 74 
  c1 e8 10 3b 46 10 eb 
  ERROR: Target sequence must be replaced 2 time(s)!
  81 f9 00 80 00 00 0f 85 00 00 00 00 a9 00 00 00 08
 

Also, the Control Panel in the new unified drivers shoud install without any patching.

paydogs - double check if everything works. In display properties > settings > advanced > adapter you should have chip type and adapter string listed as FireGL, and the firegl control panel should be visible. If it is, go into configuration tab, select “Maya” configuration profile from the list and check that OpenGL hardware acceleration is on.


#49

Hey fellas!
Regarding the new drivers,i take back everything i said beffore.It must have been some kind off mistake on riva tuner part.Cause it said that those new drivers were patched correctly but after a day they stoped working correctly so dont trie those drivers.Ill stick with
“firegl-unified-8.083” drivers for now.Maya is still acting funny on my side to,every viewport works fine but in the perspective viewport my geometry is almoust translucent.
So i apologize for missleading people here,ill recomend everyone to stick with the tutorial.
I anyone finds a workarround for Maya please post solution.
Cheers!


#50

OK, now everything works… I don’t know, what was the matter, I’ve do it again (the whole process), and now it’s working… And not translucent… Thanks folks


#51

Let’s here it for the Ultimatebadass!!! All the help your dealing out is awesome.

I’ve been pretty disappointed with the way my Radeon 800 is running maya, so I’ll definately give this a shot.

Thanks!
m :slight_smile:


#52

Any Link on softmodding Nvidia cards like 6600GT to a Quadro FX


#53

Morlockis - hope it works for you

alvin777 - you might want to take a looks at guru3d forums in the riva tuner section


#54

Will this softmod work on a mobility radeon 9600?


#55

Tecton3d - I doubt, since it’s a different chip than the normal 9600.


#56

Ultimatebadass… thanks for the info


#57

I’m running the latest Catatlyst drivers and it won’t let me install the version you recommend for this mod.

It says “missing required hardware and/or software to install” and kicks me out. I have the Radeon 800.

Am I missing something?

thx,
m


#58

Morlockis - If you have the X800 you need to mod the drivers for FireGL X3 before installing them. Follow the step by step guide and you should have no problems :slight_smile:


#59

Exactly. My wannabe-FireGL X3 is working great! :wink:


#60

Hi UB,

I had a few questions, if you don’t mind. There were a few oddities for me in the process, and I’m not sure whether it’s setup properly. Everything works, but I’m not seeing anything about FireXL in my display panel, except that the adatper is listed as a FireXL 3X - 256.

A few things that didn’t go according to the plan:

  1. My Device ID had all 4 numbers different than what was listed in the .ini (I changed all 4 numbers)

  2. In the .ini there were 2 listings of the FireX3-256, which were the exact same. I changed all 4 digits of all three (including secondary) to my device ID.

  3. When I install the CPanel the modify option doesn’t give me a list of options, it just installs a bunch of stuff. I get a TV display dialog box when I reboot. But I don’t see anything that specifically says FireXL. However, I found a setting in the display options for Maya. I selected that profile.

Anyway, let me know if there is any way to confirm that everything is cool.

Thanks again,
mo